FlowframTk is subject to the GNU General Public License. See the file LICENSE for details.

DOCUMENTATION IS PROVIDED “AS IS” AND ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH DISCLAIMERS ARE HELD TO BE LEGALLY INVALID.

This document is a user manual for FlowframTk. For information about Jdrview or jdrutils, see jdrview.pdf or jdrutils.pdf, respectively.

The latest version can be downloaded from http://www.dickimaw-books.com/software/flowframtk/

Occasionally the canvas doesn’t get redrawn correctly. To force a redraw, use F11.
## Contents

1 Introduction .................................................. 1  
   1.1 Installation .............................................. 2  

2 Accessibility .................................................. 3  

3 Settings ....................................................... 8  
   3.1 Command Line Arguments .................................. 8  
   3.2 The Settings Menu ........................................ 9  
      3.2.1 Styles ............................................... 11  
      3.2.2 Show Rulers ......................................... 11  
      3.2.3 Grid ................................................ 11  
      3.2.4 Zoom ............................................... 12  
      3.2.5 Paper .............................................. 12  
      3.2.6 Image Settings Dialog .............................. 14  
      3.2.7 TeX Settings Dialog ................................ 19  
      3.2.8 User Interface Settings Dialog .................... 28  
   3.3 Configuration Directory ................................. 42  

4 The Basics .................................................... 45  
   4.1 The Canvas ............................................... 45  
   4.2 The Toolbars ............................................. 46  
   4.3 The Rulers ............................................... 46  
   4.4 The Status Bar .......................................... 46  

5 The File Menu ................................................ 48  
   5.1 New ....................................................... 48  
   5.2 Open ...................................................... 48  
   5.3 Recent Files ............................................. 48  
   5.4 Image Description ....................................... 50  
   5.5 Save and Save As ....................................... 50  
   5.6 Export .................................................... 50  
      5.6.1 Export to PNG ....................................... 51  
      5.6.2 Export to a Class or Package ....................... 51  
      5.6.3 Export to PGF ....................................... 52  
      5.6.4 Export to Single-Paged Document .................. 52  
   5.7 Print ...................................................... 55  
   5.8 Message Window ......................................... 55  
   5.9 Close ..................................................... 55  
   5.10 Quit ..................................................... 56  

6 Creating New Objects ...................................... 57  
   6.1 Line Paths ............................................... 59  
   6.2 Curve Paths ............................................. 59  
   6.3 Rectangles ............................................... 60  
   6.4 Ellipses ................................................. 61  
   6.5 Text ..................................................... 61
# CONTENTS

## 7 Bitmaps

7.1 Properties .............................................. 67

## 8 Selecting and Editing Objects

8.1 Moving an Object ...................................... 71
8.2 Cut ...................................................... 72
8.3 Copy ..................................................... 72
8.4 Paste .................................................... 72
8.5 Object Description ...................................... 72
8.6 Editing Control Points ................................ 73
8.7 Symmetric Shapes ....................................... 78
8.8 Editing Text Areas ...................................... 80
8.9 Combining a Text Area and Path to Form a Text-Path .... 84
8.10 Text Outlines .......................................... 86
8.11 Reducing to Grey Scale ................................ 86
8.12 Colour Space Conversions .............................. 88
8.13 Fade ..................................................... 88
8.14 Removing Translucency ................................ 88
8.15 Moving an Object Up or Down the Stacking Order .... 89
8.16 Rotating Objects ....................................... 90
8.17 Scaling Objects ........................................ 93
8.18 Shearing Objects ....................................... 94
8.19 Distorting Shapes ...................................... 99
8.20 Grouping and Ungrouping Objects ..................... 99
8.21 Aligning Objects ...................................... 101
8.22 Reversing a Path’s Direction .......................... 103
8.23 Merging Paths .......................................... 103
8.24 Path Union .............................................. 108
8.25 Exclusive Or Function ................................ 109
8.26 Path Intersection ...................................... 112
8.27 Path Subtraction ...................................... 113
8.28 Separating a Text-Path into a Text Area and Path ... 114
8.29 Converting a Path or Text-Path into a Pattern ...... 114
8.30 Converting to a Path ................................... 122
  8.30.1 Converting a Text Area, Text-Path or Pattern to a Path  122
  8.30.2 Converting an Outline to a Path .................. 122
8.31 Splitting Text Areas ................................... 124

## 9 Path and Text Styles

9.1 Line Colour ............................................. 126
9.2 Fill Colour .............................................. 127
9.3 Line Style .............................................. 128
  9.3.1 Line Thickness (or Pen Width) ....................... 128
  9.3.2 Dash Pattern ....................................... 128
  9.3.3 Cap Style ........................................... 128
  9.3.4 Join Style .......................................... 129
  9.3.5 Markers ............................................. 129
  9.3.6 Winding Rule ...................................... 137
9.4 Text Colour ............................................. 138
9.5 Text Style .............................................. 139
# List of Tables

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1</td>
<td>Keyboard Accelerators and Menu Mnemonics</td>
<td>3</td>
</tr>
<tr>
<td>2.2</td>
<td>JavaHelp Viewer Shortcut Keys</td>
<td>6</td>
</tr>
<tr>
<td>3.1</td>
<td>Paper Size Identifiers</td>
<td>10</td>
</tr>
<tr>
<td>3.2</td>
<td>Available Values for the Normal Font Size</td>
<td>20</td>
</tr>
<tr>
<td>3.3</td>
<td>Hotspot Functions</td>
<td>30</td>
</tr>
<tr>
<td>9.1</td>
<td>Available Marker Styles and Dependencies for Arrow Style Markers</td>
<td>130</td>
</tr>
<tr>
<td>9.2</td>
<td>Available Marker Styles and Dependencies for Partial Arrow StyleMarkers</td>
<td>131</td>
</tr>
<tr>
<td>9.3</td>
<td>Available Marker Styles and Dependencies for Data Point Style Markers</td>
<td>133</td>
</tr>
<tr>
<td>9.4</td>
<td>Available Marker Styles and Dependencies for Bracket Style Markers</td>
<td>134</td>
</tr>
<tr>
<td>9.5</td>
<td>Available Marker Styles and Dependencies for Cap Style Markers</td>
<td>131</td>
</tr>
<tr>
<td>9.6</td>
<td>Available Marker Styles and Dependencies for Decorative Markers</td>
<td>135</td>
</tr>
<tr>
<td>A.1</td>
<td>Available Colour Types</td>
<td>260</td>
</tr>
<tr>
<td>A.2</td>
<td>Tool Identifiers</td>
<td>262</td>
</tr>
<tr>
<td>A.3</td>
<td>Paper Size Identifiers</td>
<td>263</td>
</tr>
<tr>
<td>A.4</td>
<td>Additional Paper Size Identifiers (JDR v1.3 onwards)</td>
<td>264</td>
</tr>
<tr>
<td>A.5</td>
<td>Marker IDs</td>
<td>271</td>
</tr>
<tr>
<td>A.6</td>
<td>Additional Marker IDs (JDR 1.4)</td>
<td>271</td>
</tr>
<tr>
<td>A.7</td>
<td>Additional Marker IDs (JDR 1.6)</td>
<td>272</td>
</tr>
</tbody>
</table>
# List of Figures

3.1 **Available Regular Grids** ........................................ 13  
3.2 **Tschichold Grid** .................................................. 14  
3.3 **Configuration Dialog Box (Control Point Settings)** ............... 15  
3.4 **Configuration Dialog Box (Startup Directory Settings)** ......... 15  
3.5 **Configuration Dialog Box (JDR/AJR Settings)** ................... 16  
3.6 **Configuration Dialog Box (Startup Settings)** ................... 17  
3.7 **Configuration Dialog Box (Bitmap Settings)** ................... 18  
3.8 **Configuration Dialog Box (Application Paths)** .................. 18  
3.9 **Setting the Normal Font Size and (optionally) the Class** ....... 19  
3.10 **Flowframe Settings Tab** ......................................... 21  
3.11 **LaTeX-Related Text Settings** .................................... 22  
3.12 **LaTeX-Related Text Settings — Maths-Mode Mappings** ........... 24  
3.13 **Adding a New Text Mapping** ...................................... 25  
3.14 **Symbol Lookup Script** ........................................... 26  
3.15 **Default Preamble Code** ........................................... 28  
3.16 **Configuration UI Dialog Box (Graphics Settings)** ............... 29  
3.17 **Hotspots** .......................................................... 30  
3.18 **Configuration UI Dialog Box (Annotations Settings)** ............ 31  
3.19 **Configuration UI Dialog Box (Language Settings)** .............. 32  
3.20 **Configuration UI Dialog Box (Accelerators)** .................... 34  
3.21 **Changing a keyboard shortcut** ................................... 35  
3.22 **Configuration UI Dialog Box (Toolbar, Ruler and Status Bar Settings)** 36  
3.23 **Configuration UI Dialog Box (Normalization)** .................. 37  
3.24 **Configuration UI Dialog Box (TeX Editor Settings)** ............ 38  
3.25 **Configuration UI Dialog Box (Look and Feel Settings)** ......... 40  
3.26 **Look and Feel Examples** .......................................... 41  
3.27 **Dialog Buttons with Small Icons and Trailing Text** .............. 43  
4.1 **The Main Window** .................................................. 45  
4.2 **The Status Bar** .................................................... 46  
4.3 **The Information Dialog** ........................................... 47  
5.1 **Drag and Drop onto FlowframTk’s Internal Desktop** .............. 49  
5.2 **Export to PNG Settings** ........................................... 51  
5.3 **Exported Text Areas Can Overflow Bounding Box** ................ 54  
5.4 **Confirm Discard Dialog (1 Modified Image)** ..................... 55  
5.5 **Confirm Discard Dialog (2 Modified Images)** .................... 56  
6.1 **Path Attributes Are Only Set Once the Path is Completed** ....... 58  
6.2 **Go To Co-ordinate Dialog Box** ................................... 58  
6.3 **Text Area Construction Field** .................................... 62  
6.4 **Drag and Drop Text** ................................................ 64  
6.5 **Text Area Popup Menu** ............................................. 65  
6.6 **Insert Symbol Dialog Box** ........................................ 65  
6.7 **Package Required by Mapping Added to the Early Preamble** ...... 65
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.1</td>
<td>Bitmaps Are Displayed in Draft Mode When There Is Insufficient Memory in the JRE</td>
<td>68</td>
</tr>
<tr>
<td>7.2</td>
<td>Bitmap Properties Dialog</td>
<td>68</td>
</tr>
<tr>
<td>8.1</td>
<td>Popup Menus in Select Mode Depend on What Objects Have Been Selected</td>
<td>71</td>
</tr>
<tr>
<td>8.2</td>
<td>Move Selected Objects Dialog Box</td>
<td>72</td>
</tr>
<tr>
<td>8.3</td>
<td>Setting an Object’s Description</td>
<td>73</td>
</tr>
<tr>
<td>8.4</td>
<td>Making the Join Between Segments Continuous</td>
<td>76</td>
</tr>
<tr>
<td>8.5</td>
<td>Continuity Anchor</td>
<td>76</td>
</tr>
<tr>
<td>8.6</td>
<td>Opening a Path</td>
<td>77</td>
</tr>
<tr>
<td>8.7</td>
<td>Closing a Path</td>
<td>77</td>
</tr>
<tr>
<td>8.8</td>
<td>Symmetric Path with Gaps</td>
<td>79</td>
</tr>
<tr>
<td>8.9</td>
<td>Adding Symmetry to a Path</td>
<td>81</td>
</tr>
<tr>
<td>8.10</td>
<td>Closed Symmetric Path</td>
<td>82</td>
</tr>
<tr>
<td>8.11</td>
<td>Edit Text Dialog Box</td>
<td>83</td>
</tr>
<tr>
<td>8.12</td>
<td>Combining a Text Area and Path to Form a Text-Path</td>
<td>85</td>
</tr>
<tr>
<td>8.13</td>
<td>Symmetric Text-Paths</td>
<td>87</td>
</tr>
<tr>
<td>8.14</td>
<td>Text Outline</td>
<td>87</td>
</tr>
<tr>
<td>8.15</td>
<td>Removing Translucency</td>
<td>89</td>
</tr>
<tr>
<td>8.16</td>
<td>Stacking Order</td>
<td>90</td>
</tr>
<tr>
<td>8.17</td>
<td>Three Selected Objects Rotated by 90 Degrees</td>
<td>91</td>
</tr>
<tr>
<td>8.18</td>
<td>A Group Consisting of Three Objects Rotated by 90 Degrees</td>
<td>91</td>
</tr>
<tr>
<td>8.19</td>
<td>Rotating a Text-Path</td>
<td>92</td>
</tr>
<tr>
<td>8.20</td>
<td>Three Selected Objects Scaled by a Factor of 2</td>
<td>93</td>
</tr>
<tr>
<td>8.21</td>
<td>A Group Consisting of Three Objects Scaled by a Factor of 2</td>
<td>94</td>
</tr>
<tr>
<td>8.22</td>
<td>Scaling a Text-Path</td>
<td>95</td>
</tr>
<tr>
<td>8.23</td>
<td>Two Selected Objects Sheared Horizontally</td>
<td>96</td>
</tr>
<tr>
<td>8.24</td>
<td>A Group Consisting of Two Objects Sheared Horizontally</td>
<td>96</td>
</tr>
<tr>
<td>8.25</td>
<td>Shearing a Text-Path</td>
<td>97</td>
</tr>
<tr>
<td>8.26</td>
<td>Shearing a Pattern</td>
<td>98</td>
</tr>
<tr>
<td>8.27</td>
<td>Distorting a Path</td>
<td>100</td>
</tr>
<tr>
<td>8.28</td>
<td>Aligning a Group Consisting of Three Objects</td>
<td>102</td>
</tr>
<tr>
<td>8.29</td>
<td>Aligning a Wider Object Relative to a Thinner Object</td>
<td>104</td>
</tr>
<tr>
<td>8.30</td>
<td>Reversing the Direction of a Path</td>
<td>105</td>
</tr>
<tr>
<td>8.31</td>
<td>Reversing the Direction of a Text-Path</td>
<td>105</td>
</tr>
<tr>
<td>8.32</td>
<td>Merging Two Paths</td>
<td>105</td>
</tr>
<tr>
<td>8.33</td>
<td>Merging Two Text-Paths</td>
<td>106</td>
</tr>
<tr>
<td>8.34</td>
<td>Paths Are Merged According to the Stacking Order</td>
<td>107</td>
</tr>
<tr>
<td>8.35</td>
<td>Path Union</td>
<td>108</td>
</tr>
<tr>
<td>8.36</td>
<td>Text-Path Union</td>
<td>109</td>
</tr>
<tr>
<td>8.37</td>
<td>Pattern Union</td>
<td>110</td>
</tr>
<tr>
<td>8.38</td>
<td>Exclusive OR Function</td>
<td>111</td>
</tr>
<tr>
<td>8.39</td>
<td>Path Intersection Function</td>
<td>112</td>
</tr>
<tr>
<td>8.40</td>
<td>Path Subtraction Function</td>
<td>113</td>
</tr>
<tr>
<td>8.41</td>
<td>Subtracting From a Text-Path</td>
<td>113</td>
</tr>
<tr>
<td>8.42</td>
<td>Separating the Text and Path from a Text-Path</td>
<td>115</td>
</tr>
<tr>
<td>8.43</td>
<td>Separating the Text and Path from an Outline Text-Path</td>
<td>116</td>
</tr>
<tr>
<td>8.44</td>
<td>A Rotational Pattern</td>
<td>117</td>
</tr>
<tr>
<td>8.45</td>
<td>A Scaled Pattern</td>
<td>118</td>
</tr>
<tr>
<td>Figure</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------</td>
<td>------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>8.46</td>
<td>A Spiral Pattern</td>
<td>119</td>
</tr>
<tr>
<td>8.47</td>
<td>Patterns Can Either be Single or Multi-Mode</td>
<td>120</td>
</tr>
<tr>
<td>8.48</td>
<td>Text-Path Patterns</td>
<td>121</td>
</tr>
<tr>
<td>8.49</td>
<td>Converting a Text Area to a Path</td>
<td>122</td>
</tr>
<tr>
<td>8.50</td>
<td>Converting an Outline to a Path</td>
<td>123</td>
</tr>
<tr>
<td>8.51</td>
<td>Splitting a Text Area</td>
<td>124</td>
</tr>
<tr>
<td>8.52</td>
<td>Splitting a Text Path</td>
<td>125</td>
</tr>
<tr>
<td>9.1</td>
<td>Example Dash Patterns</td>
<td>128</td>
</tr>
<tr>
<td>9.2</td>
<td>Cap Styles</td>
<td>129</td>
</tr>
<tr>
<td>9.3</td>
<td>The Cap Style Is Affected by Whether the Path Is Open or Closed</td>
<td>129</td>
</tr>
<tr>
<td>9.4</td>
<td>Join Styles</td>
<td>130</td>
</tr>
<tr>
<td>9.5</td>
<td>Repeat Markers</td>
<td>134</td>
</tr>
<tr>
<td>9.6</td>
<td>Repeat Markers Are Placed Along the Gradient Vector</td>
<td>134</td>
</tr>
<tr>
<td>9.7</td>
<td>Reversed Markers</td>
<td>135</td>
</tr>
<tr>
<td>9.8</td>
<td>Examples of Composite Markers</td>
<td>136</td>
</tr>
<tr>
<td>9.9</td>
<td>Disabling the Marker Auto Offset</td>
<td>137</td>
</tr>
<tr>
<td>9.10</td>
<td>Changing a Marker’s Offset Moves It Along the Gradient Vector</td>
<td>137</td>
</tr>
<tr>
<td>9.11</td>
<td>Repeat Gap</td>
<td>137</td>
</tr>
<tr>
<td>9.12</td>
<td>Marker Colour May Be Independent of the Line Colour</td>
<td>138</td>
</tr>
<tr>
<td>9.13</td>
<td>Primary and Secondary Markers are Independent</td>
<td>138</td>
</tr>
<tr>
<td>9.14</td>
<td>Winding Rules</td>
<td>138</td>
</tr>
<tr>
<td>9.15</td>
<td>Setting the Font Family</td>
<td>139</td>
</tr>
<tr>
<td>9.16</td>
<td>Setting the Font Size</td>
<td>141</td>
</tr>
<tr>
<td>9.17</td>
<td>Setting the Font Series</td>
<td>141</td>
</tr>
<tr>
<td>9.18</td>
<td>Setting the Font Shape</td>
<td>142</td>
</tr>
<tr>
<td>9.19</td>
<td>Text-Path Transformation Matrix</td>
<td>144</td>
</tr>
<tr>
<td>9.20</td>
<td>The Effect of Converting from Java Fonts to TeX Fonts</td>
<td>145</td>
</tr>
<tr>
<td>9.21</td>
<td>The Font Used by the LaTeX Document may Result in Considerable Differences from the Original Image</td>
<td>145</td>
</tr>
<tr>
<td>9.22</td>
<td>Text Area Containing Maths</td>
<td>146</td>
</tr>
<tr>
<td>9.23</td>
<td>The Text Area’s Transformation Matrix Will Also Be Applied to the Anchor</td>
<td>147</td>
</tr>
<tr>
<td>10.1</td>
<td>The Preamble Panel</td>
<td>151</td>
</tr>
<tr>
<td>10.2</td>
<td>The Late-Preamble Tab</td>
<td>152</td>
</tr>
<tr>
<td>10.3</td>
<td>Parshape (Using Outline)</td>
<td>154</td>
</tr>
<tr>
<td>10.4</td>
<td>Parshape (Using Path)</td>
<td>154</td>
</tr>
<tr>
<td>10.5</td>
<td>Shapepar Example</td>
<td>156</td>
</tr>
<tr>
<td>10.6</td>
<td>Setting the Typeblock</td>
<td>160</td>
</tr>
<tr>
<td>10.7</td>
<td>The typeblock is shown as a light grey rectangle</td>
<td>161</td>
</tr>
<tr>
<td>10.8</td>
<td>Frame Attributes Dialog Box</td>
<td>162</td>
</tr>
<tr>
<td>10.9</td>
<td>Layout Containing Six Circles</td>
<td>166</td>
</tr>
<tr>
<td>10.10</td>
<td>The Effects of Too Much and Too Little Text</td>
<td>166</td>
</tr>
<tr>
<td>11.1</td>
<td>House Example—Creating a Rectangle</td>
<td>169</td>
</tr>
<tr>
<td>11.2</td>
<td>House Example—Creating a Triangle</td>
<td>169</td>
</tr>
<tr>
<td>11.3</td>
<td>House Example — Completed Image</td>
<td>170</td>
</tr>
<tr>
<td>11.4</td>
<td>House Example — Saving the Image</td>
<td>170</td>
</tr>
<tr>
<td>11.5</td>
<td>House Example—Exporting the Image to a LaTeX File</td>
<td>170</td>
</tr>
</tbody>
</table>
### LIST OF FIGURES

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.6</td>
<td>Lettuce on Toast Example — Brown Rectangle</td>
<td>171</td>
</tr>
<tr>
<td>11.7</td>
<td>Lettuce on Toast Example — Editing the Rectangle</td>
<td>171</td>
</tr>
<tr>
<td>11.8</td>
<td>Lettuce on Toast Example — Converting the Top Segment to a Curve</td>
<td>172</td>
</tr>
<tr>
<td>11.9</td>
<td>Lettuce on Toast Example — Finish Editing the Curve</td>
<td>172</td>
</tr>
<tr>
<td>11.10</td>
<td>Lettuce on Toast Example — Adding a Closed Curve Path</td>
<td>173</td>
</tr>
<tr>
<td>11.11</td>
<td>Lettuce on Toast Example — Completed Image</td>
<td>173</td>
</tr>
<tr>
<td>11.12</td>
<td>Cheese and Lettuce on Toast Example — A Filled Rectangle</td>
<td>174</td>
</tr>
<tr>
<td>11.13</td>
<td>Cheese and Lettuce on Toast Example — Adding Ellipses</td>
<td>174</td>
</tr>
<tr>
<td>11.14</td>
<td>Cheese and Lettuce on Toast Example — Merging Paths</td>
<td>174</td>
</tr>
<tr>
<td>11.15</td>
<td>Cheese and Lettuce on Toast Example — Completed Image</td>
<td>175</td>
</tr>
<tr>
<td>11.16</td>
<td>Artificial Neuron Example — Adding a Rectangle</td>
<td>175</td>
</tr>
<tr>
<td>11.17</td>
<td>Artificial Neuron Example — Adding a Circle</td>
<td>175</td>
</tr>
<tr>
<td>11.18</td>
<td>Artificial Neuron Example — Creating a Sigmoidal Curve</td>
<td>176</td>
</tr>
<tr>
<td>11.19</td>
<td>Artificial Neuron Example — Setting the Current Line Style</td>
<td>176</td>
</tr>
<tr>
<td>11.20</td>
<td>Artificial Neuron Example — End Marker Dialog Box</td>
<td>177</td>
</tr>
<tr>
<td>11.21</td>
<td>Artificial Neuron Example — Adding Arrows</td>
<td>177</td>
</tr>
<tr>
<td>11.22</td>
<td>Artificial Neuron Example — Adding Text</td>
<td>177</td>
</tr>
<tr>
<td>11.23</td>
<td>Artificial Neuron Example — Editing Text</td>
<td>178</td>
</tr>
<tr>
<td>11.24</td>
<td>Artificial Neuron Example — Insert Symbol Dialog Box</td>
<td>178</td>
</tr>
<tr>
<td>11.25</td>
<td>Artificial Neuron Example — Setting the Font Style</td>
<td>178</td>
</tr>
<tr>
<td>11.26</td>
<td>Artificial Neuron Example — Setting the Equivalent LaTeX Symbol</td>
<td>179</td>
</tr>
<tr>
<td>11.27</td>
<td>Artificial Neuron Example — Justifying Objects</td>
<td>179</td>
</tr>
<tr>
<td>11.28</td>
<td>Artificial Neuron Example — Image as it Appears in a \LaTeX Document</td>
<td>180</td>
</tr>
<tr>
<td>11.29</td>
<td>Bus Example — Setting the Normal Font Size</td>
<td>181</td>
</tr>
<tr>
<td>11.30</td>
<td>Bus Example — Create a Circle</td>
<td>181</td>
</tr>
<tr>
<td>11.31</td>
<td>Bus Example — Editing the Path</td>
<td>181</td>
</tr>
<tr>
<td>11.32</td>
<td>Bus Example — Break the Path</td>
<td>182</td>
</tr>
<tr>
<td>11.33</td>
<td>Bus Example — Move and Rotate Top Semi-Circle</td>
<td>182</td>
</tr>
<tr>
<td>11.34</td>
<td>Bus Example — Adding Lines</td>
<td>182</td>
</tr>
<tr>
<td>11.35</td>
<td>Bus Example — Convert Line Segment to a Curve</td>
<td>183</td>
</tr>
<tr>
<td>11.36</td>
<td>Bus Example — Add Windows</td>
<td>183</td>
</tr>
<tr>
<td>11.37</td>
<td>Bus Example — Subtract Windows from Bus Outline and Set Fill Colour</td>
<td>184</td>
</tr>
<tr>
<td>11.38</td>
<td>Bus Example — Resulting Shaped Paragraph</td>
<td>184</td>
</tr>
<tr>
<td>11.39</td>
<td>Poster Example — The Typeblock</td>
<td>185</td>
</tr>
<tr>
<td>11.40</td>
<td>Poster Example — Adding Rectangles</td>
<td>186</td>
</tr>
<tr>
<td>11.41</td>
<td>Poster Example — Adding a Bitmap</td>
<td>187</td>
</tr>
<tr>
<td>11.42</td>
<td>Poster Example — Adding Some Colour</td>
<td>187</td>
</tr>
<tr>
<td>11.43</td>
<td>Poster Example — Assigning Frame Information</td>
<td>188</td>
</tr>
<tr>
<td>11.44</td>
<td>Poster Example — Adding Contents to a Static Frame</td>
<td>188</td>
</tr>
<tr>
<td>11.45</td>
<td>Poster Example — Frame Information Assigned</td>
<td>189</td>
</tr>
<tr>
<td>11.46</td>
<td>Poster Example — Adding Preamble Information</td>
<td>190</td>
</tr>
<tr>
<td>11.47</td>
<td>Poster Example — Export Frame Information to a \LaTeX Package</td>
<td>191</td>
</tr>
<tr>
<td>11.48</td>
<td>Poster Example — Final Document</td>
<td>192</td>
</tr>
<tr>
<td>11.49</td>
<td>Newspaper Example — Setting the \LaTeX Normal Font Size</td>
<td>193</td>
</tr>
<tr>
<td>11.50</td>
<td>Newspaper Example — Setting the Grid</td>
<td>193</td>
</tr>
<tr>
<td>11.51</td>
<td>Newspaper Example — Setting the Storage Unit</td>
<td>193</td>
</tr>
<tr>
<td>11.52</td>
<td>Newspaper Example — Setting the Typeblock</td>
<td>194</td>
</tr>
<tr>
<td>11.53</td>
<td>Newspaper Example — Title Frame</td>
<td>195</td>
</tr>
</tbody>
</table>
LIST OF FIGURES

11.54 Newspaper Example—Assigning Flowframe Data to Title Frame . 196
11.55 Newspaper Example—Left and Right Heading Frames Added . 197
11.56 Newspaper Example—Assigning Flowframe Data to Left Heading Frame . 197
11.57 Newspaper Example—Added L Shaped Frame . 198
11.58 Newspaper Example—Assigning Flowframe Data to L Shaped Frame . 199
11.59 Newspaper Example—Added Image . 200
11.60 Newspaper Example—Assigning Flowframe Data to Bitmap . 200
11.61 Newspaper Example—Added Right Hand Polygon . 201
11.62 Newspaper Example—Assigning Flowframe Data to Right Hand Polygon . 202
11.63 Newspaper Example—Added L Shaped Divider . 203
11.64 Newspaper Example—Assigning Flowframe Data to L Shaped Divider . 203
11.65 Newspaper Example—Added Horizontal Divider . 204
11.66 Newspaper Example—Assigning Flowframe Data to Horizontal Divider . 204
11.67 Newspaper Example—Added Lower Header . 205
11.68 Newspaper Example—Assigning Flowframe Data to Lower Header . 205
11.69 Newspaper Example—Added Lower Left and Right Rectangles . 206
11.70 Newspaper Example—Assigning Flowframe Data to Lower Left Rectangle . 207
11.71 Newspaper Example—Added Sheep Bitmap . 208
11.72 Newspaper Example—Assigning Flowframe Data to Sheep Bitmap . 208
11.73 Newspaper Example—Added Polygon Defining Text Region . 209
11.74 Newspaper Example—Computing Parshape Parameters . 209
11.75 Newspaper Example—Setting the Early Preamble Code . 210
11.76 Newspaper Example—Setting the Late Preamble Code . 211
11.77 Newspaper Example—Constructing the Footer Frame . 212
11.78 Newspaper Example—Assigning the Footer Frame Data . 213
11.79 Newspaper Example—Final Document . 214
11.80 The Normal Font Size Setting Affects Paragraph Shapes . 216
11.81 Brochure Example—Setting the Grid . 216
11.82 Brochure Example—Setting the Normal Font Size . 216
11.83 Brochure Example—Setting the Storage Unit . 217
11.84 Brochure Example—Draw a Rectangle . 219
11.85 Brochure Example—Setting the Typeblock . 220
11.86 Brochure Example—Setting the Main Flow Frame . 220
11.87 Brochure Example—Draw a Circle . 221
11.88 Brochure Example—Change the Circle into an Arc . 222
11.89 Brochure Example—Move the Arc to the Bottom Right Corner . 223
11.90 Brochure Example—Apply a Fill Paint to the Arc . 224
11.91 Brochure Example—Setting The Odd Footer . 226
11.92 Brochure Example—Arc is Now an Odd Footer . 227
11.93 Brochure Example—Flipping the Duplicate Arc . 227
11.94 Brochure Example—Setting the Even Footer . 228
11.95 Brochure Example—Changing the Display Page . 228
11.96 Brochure Example—Even Pages Display . 229
11.97 Brochure Example—Moving the Even Footer . 230
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.98</td>
<td>Brochure Example — “all pages” display mode shows all objects in</td>
<td>231</td>
</tr>
<tr>
<td></td>
<td>their odd-page location.</td>
<td></td>
</tr>
<tr>
<td>11.99</td>
<td>Brochure Example — Adding a Closed Polygon</td>
<td>232</td>
</tr>
<tr>
<td>11.100</td>
<td>Brochure Example — Setting The Odd Header</td>
<td>233</td>
</tr>
<tr>
<td>11.101</td>
<td>Brochure Example — Create a Duplicate Polygon</td>
<td>234</td>
</tr>
<tr>
<td>11.102</td>
<td>Brochure Example — Setting the Even Header</td>
<td>235</td>
</tr>
<tr>
<td>11.103</td>
<td>Brochure Example — Even Pages Display (Two Objects Hidden)</td>
<td>236</td>
</tr>
<tr>
<td>11.104</td>
<td>Brochure Example — Move Even Header</td>
<td>237</td>
</tr>
<tr>
<td>11.105</td>
<td>Brochure Example — All Pages View Again (All Frames Shown in</td>
<td>238</td>
</tr>
<tr>
<td></td>
<td>their Odd Page Position)</td>
<td></td>
</tr>
<tr>
<td>11.106</td>
<td>Brochure Example — Double-Page Spread View of Brochure</td>
<td>239</td>
</tr>
<tr>
<td>11.107</td>
<td>No Mouse Example — Grid Settings Dialog Box</td>
<td>240</td>
</tr>
<tr>
<td>11.108</td>
<td>No Mouse Example — Storage Unit</td>
<td>240</td>
</tr>
<tr>
<td>11.109</td>
<td>No Mouse Example — Go To Co-Ordinate Dialog Box</td>
<td>241</td>
</tr>
<tr>
<td>11.110</td>
<td>No Mouse Example — Completed Rectangle</td>
<td>241</td>
</tr>
<tr>
<td>11.111</td>
<td>No Mouse Example — Set Fill Colour Dialog Box</td>
<td>242</td>
</tr>
<tr>
<td>11.112</td>
<td>No Mouse Example — Fill Colour Set</td>
<td>243</td>
</tr>
<tr>
<td>11.113</td>
<td>No Mouse Example — Completed Triangle</td>
<td>244</td>
</tr>
<tr>
<td>11.114</td>
<td>No Mouse Example — Triangle Fill Colour Set to Red</td>
<td>244</td>
</tr>
<tr>
<td>11.115</td>
<td>No Mouse Example — Windows Added</td>
<td>245</td>
</tr>
<tr>
<td>11.116</td>
<td>No Mouse Example — Window Fill Colour Set</td>
<td>246</td>
</tr>
<tr>
<td>11.117</td>
<td>No Mouse Example — Completed House</td>
<td>246</td>
</tr>
<tr>
<td>11.118</td>
<td>No Mouse Example — Move Dialog Box</td>
<td>246</td>
</tr>
<tr>
<td>11.119</td>
<td>No Mouse Example — Edit Mode</td>
<td>247</td>
</tr>
<tr>
<td>11.120</td>
<td>No Mouse Example — Edit Path Menu</td>
<td>248</td>
</tr>
<tr>
<td>11.121</td>
<td>No Mouse Example — Control Point Co-Ordinates Dialog Box</td>
<td>248</td>
</tr>
<tr>
<td>11.122</td>
<td>No Mouse Example — Editing Finished</td>
<td>248</td>
</tr>
<tr>
<td>11.123</td>
<td>No Mouse Example — Creating a New Text Area</td>
<td>249</td>
</tr>
<tr>
<td>11.124</td>
<td>No Mouse Example — Editing Text Area</td>
<td>249</td>
</tr>
<tr>
<td>11.125</td>
<td>No Mouse Example — Text is Now Centred</td>
<td>250</td>
</tr>
<tr>
<td>11.126</td>
<td>Selecting a Radial Grid</td>
<td>251</td>
</tr>
<tr>
<td>11.127</td>
<td>The Underlying Path</td>
<td>252</td>
</tr>
<tr>
<td>11.128</td>
<td>Give the Path Symmetry Using the Popup Menu</td>
<td>253</td>
</tr>
<tr>
<td>11.129</td>
<td>De-anchoring the End Control Using the Popup Menu</td>
<td>253</td>
</tr>
<tr>
<td>11.130</td>
<td>Move the Line of Symmetry</td>
<td>253</td>
</tr>
<tr>
<td>11.131</td>
<td>Add a Joining Curve Between the Underlying Path and its Reflection</td>
<td>253</td>
</tr>
<tr>
<td>11.132</td>
<td>Adjust the Curvature Control of the Join Segment</td>
<td>254</td>
</tr>
<tr>
<td>11.133</td>
<td>Change the Path Style</td>
<td>255</td>
</tr>
<tr>
<td>11.134</td>
<td>The Symmetric Path</td>
<td>256</td>
</tr>
<tr>
<td>11.135</td>
<td>Setting the Pattern</td>
<td>256</td>
</tr>
<tr>
<td>11.136</td>
<td>The Pattern</td>
<td>257</td>
</tr>
<tr>
<td>11.137</td>
<td>Move the Control Governing the Rotational Anchor</td>
<td>257</td>
</tr>
<tr>
<td>11.138</td>
<td>Add a Circle Around the Pattern</td>
<td>257</td>
</tr>
<tr>
<td>11.139</td>
<td>The Completed Lute Rose</td>
<td>257</td>
</tr>
</tbody>
</table>
1 Introduction

FlowframTk is a vector graphics application written in Java, with a graphical user interface (GUI). The main purpose of FlowframTk is to generate \LaTeX packages or classes that use the \texttt{flowfram} package, and to generate \texttt{pgf} picture drawing code. As a side-effect, it can also be used to generate \texttt{\parshape} and \texttt{\shapepar} or \texttt{\Shapepar} specifications. In order to run the application you must have the Java Runtime Environment (JRE) installed (at least version 1.8).

In FlowframTk, you can:

- construct shapes using line, move and cubic Bézier segments;
- edit paths by modifying the defining control points;
- incorporate text and bitmap images (for annotating and background effects);
- combine text and a path to form a text-along-path effect;
- apply replicas to a shape to form patterns;
- extract the parameters for \LaTeX's \texttt{\parshape} command and for the \texttt{\shapepar} (or \texttt{\Shapepar}) command defined in the \texttt{shapepar} package;
- construct frames for use with the \texttt{flowfram} package.

Pictures can be saved as or loaded from FlowframTk’s native JDR (binary) or AJR (ascii) file formats. Additionally, images can be exported as:

- a \LaTeX file containing a \texttt{pgfpicture} environment for inclusion in a \LaTeX document;
- a single-paged \LaTeX document containing the image (either just encapsulating the image or with the page set to the same size as the canvas);
- a \LaTeX package or class that loads the \texttt{flowfram} package;
- a PNG file;
- a PostScript file;
- a PDF file;
- A scalable vector graphics (SVG) file.

Note that the export to PS/PDF/SVG functions use external processes, such as \texttt{latex} and \texttt{dvips}. You can’t import back from the files you can export to.

The low-level pgf basic layer commands are used during exports to \LaTeX files. These commands aren’t particularly easy to read but are faster to compile than the higher-level commands that require extra processing to parse the syntax and perform additional calculations. The primary purpose of FlowframTk is to provide a graphical interface that can generate complicated code that’s hard to write manually.

\footnote{This application is a replacement for the now-obsolete Jpgfdraw (Java pgf-code generating drawing application). In fact, it’s actually just been renamed and the code refactored.}
FlowframTk was tested with version 3.0.0 of the pgf package, version 1.16 of the flowfram package and version 2.2 of the shapepar package. Files created by FlowframTk may not work with earlier versions of those packages. Note that some DVI viewers may not understand PGF specials. I strongly recommend that you read the user manuals for those packages.

Notation: a primary-click is a single click with the primary mouse button. This is typically the left button for a right-handed mouse, but may be the right button for a left-handed mouse. A menu-click is a click with the context-menu mouse button. This button depends on your configuration, but is typically the right button for a right-handed two-button mouse. If the button isn’t mentioned, a click can be assumed to mean a primary-click.

1.1 Installation

Ensure that you have the JRE installed. This can be downloaded from http://java.sun.com/j2se/. You must ensure that you use at least Java 7, as FlowframTk does not work with earlier versions.

To install, download the installer flowframtk-0.8.4-installer.jar and run it. This can be done from a terminal or command prompt using:

```
java -jar flowframtk-0.8.4-installer.jar
```

Depending on the setup of your operating system, you may also be able to double-click on the .jar file to run it.
2 Accessibility

Most of FlowframTk’s mouse functions can be emulated using the keyboard, however note that some systems do not allow applications to move the pointer, so keyboard functions that move the pointer are not guaranteed to work on every system. Keyboard accelerators and their menu mnemonic equivalents are listed in Table 2.1. These accelerators may be changed using the Accelerators Tab in the Configure User Interface window. In addition, there are also keyboard accelerators for the JavaHelp system. These are listed in Table 2.2 but are not configurable as far as I know. F10 switches the focus to the menu bar. The Enter key will usually be equivalent to the Okay button except when the focus is with a component that interprets Enter for some other purpose (such as a drop-down list), in which case you need to use Shift-Enter.

Within editable text fields, you can use Ctrl-A to select all the text, or Shift followed by the left or right arrow key to select a portion of the text. If some of the text has been selected, you can use Ctrl-C or Ctrl-X to copy or cut the text onto the clipboard, and you can use Ctrl-V to paste text from the clipboard into the text field.

Note that a few of the accelerators used by JpgfDraw have been changed in FlowframTk, as they caused a conflict. For example, Escape cancels a displayed menu, so if you use it to dismiss a menu while you had a path under construction, the entire path could be discarded, which is undesirable. Therefore the abandon path accelerator is now Shift-Escape. The F1 key is now only for the main manual help button. The help buttons in dialog windows and the preamble editor are activated with Shift-F1 and the help button is the status bar is activated with Ctrl-F1 (otherwise the main help button, preamble editor help button and status bar help button would conflict).

Table 2.1: Keyboard Accelerators and Menu Mnemonics

<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter</td>
<td>Finish current path/text area or</td>
<td>Alt-O F</td>
</tr>
<tr>
<td>Shift-Enter</td>
<td>Select Okay or Close button in dialog boxes</td>
<td></td>
</tr>
<tr>
<td>Shift-Escape</td>
<td>Abandon current path</td>
<td>Alt-O A</td>
</tr>
<tr>
<td>Escape</td>
<td>Select Cancel button in dialog boxes or close displayed menu</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Delete selected control point</td>
<td>F3 Alt-D</td>
</tr>
<tr>
<td>Backspace</td>
<td>Delete last segment (path construction mode)</td>
<td>F3 Alt-A</td>
</tr>
<tr>
<td>Insert</td>
<td>Add control point or</td>
<td>F3 Alt-I</td>
</tr>
<tr>
<td>Tab</td>
<td>Move focus to next focusable component</td>
<td></td>
</tr>
<tr>
<td>Space</td>
<td>Select component with current focus</td>
<td></td>
</tr>
<tr>
<td>PageUp</td>
<td>Scroll up by one screen full</td>
<td></td>
</tr>
<tr>
<td>PageDown</td>
<td>Scroll down by one screen full</td>
<td></td>
</tr>
</tbody>
</table>

† Functions that move the pointer

Continued on next page
### Table 2.1: Keyboard Accelerators and Menu Mnemonics (Continued)

<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-PageDown</td>
<td>If in a tabbed pane: &lt;br&gt;Move to the next tab &lt;br&gt;Otherwise: &lt;br&gt;Scroll right by one screen full</td>
<td></td>
</tr>
<tr>
<td>Ctrl-PageUp</td>
<td>If in a tabbed pane: &lt;br&gt;Move to the previous tab &lt;br&gt;Otherwise: &lt;br&gt;Scroll left by one screen full</td>
<td></td>
</tr>
<tr>
<td>Arrow Keys</td>
<td>If left mouse button pressed: &lt;br&gt;† move mouse by one pixel in given direction &lt;br&gt;Otherwise: &lt;br&gt;scroll by one tick mark in given direction</td>
<td></td>
</tr>
<tr>
<td>Home</td>
<td>Scroll to the top of the canvas</td>
<td>F5 Alt-N G</td>
</tr>
<tr>
<td>End</td>
<td>Scroll to the bottom of the canvas</td>
<td>F5 Alt-E N</td>
</tr>
<tr>
<td>Ctrl-Home</td>
<td>Scroll leftmost</td>
<td>Ctrl-End</td>
</tr>
<tr>
<td>Ctrl-End</td>
<td>Scroll rightmost</td>
<td>F10 Alt-E R</td>
</tr>
<tr>
<td>F1</td>
<td>Display Handbook</td>
<td>Ctrl-F1</td>
</tr>
<tr>
<td>F2</td>
<td>Show/hide grid</td>
<td>Ctrl-F11</td>
</tr>
<tr>
<td>F3</td>
<td>Show canvas popup menu (if available for current mode)</td>
<td>Shift-F2</td>
</tr>
<tr>
<td>F4</td>
<td>Emulate primary-click in construction mode</td>
<td>Shift-F5</td>
</tr>
<tr>
<td>F5</td>
<td>† Go to coordinate</td>
<td></td>
</tr>
<tr>
<td>F6</td>
<td>Select mode: &lt;br&gt;deselect the back-most selected object, and select next object in the stack &lt;br&gt;Edit mode: &lt;br&gt;select next control point</td>
<td></td>
</tr>
<tr>
<td>F7</td>
<td>Select mode: &lt;br&gt;Move selected objects &lt;br&gt;Edit mode: &lt;br&gt;Move selected control point</td>
<td></td>
</tr>
<tr>
<td>F8</td>
<td>Undo</td>
<td></td>
</tr>
<tr>
<td>F9</td>
<td>Redo</td>
<td></td>
</tr>
<tr>
<td>F10</td>
<td>Switch focus to menu bar</td>
<td></td>
</tr>
<tr>
<td>F11</td>
<td>Repaint canvas</td>
<td></td>
</tr>
<tr>
<td>Ctrl-F1</td>
<td>Display current tool help (status bar help button)</td>
<td></td>
</tr>
<tr>
<td>Ctrl-F11</td>
<td>Saves all images to configuration directory</td>
<td></td>
</tr>
<tr>
<td>Shift-F1</td>
<td>Display subject help (help buttons in dialog windows or preamble editor)</td>
<td></td>
</tr>
<tr>
<td>Shift-F2</td>
<td>Lock/unlock grid</td>
<td></td>
</tr>
<tr>
<td>Shift-F5</td>
<td>Select next object in the stack (from the front), and deselect all others</td>
<td></td>
</tr>
</tbody>
</table>

† Functions that move the pointer

Continued on next page
### Table 2.1: Keyboard Accelerators and Menu Mnemonics (Continued)

<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift-F6</td>
<td>Select mode:</td>
<td>Alt-N A</td>
</tr>
<tr>
<td></td>
<td>Add next object in the stack (from the front) to selection</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>select previous control point</td>
<td>F3 Alt-V</td>
</tr>
<tr>
<td>Shift-F7</td>
<td>† Find selected objects</td>
<td>Alt-N F</td>
</tr>
<tr>
<td>Shift-F11</td>
<td>Displays debugging information</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Shift-F11</td>
<td>Writes log file in the configuration directory</td>
<td></td>
</tr>
<tr>
<td>Alt-F4</td>
<td>Quit</td>
<td>Alt-F Q</td>
</tr>
<tr>
<td>Ctrl-A</td>
<td>Select all objects</td>
<td>Alt-E A</td>
</tr>
<tr>
<td>Ctrl-B</td>
<td>Move selected objects to the back</td>
<td>Alt-E B</td>
</tr>
<tr>
<td>Ctrl-C</td>
<td>Copy selected objects to clipboard</td>
<td>Alt-E C</td>
</tr>
<tr>
<td>Ctrl-D</td>
<td>Convert outline to a path</td>
<td>Alt-T C</td>
</tr>
<tr>
<td>Ctrl-E</td>
<td>Switch to ellipse tool</td>
<td>Alt-O E</td>
</tr>
<tr>
<td>Ctrl-F</td>
<td>Select mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Move selected objects to the front</td>
<td>Alt-E F</td>
</tr>
<tr>
<td></td>
<td>TeX editor:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Find text</td>
<td>Alt-S F</td>
</tr>
<tr>
<td>Ctrl-G</td>
<td>Select mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Group selected objects</td>
<td>Alt-T G</td>
</tr>
<tr>
<td></td>
<td>TeX editor:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Find again</td>
<td>Alt-S A</td>
</tr>
<tr>
<td>Ctrl-H</td>
<td>Select mode:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shear selected objects</td>
<td>Alt-T H</td>
</tr>
<tr>
<td></td>
<td>TeX editor:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Find and Replace text</td>
<td>Alt-S R</td>
</tr>
<tr>
<td>Ctrl-I</td>
<td>Edit selected path</td>
<td>Alt-E H E</td>
</tr>
<tr>
<td>Ctrl-J</td>
<td>Merge selected paths</td>
<td>Alt-T M</td>
</tr>
<tr>
<td>Ctrl-K</td>
<td>Switch to open curve tool</td>
<td>Alt-O C</td>
</tr>
<tr>
<td>Ctrl-L</td>
<td>Switch to open line tool</td>
<td>Alt-O L</td>
</tr>
<tr>
<td>Ctrl-M</td>
<td>Gap function</td>
<td>Alt-O G</td>
</tr>
<tr>
<td>Ctrl-N</td>
<td>New canvas</td>
<td>Alt-F N</td>
</tr>
<tr>
<td>Ctrl-O</td>
<td>Open JDR or AJR file</td>
<td>Alt-F O</td>
</tr>
<tr>
<td>Ctrl-P</td>
<td>Switch to select tool</td>
<td>Alt-O S</td>
</tr>
<tr>
<td>Ctrl-Q</td>
<td>Quit</td>
<td>Alt-F Q</td>
</tr>
<tr>
<td>Ctrl-R</td>
<td>Switch to rectangle tool</td>
<td>Alt-O R</td>
</tr>
<tr>
<td>Ctrl-S</td>
<td>Save current image</td>
<td>Alt-F S</td>
</tr>
<tr>
<td>Ctrl-T</td>
<td>Switch to text tool</td>
<td>Alt-O T</td>
</tr>
<tr>
<td>Ctrl-U</td>
<td>Ungroup selected groups</td>
<td>Alt-T U</td>
</tr>
<tr>
<td>Ctrl-V</td>
<td>Paste objects from clipboard</td>
<td>Alt-E P</td>
</tr>
<tr>
<td>Ctrl-W</td>
<td>Rotate selected objects</td>
<td>Alt-T R</td>
</tr>
<tr>
<td>Ctrl-X</td>
<td>Cut selected objects</td>
<td>Alt-E T</td>
</tr>
<tr>
<td>Ctrl-Y</td>
<td>Edit the selected paths’ line styles</td>
<td>Alt-E H S A</td>
</tr>
<tr>
<td>Ctrl-Z</td>
<td>Scale selected objects</td>
<td>Alt-T S</td>
</tr>
<tr>
<td>Ctrl+Shift-A</td>
<td>Deselect all</td>
<td>Alt-E D</td>
</tr>
</tbody>
</table>

† Functions that move the pointer

*Continued on next page*
Table 2.1: Keyboard Accelerators and Menu Mnemonics (Continued)

<table>
<thead>
<tr>
<th>Accelerator</th>
<th>Function</th>
<th>Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift-B</td>
<td>Move selected object down the stack</td>
<td>Alt-E W</td>
</tr>
<tr>
<td>Ctrl+Shift-F</td>
<td>Move selected object up the stack</td>
<td>Alt-E V</td>
</tr>
<tr>
<td>Ctrl+Shift-I</td>
<td>Edit selected text</td>
<td>Alt-E X E</td>
</tr>
<tr>
<td>Ctrl+Shift-K</td>
<td>Switch to closed curve tool</td>
<td>Alt-O U</td>
</tr>
<tr>
<td>Ctrl+Shift-L</td>
<td>Switch to closed line tool</td>
<td>Alt-O I</td>
</tr>
<tr>
<td>Ctrl+Shift-T</td>
<td>Switch to maths mode tool</td>
<td>Alt-O M</td>
</tr>
<tr>
<td>Alt-1 . . . Alt-8</td>
<td>Linear gradient paint direction selectors</td>
<td></td>
</tr>
<tr>
<td>Alt-1 . . . Alt-9</td>
<td>Radial gradient paint start location selectors</td>
<td></td>
</tr>
</tbody>
</table>

Table 2.2: JavaHelp Viewer Shortcut Keys

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-F1</td>
<td>Displays alternative text for the toolbar button that currently has the focus.</td>
</tr>
<tr>
<td>F6</td>
<td>Moves the focus between the navigation pane and content pane.</td>
</tr>
<tr>
<td>Tab</td>
<td>Traverses through the viewer.</td>
</tr>
<tr>
<td>Shift-Tab</td>
<td>Traverses backwards through the viewer.</td>
</tr>
<tr>
<td>Space</td>
<td>Activates the toolbar button with the current focus.</td>
</tr>
<tr>
<td>Ctrl-Space</td>
<td>Follows a link in the content pane.</td>
</tr>
<tr>
<td>F8</td>
<td>Selects the splitter bar between the navigator pane and the content pane.</td>
</tr>
<tr>
<td>Left/Right Arrow</td>
<td>If the splitter bar is selected:</td>
</tr>
<tr>
<td></td>
<td>Moves the splitter bar to the left/right</td>
</tr>
<tr>
<td></td>
<td>If in the navigator pane:</td>
</tr>
<tr>
<td></td>
<td>Moves to another navigator tab</td>
</tr>
<tr>
<td></td>
<td>If in the viewer’s toolbar:</td>
</tr>
<tr>
<td></td>
<td>Moves the focus to the next toolbar button</td>
</tr>
<tr>
<td></td>
<td>If in the content pane:</td>
</tr>
<tr>
<td></td>
<td>Moves one character to the left/right.</td>
</tr>
<tr>
<td>Up/Down Arrow</td>
<td>If the splitter bar is selected:</td>
</tr>
<tr>
<td></td>
<td>Moves the splitter bar to the left/right</td>
</tr>
<tr>
<td></td>
<td>If in the navigator pane:</td>
</tr>
<tr>
<td></td>
<td>Selects the previous/next item in the list</td>
</tr>
<tr>
<td></td>
<td>If in the content pane:</td>
</tr>
<tr>
<td></td>
<td>Moves the focus to the previous/next line.</td>
</tr>
<tr>
<td>Home</td>
<td>Selects the first item in the navigator list.</td>
</tr>
<tr>
<td>End</td>
<td>Selects the last item in the navigator list.</td>
</tr>
<tr>
<td>Ctrl-Home</td>
<td>Selects the first line in the content pane.</td>
</tr>
<tr>
<td>Ctrl-End</td>
<td>Selects the last line in the content pane.</td>
</tr>
<tr>
<td>Ctrl-T</td>
<td>Shifts focus to the next link in the content pane.</td>
</tr>
<tr>
<td>Ctrl+Shift-T</td>
<td>Shifts the focus to the previous link in the content pane.</td>
</tr>
</tbody>
</table>

See also:

- §3.2.8 User Interface Settings Dialog
• §8 Selecting and Editing Objects
• §6 Creating New Objects
• §11.9 Step-by-Step Example: A House With No Mouse
3  Settings

You can customise the appearance of FlowframTk’s main window either using the command line arguments or using the settings menu.

3.1  Command Line Arguments

FlowframTk can be invoked from a command prompt using:

    flowframtk (option-list) (filename 1) ... (filename N)

(You’ll need to add FlowframTk’s bin subdirectory to your PATH environment variable.)

Note that (option-list) and the filenames may be omitted. Each filename must be either a JDR or an AJR file. This script uses the environment variable JDR_JVMOPTS to pass options to the Java Virtual Machine (JVM). For example, if you want to run FlowframTk with a maximum size of 128Mb for the memory allocation pool, you can set JDR_JVMOPTS to -Xmx128m:

    setenv JDR_JVMOPTS -Xmx128m

The flowframtk script also uses the environment variable FLOWFRAMTK_OPTS to pass options to FlowframTk. For example, if you always want FlowframTk to start up with the grid showing, you can set FLOWFRAMTK_OPTS to -show_grid:

    setenv FLOWFRAMTK_OPTS -show_grid

Note that these environment variables only have an effect if you use the flowframtk script to run the JRE.

If you can’t use the flowframtk script, you can invoke FlowframTk from the command line using (no line breaks):

    java \{java options\} -jar flowframtk.jar \{flowframtk options\} \{filename\}

(You may need to include the full pathname to flowframtk.jar.)

The following options are provided:

- **disable_print**  Don’t request printer attributes on startup.
- **nodisable_print**  Request printer attributes on startup (default).
- **show_grid**  Show the grid.
- **noshow_grid**  Don’t show the grid.
- **grid_lock**  Set the grid lock on.
- **nogrid_lock**  Don’t set the grid lock.
- **toolbar**  Show the toolbars.

1If you have previously used Jpgfdraw, the JPGFDRAW_OPTS environment variable will also be recognised, but any settings in FLOWFRAMTK_OPTS will override those in JPGFDRAW_OPTS.
3.2 THE SETTINGS MENU

-`notoolbar` Don’t show the toolbars.
-`statusbar` Show the status bar.
-`nostatusbar` Don’t show the status bar.
-`rulers` Show the rulers.
-`norulers` Don’t show the rulers.
-`paper` Set the paper size. This option must be followed by a string identifying the paper size. Known paper sizes are listed in Table 3.1. Custom sizes can be specified using `-paper user ⟨width⟩⟨height⟩`, where ⟨width⟩ and ⟨height⟩ must be positive dimensions. Recognised units: pt, bp, in, mm, cm, pc, dd and cc. If the unit is omitted, bp is assumed. Examples:
  
  - `-paper a4r`
  - `-paper user 8.5in 12in`
  - `-paper user 600 1000`

-`experimental` Enables experimental functions for testing purposes. These functions don’t work properly and are not documented.
-`noexperimental` Disables experimental functions. (Default.)
-`debug` Enables the debug menu. This menu provides the functions: Debug → Object Info (which displays diagnostic information about the currently selected objects), Debug → Write Log (which writes diagnostic information for all currently open images to a log file in the configuration directory) and Debug → Dump All (which saves all current images to a subdirectory of the configuration directory).
-`nodebug` Disables the debug menu (default). However you can still use Shift-F11 and Ctrl-F11 to do the same action as Debug → Write Log and Debug → Dump All, respectively.
-`version` Prints the current version to standard output. (Synonyms `--version` and `-v` are also available.)
-`help` Prints available command line options to standard output. (Synonyms `-h` and `--help` are also available.)

3.2 The Settings Menu

While FlowframTk is running, you can change the current settings using the Settings menu. Most of the settings will be remembered next time you use FlowframTk, but may be overridden either by command line arguments or by settings specified in any JDR or AJR file that you load.

If you have selected Use default settings on start up in the Startup Settings tab of the Configure Image Settings dialog, then the canvas settings will be set to the default values on startup (unless overridden, as above). Some (but not all) of the user interface settings may still be remembered from the previous session.
Table 3.1: Paper size identifiers for use with \texttt{paper} command line switch.

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>a10</td>
<td>A10 portrait</td>
<td>a10r</td>
<td>A10 landscape</td>
</tr>
<tr>
<td>a9</td>
<td>A9 portrait</td>
<td>a9r</td>
<td>A9 landscape</td>
</tr>
<tr>
<td>a8</td>
<td>A8 portrait</td>
<td>a8r</td>
<td>A8 landscape</td>
</tr>
<tr>
<td>a7</td>
<td>A7 portrait</td>
<td>a7r</td>
<td>A7 landscape</td>
</tr>
<tr>
<td>a6</td>
<td>A6 portrait</td>
<td>a6r</td>
<td>A6 landscape</td>
</tr>
<tr>
<td>a5</td>
<td>A5 portrait</td>
<td>a5r</td>
<td>A5 landscape</td>
</tr>
<tr>
<td>a4</td>
<td>A4 portrait</td>
<td>a4r</td>
<td>A4 landscape</td>
</tr>
<tr>
<td>a3</td>
<td>A3 portrait</td>
<td>a3r</td>
<td>A3 landscape</td>
</tr>
<tr>
<td>a2</td>
<td>A2 portrait</td>
<td>a2r</td>
<td>A2 landscape</td>
</tr>
<tr>
<td>a1</td>
<td>A1 portrait</td>
<td>a1r</td>
<td>A1 landscape</td>
</tr>
<tr>
<td>a0</td>
<td>A0 portrait</td>
<td>a0r</td>
<td>A0 landscape</td>
</tr>
<tr>
<td>b10</td>
<td>B10 portrait</td>
<td>b10r</td>
<td>B10 landscape</td>
</tr>
<tr>
<td>b9</td>
<td>B9 portrait</td>
<td>b9r</td>
<td>B9 landscape</td>
</tr>
<tr>
<td>b8</td>
<td>B8 portrait</td>
<td>b8r</td>
<td>B8 landscape</td>
</tr>
<tr>
<td>b7</td>
<td>B7 portrait</td>
<td>b7r</td>
<td>B7 landscape</td>
</tr>
<tr>
<td>b6</td>
<td>B6 portrait</td>
<td>b6r</td>
<td>B6 landscape</td>
</tr>
<tr>
<td>b5</td>
<td>B5 portrait</td>
<td>b5r</td>
<td>B5 landscape</td>
</tr>
<tr>
<td>b4</td>
<td>B4 portrait</td>
<td>b4r</td>
<td>B4 landscape</td>
</tr>
<tr>
<td>b3</td>
<td>B3 portrait</td>
<td>b3r</td>
<td>B3 landscape</td>
</tr>
<tr>
<td>b2</td>
<td>B2 portrait</td>
<td>b2r</td>
<td>B2 landscape</td>
</tr>
<tr>
<td>b1</td>
<td>B1 portrait</td>
<td>b1r</td>
<td>B1 landscape</td>
</tr>
<tr>
<td>b0</td>
<td>B0 portrait</td>
<td>b0r</td>
<td>B0 landscape</td>
</tr>
<tr>
<td>c10</td>
<td>C10 portrait</td>
<td>c10r</td>
<td>C10 landscape</td>
</tr>
<tr>
<td>c9</td>
<td>C9 portrait</td>
<td>c9r</td>
<td>C9 landscape</td>
</tr>
<tr>
<td>c8</td>
<td>C8 portrait</td>
<td>c8r</td>
<td>C8 landscape</td>
</tr>
<tr>
<td>c7</td>
<td>C7 portrait</td>
<td>c7r</td>
<td>C7 landscape</td>
</tr>
<tr>
<td>c6</td>
<td>C6 portrait</td>
<td>c6r</td>
<td>C6 landscape</td>
</tr>
<tr>
<td>c5</td>
<td>C5 portrait</td>
<td>c5r</td>
<td>C5 landscape</td>
</tr>
<tr>
<td>c4</td>
<td>C4 portrait</td>
<td>c4r</td>
<td>C4 landscape</td>
</tr>
<tr>
<td>c3</td>
<td>C3 portrait</td>
<td>c3r</td>
<td>C3 landscape</td>
</tr>
<tr>
<td>c2</td>
<td>C2 portrait</td>
<td>c2r</td>
<td>C2 landscape</td>
</tr>
<tr>
<td>c1</td>
<td>C1 portrait</td>
<td>c1r</td>
<td>C1 landscape</td>
</tr>
<tr>
<td>c0</td>
<td>C0 portrait</td>
<td>c0r</td>
<td>C0 landscape</td>
</tr>
<tr>
<td>letter</td>
<td>Letter portrait</td>
<td>letterr</td>
<td>Letter landscape</td>
</tr>
<tr>
<td>legal</td>
<td>Legal portrait</td>
<td>legalr</td>
<td>Legal landscape</td>
</tr>
<tr>
<td>executive</td>
<td>Executive portrait</td>
<td>executiver</td>
<td>Executive landscape</td>
</tr>
</tbody>
</table>
3.2.1 Styles

Settings \(\rightarrow\) Styles can be used to set the current path and text area attributes. New paths and text areas will use these attributes when they are created. The attributes for existing paths and text areas are changed using the Edit menu. These settings are discussed in more detail in chapter 9.

3.2.2 Show Rulers

Settings \(\rightarrow\) Show Rulers will toggle between showing and hiding the rulers for the current canvas. This setting will be applied to new canvases that are subsequently opened, but the setting may be overridden when a new image is loaded.

See also:

- §4 Toolbar, Ruler and Status Bar Settings

3.2.3 Grid

The Settings \(\rightarrow\) Grid submenu allows you to change the grid settings:

- Settings \(\rightarrow\) Grid \(\rightarrow\) Show Grid will toggle between displaying the grid on the canvas and hiding it. If there is enough memory available, the grid will be stored as a bitmap in order to improve redraw speed.
- Settings \(\rightarrow\) Grid \(\rightarrow\) Lock Grid will toggle between locking and unlocking the grid. If the grid is locked, mouse clicks will be translated to the nearest tick mark. This means that if you use a mouse click to set the location of a control point when constructing a path, the point will be placed at the nearest tick mark. This also means that when you move a point while in edit mode, the point will be moved in intervals of the gap between tick marks. Note that locking the grid does not affect the keyboard or menu driven functions, such as Navigate \(\rightarrow\) Go To (F5) or emulate a primary-click (F4).

When the grid is locked, the status bar will show the image \(\bullet\) otherwise it will show the image \(\bullet\). You can double-click on this image to toggle the state.

Warning: if you lock the grid, you will be unable to use the mouse to select narrow paths that lie between tick marks as mouse clicks will be translated to the nearest tick mark, unless you use the drag rectangle (which may select other objects as well). Similarly, if the size of the control points is less than the gap between the tick marks, you will not be able to select control points using the mouse whilst in edit mode. (You will however be able to select them using the Next Control (F6) of Previous Control (Shift-F6) popup menu item.)

- Settings \(\rightarrow\) Grid \(\rightarrow\) Grid Settings will produce a dialog box in which you can specify the position of the tick marks and the units used. You can also open this dialog box by double-clicking on the top left corner between the rulers, where the current grid unit is displayed.

Available grid types:
3.2.4 ZOOM

- a rectangular grid with the origin at the top left hand corner of the canvas (Figure 3.1(a));
- a radial grid with the origin at the centre of the canvas (Figure 3.1(b));
- an isometric grid with the origin at the top left hand corner of the canvas where the major divisions indicate the length of each side of the equilateral triangles forming the grid (Figure 3.1(c));
- a typesetting grid after Tschichold (see [3, p. 40]). This is the only grid that checks the display page setting. If an even numbered page is displayed, the verso grid is shown (Figure 3.2(a)), otherwise the recto grid is shown (see Figure 3.2(b)). The recto grid is used for the default All Pages setting. Note that you are limited to only fourteen locations if you have the grid lock on. The settings for this grid style are the same as for the rectangular grid and are only applied to the rulers. The origin is the top left corner of the canvas for both the recto and verso displays.

Note: the grid unit is independent of the storage unit. However, it’s a good idea to choose a grid unit and storage unit that have a convenient conversion factor between them. For example, mm storage unit and cm grid unit. Regardless of the grid used, co-ordinates are always stored as left-handed rectangular co-ordinates where the origin is at the top left. This may cause slight rounding errors in the conversion between rectangular and radial co-ordinates. If you are using a radial grid and you change the paper size or orientation, the grid origin will shift but the objects will maintain their original positions relative to the top left corner of the canvas.

3.2.4 Zoom

The Settings → Zoom submenu allows you to change the magnification. You can choose one of the predefined settings or you can specify an arbitrary setting using Settings → Zoom → User Defined. The magnification value may be entered as either a percentage or a decimal value. For example, either 150% or 1.5 to zoom by a factor of 1.5. You can also change the magnification using the zoom function in the status bar. Click on the decrease button to reduce the magnification or on the increase button to increase the magnification, according to the list of preset values. Alternatively, you can double-click to open the zoom dialog box or menu-click on the percentage value to open a popup menu.

3.2.5 Paper

The Settings → Paper submenu allows you to change the paper size and orientation. In addition, Settings → Paper → Show Margins toggles between showing and hiding the printer margins, but note that this facility is not available if you use the disable_print command line argument.

The predefined paper sizes A0 to A5, letter, legal and executive can be selected from the Settings → Paper menu. Other paper sizes can be selected from the dialog box displayed using Settings → Paper → Other. Select the radio button labelled Predefined to enable a list of additional known paper sizes or select the radio button labelled User to enter a custom size.
Figure 3.1: Available regular grids: (a) rectangular grid; (b) radial grid; (c) isomorphic grid
3.2.6 IMAGE SETTINGS DIALOG

The Settings → Configure Image Settings menu item opens the Configure Image Settings dialog box, which can be used to change image settings. (§3.2.7 TeX Settings Dialog covers \TeX/\LaTeX related settings and §3.2.8 User Interface Settings Dialog covers settings related to the user interface.)

Control Point Settings

The Control Points tab (Figure 3.3) allows you to:

• set the size of the control points;
• specify whether the control point size should be affected by the zoom setting;
• set the storage unit.

It’s best to set the storage unit before you start creating an image. If the selected canvas isn’t empty, all objects will have their co-ordinates recomputed in terms of the new unit, which may take a while if there are many objects or paths with many segments. You can also open a dialog window with just the storage unit panel in it by double-clicking the mouse on the storage unit area of the status bar.

Startup Directory

The Startup Directory tab (Figure 3.4) allows you to choose which directory FlowframTk should use as the current working directory when it starts up. You have a choice of:

• the current working directory that you were in when you started up FlowframTk;
• the directory you were using when you last used FlowframTk;
• a specific directory. In this case, type in the path in the box labelled Use this directory or use the Browse button to select the required directory.

Figure 3.2: Tschichold grid: (a) verso (even pages); (b) recto (odd pages)
3.2.6  IMAGE SETTINGS DIALOG

Figure 3.3: Configuration Dialog Box (Control Point Settings)

Figure 3.4: Configuration Dialog Box (Startup Directory Settings)
JDR/AJR Settings

You can use the JDR/AJR Settings tab (Figure 3.5) to specify whether or not you want the current canvas settings stored in the JDR or AJR file when you save your image. You can also choose whether or not you want to apply any canvas settings information stored in any JDR or AJR file that you load. The canvas settings consist of: grid show/hide, grid locked/not locked, rulers displayed/not displayed, the tool in use, the LaTeX normal size, the paper size, the grid style, the size of the control points and whether they should be affected by the magnification setting.

Startup Settings

You can use the Startup Settings tab (Figure 3.6) to choose whether you want FlowframTk to start with its default settings, or whether to restore the settings from the last time you used FlowframTk, or whether to use the settings that are currently in use.

If you choose the default settings option, the canvas settings will be set to the default on startup. Some (but not all) of the user interface settings may still be remembered from the previous session, including the language used by the user interface and the manual, the paths to the required applications used by the export functions and the button styles.

Most of the settings are saved in the file flowframtk.conf in the configuration directory. Mappings, accelerators, language settings and the recent file list aren’t governed by the startup setting and are stored in separate files in the configuration directory. When you upgrade to a new version of FlowframTk, the accelerators are reset to the default and then the existing accelerators file is loaded to ensure any new accelerators are added. Don’t modify these files whilst FlowframTk is running. You may
modify them after you have quit FlowframTk using a text editor, but make sure you save your changes before restarting FlowframTk.

**Bitmap Settings**

You can use the Bitmaps tab (Figure 3.7) to choose whether included bitmaps should be saved using their full path name or a path name relative to the file being saved. Relative names allow for greater portability, but if you move the saved file to a different location, you will need to remember to move the bitmap files relative to the new location or they won’t be found.

You can also use this tab to specify your preferred default image command, which may be either \pgfimage or \includegraphics.

**Application Paths**

If you export your image to PDF, EPS or SVG (see §5.6.4 Export to Single-Paged Document) FlowframTk will first save the image as an encapsulated \LaTeX document and will then run external applications to create the desired file format. In order to do this, FlowframTk needs to know the correct paths to these applications. It will try to find them from your system’s PATH environment variable, but if it can’t find them you can use the Application Paths tab (Figure 3.8) to set their locations. The libgs library is needed by dvisvgm, so you only need it if you intend to export to SVG.

To reduce the chance of zombie processes, each process is run with a timer that will kill the process if it exceeds the value specified in the box labelled Time-out.
3.2.6 IMAGE SETTINGS DIALOG

Figure 3.7: Configuration Dialog Box (Bitmap Settings)

Figure 3.8: Configuration Dialog Box (Application Paths)
3.2.7 \TeX\ Settings Dialog

The menu item Settings $\rightarrow$ Configure \TeX/\LaTeX\ Settings will open up a dialog box in which you can adjust the \TeX/\LaTeX\ settings. (§3.2.6 Image Settings Dialog covers image settings and §3.2.8 User Interface Settings Dialog covers user interface settings.)

Setting the Document Class and Normal Font Size

Most of FlowframTk’s \TeX/\LaTeX\ related functions (including the export function) require a value corresponding to $\texttt{\textbackslash normalsize}$ (the \LaTeX\ command that sets the normal font size). A text area needs to know the normal font size to determine the appropriate font size declaration (see §9.5.2 Font Size). In addition, both the \texttt{parshape} and \texttt{shapepar} functions use the value of $\texttt{\textbackslash baselineskip}$ for the normal font size in order to determine the location of the scan lines used to compute the required parameters. This also means that any static or dynamic frames that use a non-standard paragraph shape also require this information.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{TeXSettingsDialog.png}
\caption{Setting the Normal Font Size and (optionally) the Class}
\end{figure}

The normal font size can be set using the Document Settings tab (Figure 3.9). Select the required value from the drop-down list and select Okay to set it. Note that you must remember to use this value in your document. For example, if you set the normal size as 20, your document will need to use one of the extsizes class files, e.g. \texttt{extarticle}, and specify 20pt as one of the optional arguments:

$\texttt{\documentclass[20pt]{extarticle}}$

Note that the largest normal size listed (25pt\textsuperscript{2}) is for use with the \texttt{a0poster} class file. Remember that for very large or very small fonts, you will need to use scalable

\textsuperscript{2}this value is actually 24.88pt, but FlowframTk lists it as 25pt.
3.2.7 TEX SETTINGS DIALOG

fonts in your document to prevent font size substitutions. Available values, along with the corresponding value of \baselineskip and the file in which they are defined, are listed in Table 3.2.

Table 3.2: Available values for the normal font size, the corresponding value and the file in which they are defined (relative to the TEXMF tree).

<table>
<thead>
<tr>
<th>Normal size value</th>
<th>\baselineskip value</th>
<th>Relevant File</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>9.5</td>
<td>tex/latex/extsizes/size8.clo</td>
</tr>
<tr>
<td>9</td>
<td>11</td>
<td>tex/latex/extsizes/size9.clo</td>
</tr>
<tr>
<td>10</td>
<td>12</td>
<td>tex/latex/base/size10.clo</td>
</tr>
<tr>
<td>11</td>
<td>13.6</td>
<td>tex/latex/base/size11.clo</td>
</tr>
<tr>
<td>12</td>
<td>14.5</td>
<td>tex/latex/base/size12.clo</td>
</tr>
<tr>
<td>14</td>
<td>17</td>
<td>tex/latex/extsizes/size14.clo</td>
</tr>
<tr>
<td>17</td>
<td>22</td>
<td>tex/latex/extsizes/size17.clo</td>
</tr>
<tr>
<td>20</td>
<td>25</td>
<td>tex/latex/extsizes/size20.clo</td>
</tr>
<tr>
<td>25</td>
<td>30</td>
<td>tex/latex/a0poster/a0poster.sty</td>
</tr>
</tbody>
</table>

If the checkbox labelled Update all LaTeX font size declarations in current image is selected, changing the normal size setting in this dialog will update the LATEX font size settings for all the text areas in the current image.

If you want to export your image to a complete LATEX document (see §5.6.4 Export to Single-Paged Document) the document class will default to:

- article, if the normal size is set to 10, 11 or 12;
- a0poster, if the normal size is set to 25;
- extarticle, otherwise.

If you want to use a different document class, select the radio button Use class, which will enable the field where you can type the require class name (without the .cls extension). You need to ensure the class supports your specified normal font size (as a standard option, not a key=value option).

The document class is also used as the base class with the export to document class function (see §5.6.2 Export to a Class or Package) and is used for all export functions that use the export to encapsulated LATEX document function as an intermediate step (§5.6.4 Export to Single-Paged Document).

The Use relative font size declarations checkbox governs the suggested LATEX font size command when you change the font size setting for text areas. If this checkbox is selected, FlowframTk will attempt to select a font size declaration, such as \large, according to the current normalsize setting. Otherwise, \setfontsize will be used. If the font size is significantly larger than the largest available declaration, \setfontsize will be used regardless of this setting.

The Add \pdfinfo to exported LaTeX documents checkbox governs whether or not to add \pdfinfo to exported LATEX documents. If the image has a description, this will be added to the /Title attribute. The only other attribute that is set is the /CreationDate attribute. This setting is not used for the export to PostScript or SVG functions as they use latex rather than pdflatex.

When an image is exported to an encapsulated LATEX document or complete LATEX document, by default the image bounding box is calculated as the minimal sized rectangle that encompasses all objects on the canvas. If the image contains an text areas,
this may result in text being clipped to the left or right of the image due to the font differences. In this case, or if you require a different bounding box for some other reason, then switch on the Use typeblock as bounding box for pgfpicture checkbox and if the image has a typeblock set (see §10.4.2 Defining the Typeblock) the typeblock will be used as the image bounding box. If the image doesn’t have a typeblock set, then the default bounding box will be used. See also Figure 5.3 in §5.6.4 Export to Single-Paged Document.

Flowframe Settings

The Flowframe Settings tab (Figure 3.10) allows you to adjust the flowfram related settings.

The flowfram package now allows you to use absolute pages numbers in the page list rather than using the value of the page counter. For example, if your document pages are numbered a, b, i, ii, iii, 1, 2, 3, then with the absolute setting page number 3 refers to the page labelled i whereas with the relative setting page number 3 refers to both the page labelled iii and the page labelled 3. (See the flowfram documentation for further details.) If you want to use the absolute setting, select the button labelled absolute otherwise select the button labelled relative.

The shapepar package now has a command called \Shapepar that behaves slightly differently to \shapepar. Since \Shapepar works better than \shapepar when used with the flowframe package, FlowframTk defaults to using \Shapepar for the \TeX/\LaTeX \rightarrow \Shapepar function or when a static or dynamic frame has the shape set to Shapepar. However, if you prefer the original \shapepar command, selected the appropriate shapepar command radio button. If you want to use \Shapepar, you need to ensure you have up-to-date versions of the flowfram and shapepar pack-
3.2.7 TEX SETTINGS DIALOG

This setting applies both to frames with the Shapepar shape setting and to the TeX/LaTeX → Shapepar function.

Text Settings

The LaTeX Text Settings tab (Figure 3.11) allows you to adjust the text-related settings.

Figure 3.11: LaTeX-Related Text Settings

- If the Auto Adjust Anchor checkbox is selected, whenever you justify a group, any text areas in that group will have their anchors automatically adjusted.
- FlowframTk can’t implement paint shadings for text when exporting to pgf. (This includes the export functions that use latex or pdflatex, such as the export...
3.2.7 TEX SETTINGS DIALOG

to PDF function.) You can choose how FlowframTk should export shaded text using the When exporting text with shadings dropdown box. Available options:

- **Average Colours** The text will be given the colour obtained by averaging the shading’s start and end colour.
- **Use Start Colour** Just the shading’s start colour will be used.
- **Use End Colour** Just the shading’s end colour will be used.
- **Convert to Path** The text will be exported as a path rather than text. This means that the \LaTeX alternative text attribute will be ignored. This is equivalent to applying the convert to path, ungroup and merge path functions (without actually changing your image).

- FlowframTk cannot implement the text outline option for text-paths when exporting to pgf. (Again, this includes the export functions that use latex or pdflatex.)

You can choose how FlowframTk should export text-path outlines using the When exporting text-paths with outlines dropdown box. Available options:

- **Convert to Path** The text-path will be exported as a path rather than a text-path. This means that the \LaTeX alternative text attribute will be ignored. This is equivalent to applying the convert to path, ungroup and merge path functions, without actually changing your image. (This option will always override the shading options described above, if the text-path has a shading.)
- **Ignore Outline** The outline attribute will be ignored.

FlowframTk has two tools for creating text areas: the regular text-mode tool (Tools \rightarrow Text) and the maths-mode tool (Tools \rightarrow Maths). Each text area has an associated \LaTeX alternative text which, if set, is used during the \texttt{pgf} export operations in place of the text displayed on the canvas. (This includes the export functions that use \texttt{latex} or \texttt{pdflatex}, such as the export to PDF function.) The maths-mode tool automatically inserts the maths-shift dollar symbols $ at the start and end of the alternative text. In addition, Unicode symbols present in the text when a new text area is constructed can be mapped to a \LaTeX command.

The mappings applied depend on which tool has been selected. With the regular text-mode tool, all the ten \TeX special characters are mapped to commands. In addition, there are some other characters that are also mapped by default. These are listed in the table shown in the Text Mode Mappings tab (see Figure 3.11). If you don’t want any text mappings applied, deselect the Auto escape text symbols checkbox.

With the maths-mode tool, the hash # and percent % characters are the only two of the ten \LaTeX special characters that are mapped by default. However there are other mappings of maths-related Unicode characters and these are listed in the table shown in the Maths Mode Mappings tab (see Figure 3.12). If you don’t want maths mappings applied, deselect the Auto escape maths symbols checkbox.

The mapping tables can be sorted by clicking on their column headers. You can add, delete or modify any of these text- or maths-mode mappings. Any mapping that ends with a control word (a backslash followed by one or more letters) should usually be followed by a space or \{ \} to prevent it from running into any subsequent letter when the mapping is applied. For text-mode mappings, \{ \} is better in case the command is
### 3.2.7 TEX SETTINGS DIALOG

**Figure 3.12: LaTeX-Related Text Settings — Maths-Mode Mappings**

<table>
<thead>
<tr>
<th>Code Point</th>
<th>Symbol</th>
<th>Command</th>
<th>Package</th>
</tr>
</thead>
<tbody>
<tr>
<td>U+00623</td>
<td>π</td>
<td>\π</td>
<td></td>
</tr>
<tr>
<td>U+00625</td>
<td>≈</td>
<td>\approx</td>
<td></td>
</tr>
<tr>
<td>U+00647</td>
<td>⌘</td>
<td>\textcircled{}</td>
<td></td>
</tr>
<tr>
<td>U+00680</td>
<td>°</td>
<td>\degree</td>
<td></td>
</tr>
<tr>
<td>U+00681</td>
<td>±</td>
<td>\pm</td>
<td></td>
</tr>
<tr>
<td>U+00682</td>
<td>^</td>
<td>^\text{superscript}</td>
<td></td>
</tr>
<tr>
<td>U+00683</td>
<td>~</td>
<td>\sim</td>
<td></td>
</tr>
<tr>
<td>U+00685</td>
<td>µ</td>
<td>\text{micro}</td>
<td>gensymb</td>
</tr>
<tr>
<td>U+00686</td>
<td>,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>U+00689</td>
<td>,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>U+0068C</td>
<td>,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>U+006AC</td>
<td>,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>U+00D7</td>
<td>\times</td>
<td>\times</td>
<td></td>
</tr>
<tr>
<td>U+202C</td>
<td>\nabla</td>
<td>\nabla</td>
<td></td>
</tr>
<tr>
<td>U+2220</td>
<td>\top</td>
<td>\text{top}</td>
<td></td>
</tr>
<tr>
<td>U+2221</td>
<td>\bottom</td>
<td>\text{bottom}</td>
<td></td>
</tr>
<tr>
<td>U+2222</td>
<td>*</td>
<td>\bullet</td>
<td></td>
</tr>
<tr>
<td>U+2226</td>
<td>...</td>
<td>\ldots</td>
<td></td>
</tr>
<tr>
<td>U+222F</td>
<td>\ldots</td>
<td>\ldots</td>
<td></td>
</tr>
<tr>
<td>U+2230</td>
<td>\ldots</td>
<td>\ldots</td>
<td></td>
</tr>
<tr>
<td>U+2231</td>
<td>\ldots</td>
<td>\ldots</td>
<td></td>
</tr>
<tr>
<td>U+2234</td>
<td>\ldots</td>
<td>\ldots</td>
<td></td>
</tr>
<tr>
<td>U+2235</td>
<td>\ldots</td>
<td>\ldots</td>
<td></td>
</tr>
</tbody>
</table>
followed by an intended space, although this may depend on the command definition. For maths-mode mappings it’s better to follow the control word with a space.

You can delete a mapping or mappings by selecting the appropriate row of the mapping table (use shift-click or ctrl-click to add to the current selection) and clicking on the red minus button to the side of the table. To restore all the original mappings, quit FlowframTk and delete or rename the files `mathmappings.prop` and `textmappings.prop` in the configuration directory.

To edit an existing mapping, double-click on the second and third columns of the mapping table. The first two columns can’t be edited.

To add a new mapping, click on the green plus button to the side of the relevant table. Enter the character you want mapped in the Symbol box or type the hexadecimal value in the Code Point box and then enter the replacement command in the Command box. If the command is defined in a package, enter the package name (without the .sty extension) in the Package box. If the mapping requires multiple commands from different packages, you can specify a comma-separated list of packages in the Package box. If the replacement command is available in the \LaTeX kernel, you can leave this box blank. (These packages will be automatically added to the image’s early-preamble code, whenever the mapping is applied.)

The package name may be preceded by optional arguments in square brackets such as \[\text{weather}ifsym\] (note that the package name isn’t enclosed in braces). Set the package name to “none” or leave it empty if you don’t want it automatically added to the early-preamble code when the mappings are applied.

For example, in Figure 3.13 the new mapping dialog is being used to define a new text mapping from the Unicode dagger † symbol (U+2020) to the `\textdagger` command. Since this command is defined in the \LaTeX kernel, the package field can be left empty. The Unicode symbol can be specified either by typing the hexadecimal code into the Code Point field or by typing the actual symbol into the Symbol field. If there is already a mapping for this Unicode symbol, the old mapping will be overwritten.

![Add new text mapping dialog](image)

Figure 3.13: Adding a New Text Mapping

You can also import mappings from a tab-separated file (`.tsv`) where the first column is the hexadecimal code, the second column is the command (or commands) and the third column is the package name or comma-separated list of packages. Any additional columns are ignored, as are blank lines or lines starting with # (hash). The file shouldn’t contain any delimiters nor may any of the cells contain a newline or tab character. For example, the file may look like:

```
00260E \Telephone [misc]ifsym
0026A1 \Lightning [weather]ifsym
```
You can find extra mappings using the Symbol Lookup page at http://www.dickimaw-books.com/latex/symbol-lookup.php which has a web form you can use to look up mappings in the database. If the mapping ends with a control word the import function will automatically append a space for maths-mode or {} for text-mode, unless the Unicode character type is one of: combining spacing mark, connector punctuation, modifier symbol or modifier letter, in which case just a space is appended. (This adjustment isn’t done for the edit mapping or add a single-mapping functions described above. You need to do this yourself, as I did in Figure 3.13.) If this adjustment isn’t appropriate, you can edit the mapping to remove it.

For example, in Figure 3.14, I’ve selected the “Latin-1 Supplement” block with the mode set to “text”. If I then click on the “Search” button at the bottom of the form, this will list all the mappings listed in the database that match. To import these values into FlowframTk, you first need to download them in the correct format. Set the “Results Format” drop-down list to TSV (not CSV) and click on the “Search” button. Depending on your browser, this may automatically save the file symbol-lookup.tsv in your downloads directory/folder or it may try to open the file. Be careful if it tries to open the file in a spreadsheet application as this may change the format to one that’s not compatible with FlowframTk.

LaTeX Symbol Lookup

This script provides a way of looking up LaTeX commands that approximate Unicode characters. They may not exactly match. There may also be alternatives not listed. The database only has a small number of characters that have been mapped.

Search Criteria:  ○ AND  ○ OR
Block:  [Latin-1 Supplement]
Hex Code:  (e.g., 27'B4') OR UTF-8 Character:
Mode:  [text]
Package:  

Use ‘none’ for kernel-only commands. Regular expressions permitted, e.g. ‘\texttt{\{amsmath\}none’.

Description Matches:  \texttt{\{regular expression, case ignored\}}
Command Matches:  \texttt{\{regular expression, case ignored\}}
Order by:  Code Point then Package
Maximum Results:  200

Results Format:  [HTML]
The CSV format has a header row and uses the double-quote ‘ delimiter and a comma separator. The TSV format has no header row, no delimiters and a tab separator.

Figure 3.14: Symbol Lookup Script

If you try this search on the Symbol Lookup page and open the file in your favourite text editor, you may notice that some codepoints are listed multiple times. For example:

0000A3  \textsterling  none  text  0
0000A3  \pounds  none  both  0
If you simply import the file into `FlowframTk`, new mappings will override the earlier mappings, so in this case the mapping for U+A3 will be set to `\pounds` rather than `\textsterling` so delete any of the mappings you don’t want before you import the file.

This example also produces mappings that require the `fontenc` package. For example:

```
0000AB \guillemotleft fontenc text 0
```

This indicates commands that are part of the L\TeX\ kernel but don’t work with the default OT1 font encoding. In my case, I’ve set my `default preamble` to include `fontenc` with the T1 encoding, so I don’t want that package automatically added to my early-preamble code. To fix this, I just need to use my text-editor’s search-and-replace function to replace all instances of “`fontenc`” with “`none`” before I import this file. If you don’t have this package in the default preamble, you’ll need to add the appropriate option. For example, change the line to:

```
0000AB \guillemotleft [T1]fontenc text 0
```

(Again, you can use your text-editor’s search-and-replace function.) Similarly, if you want to import any of the symbol maps that include commands from the `mathdesign` package, you’ll need to add the option to set the required font. For example

```
002231 \intclockwise [utopia]mathdesign math 1
```

Once all these modifications have been made, the file can then be imported by clicking on the import button in the appropriate mapping pane. In this case, I have fetched mappings that are valid in text-mode, so I need to select the `Text Mode Mappings` tab and then click on the import button to the right of the mapping table. This will open a file chooser which I can use to select the TSV file.

Note that mappings take up resources and the more mappings you have, the longer it will take to startup `FlowframTk`, so it’s best to only add the mappings that you’re likely to need. The symbol lookup form on the Dickimaw Books website has a maximum limit of 500 for the search results. (A smaller limit can be set if required. The default value is 200.)

### Default Preamble

The `Default Preamble` tab (Figure 3.15) allows you to specify code that should always be added to the preamble when exporting images to complete \LaTeX{} documents or formats that use the encapsulated \LaTeX{} document function as an intermediate step (see §5.6.4 Export to Single-Paged Document). This code isn’t used for the export to class (.cls) or package (.sty) functions.

The default preamble code is stored in a file called `preamble.tex` in `FlowframTk`'s `configuration directory`. If you edit this file outside of `FlowframTk`, you’ll need to use the reload button to refresh this panel. The other buttons are the same as for the \TeX\ editor described in §4 TeX Editor Settings. You can also access these button actions through the context menu, which can be opened using a menu-click on the editor pane.
3.2.8 USER INTERFACE SETTINGS DIALOG

The menu item Settings → Configure User Interface will open up a dialog box in which you can adjust the user interface settings. (§3.2.6 Image Settings Dialog covers image settings and §3.2.7 TeX Settings Dialog covers \TeX/\LaTeX related settings.)

Graphics Settings

The Graphics tab (Figure 3.16) allows you to:

- choose between using or not using anti-aliasing to display the graphics;
- choose between speed or quality in the rendering;
- set the colour for the different types of control points;
- choose whether a mouse click on the canvas (outside of any of the control points) exits edit path mode.

You can also use this tab to choose between enabling (left icon) and disabling (right icon) hotspots along the bounding boxes. If hotspots are enabled, you can scale, rotate or shear objects by dragging the appropriate hotspot. (Note that transforming composite shapes applies the transformation to the underlying shape not to the shape as a whole.)

You may want to disable this option when you want to move small objects, or you may end up transforming them instead of moving them. When this option is enabled,
3.2.8 USER INTERFACE SETTINGS DIALOG

Figure 3.16: Configuration UI Dialog Box (Graphics Settings)
the cursor will change shape when you move it over the edge of the bounding box. Figure 3.17(a) shows how the bounding box is displayed when hotspots are enabled and Figure 3.17(b) shows how the bounding box is displayed when the hotspots have been disabled. Each hotspot is represented by a small square. Available functions are listed in Table 3.3.

Table 3.3: Hotspot Functions

<table>
<thead>
<tr>
<th>Hotspot</th>
<th>Function</th>
<th>Cursor Appearance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bottom left</td>
<td>rotate</td>
<td>hand</td>
</tr>
<tr>
<td>Bottom centre</td>
<td>scale vertically</td>
<td>South arrow</td>
</tr>
<tr>
<td>Bottom right</td>
<td>scale both directions</td>
<td>South-East arrow</td>
</tr>
<tr>
<td>Middle right</td>
<td>scale horizontally</td>
<td>East arrow</td>
</tr>
<tr>
<td>Top right</td>
<td>shear vertically</td>
<td>North arrow</td>
</tr>
<tr>
<td>Top left</td>
<td>shear horizontally</td>
<td>West arrow</td>
</tr>
</tbody>
</table>

Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed. As may be predicted, using hotspots is not as precise as using the transformation dialog boxes described in chapter 8.

Annotations Settings

The Annotations tab (Figure 3.18) allows you to set the font used for annotating frames or draft bitmaps and set the font used on the splash screen during startup.

Language Settings

You can use the Languages tab (Figure 3.16) to set which language to use for the application resources (menus, messages etc) and which language to use for the manual. These settings will not be applied until you quit and restart FlowframTk. Currently the

---

3The actual cursor appearance depends on the look and feel of the platform you are using. On some systems the South and North arrows may look the same, and similarly for the East and West arrows.
3.2.8 USER INTERFACE SETTINGS DIALOG

Figure 3.18: Configuration UI Dialog Box (Annotations Settings)
3.2.8 USER INTERFACE SETTINGS DIALOG

Figure 3.19: Configuration UI Dialog Box (Language Settings)
only available resource languages are: en-GB, en-US and zh, and the only available manual languages are: en-GB and en-US.

You can also use the Languages tab to specify the Unicode blocks to display in the symbol selector. By default, only a limited subsection of Unicode characters are available because it would significantly slow FlowframTk’s startup process to provide all possible characters. To add a new block, click on the green plus button next to the table. To remove an unwanted block, select the appropriate row in the table and click on the red minus button. The start and end values don’t need to match a complete Unicode block and may span multiple blocks. For example, suppose you regularly want to enter musical symbols into your image, then you can add a block starting from 1D100 and ending at 1D1DD. You need to quit and restart FlowframTk for the changes to take effect. If you want to restore the defaults, quit FlowframTk, open the file flowframtk.conf in the configuration directory and remove the line starting with unicode=

See also:

• §B Multilingual Support

Accelerator Settings

You can use the Accelerators tab (Figure 3.20) to change the default accelerators (keyboard shortcuts). It’s possible to use the same keystroke for different actions provided the actions are never both enabled at the same time. (For example, F6 selects the next control in path edit mode or adjust the selection in select mode.)

Note: Java’s accessibility API uses F10 to switch the focus to the menu bar, so avoid using this key for an accelerator.

Suppose you want to change the accelerator for the Undo function from the default F8 to, say, Ctrl+Shift-U. Find the appropriate row in the accelerator table and double-click on it to open the Set Accelerator dialog box (Figure 3.21).

There are two ways to change the keystroke. If the Use Selector button is selected, you can select or deselect the required modifiers (such as Shift) and use the drop-down box to select the keystroke. So to change the keystroke to Ctrl+Shift-U, select the Shift and Ctrl checkboxes and set the drop-down box to pressed U. Alternatively, if the Use Key Stroke button is selected you can type the required keystroke in the Enter Key Stroke field. Care must be taken with this option. You need to make sure you release the main key before releasing the modifiers. For example, press down the control, shift and U keys but release the U key before releasing the control and shift keys. Note that the Tab key retains its usual function of moving the focus to the next component in the window, and so can’t be typed in the Enter Key Stroke field. (Neither can certain other keys that are always intercepted by the operating system.) The Enter key, on the other hand, will be picked up by the Enter Key Stroke field if it has the focus, so you need to ensure you move the focus to a different component if you want to use Enter to activate the “Okay” button.

The accelerator settings are written to a file called accelerators.prop in the configuration directory when FlowframTk quits normally. You may edit this file using your preferred text editor to change the settings as long as FlowframTk isn’t currently running. For example, if you want to change all the keystrokes that require the control key to be pressed to requiring the meta key pressed instead, you may find it easier to do a global search and replace in accelerators.prop of ctrl with meta. If you
3.2.8 USER INTERFACE SETTINGS DIALOG

Figure 3.20: Configuration UI Dialog Box (Accelerators)
Figure 3.21: Changing a keyboard shortcut.

do edit this file, make sure you only edit the values to the right of the ‘=’ sign. To restore
the default accelerators, delete or rename this file (when FlowframTk isn’t running).

**Toolbar, Ruler and Status Bar Settings**

You can use the **Borders** tab (Figure 3.22) to customise the **rulers**, **toolbar** and **status bar**. You can show or hide the **toolbars** using the **Show Tools** checkbox. If this checkbox is selected, you can also specify the location of the vertical toolbar.

The vertical toolbar is located on the left of FlowframTk’s main window by default, but can be switched to the right by selecting the **Right** radio button (or the right-hand icon shown at the side of this paragraph). You will need to quit and restart for the change to take effect.

The width (in pixels) of the vertical ruler can be specified in the **Side Ruler Width** field, and the height (in pixels) of the horizontal ruler can be specified in the **Top Ruler Height** field. For example, if you find that the y co-ordinates don’t fit on the vertical ruler, you can make the ruler wider, say, to 30 pixels. There’s a sample panel on the right that shows the dimensions (but doesn’t show the ruler annotations).

The way the co-ordinates appear on the rulers is governed by the **Number format** field. The pattern syntax is as for java.text.DecimalFormat, described in the Java API ([http://docs.oracle.com/javase/7/docs/api/java/text/DecimalFormat.html](http://docs.oracle.com/javase/7/docs/api/java/text/DecimalFormat.html)). You can also set the locale governing the pattern, but this pattern is only applied to the **rulers**, not to the co-ordinate dialog boxes or **status bar**. The font used by the rulers can also be changed. This panel doesn’t provide a setting to show or hide the rulers as this is done for the currently selected **canvas** using the main menu item **Settings → Show Rulers**.

You can show or hide the **status bar** using the **Show Status Bar** check box. If this box is selected, you can additionally choose to show or hide the individual **status bar** elements.

See also:

- §4.3 The Rulers
- §4.4 The Status Bar
Figure 3.22: Configuration UI Dialog Box (Toolbar, Ruler and Status Bar Settings)
Normalization

When an image is drawn on the canvas via Java’s painting methods, the co-ordinates of all the objects are converted into PostScript points (including any scaling applied by the zoom settings). However, it is rare for any display device, such as a standard monitor, to have pixels that are exactly one PostScript point square in size. This means that a 1in (or 72bp) line drawn on the screen at 100% magnification may not actually measure 1in if you hold a ruler up to your screen. You can compensate for this by setting the horizontal and vertical normalization factors. If you already know these factors you can type them into the boxes below (or set them both to 1 to remove normalization):

X Normalize Factor: 1.0  Y Normalize Factor: 1.0  Reset

or you can hold your ruler up against the unnormalized horizontal and vertical lines, enter their measurements in the boxes and click on the ‘Compute buttons below.

When an image is drawn on the canvas via Java’s painting methods, the co-ordinates of all the objects are converted into PostScript points (including any scaling applied by the zoom settings). However, it is rare for any display device, such as a standard monitor, to have pixels that are exactly one PostScript point square in size. This means that a 1in (or 72bp) line drawn on the screen at 100% magnification may not actually measure 1in if you hold a ruler up against the screen. This is fairly typical for most graphical applications but, if it bothers you, you can adjust the horizontal and vertical normalization factors used by FlowframTk in the Normalization tab (Figure 3.23).

If you happen to already know the normalization factors for your device, you can enter them in the X Normalize Factor and Y Normalize Factor fields. If you don’t know them, FlowframTk can compute them for you. To do this, you need to hold a ruler
against the Unnormalized Horizontal line, enter the measurement in the length field below the line and click on the Compute X Norm button. This will insert the normalization factor into the X Normalize Factor field. Next, hold the ruler against the Unnormalized Vertical line, enter the measurement in the length field below that line and click on the Compute Y Norm button. This will insert the normalization factor into the Y Normalize Factor field. You then need to click on the okay button to set these normalization factors.

TeX Editor Settings

![Figure 3.24: Configuration UI Dialog Box (TeX Editor Settings)](image)

FlowframTk has small text editor that’s opened when you want to edit the contents of a static or dynamic frame. The font used by this editor can be changed in the TeX Editor tab (Figure 3.24). You can also set the default width (in terms of approximate
number of characters per line) and the default height (in terms of lines) for the editor when it’s first created at startup. You can also enable or disable syntax highlighting by selecting or deselecting the button marked Syntax highlighting. If selected, you can also set the colour used for comments (indicated by \TeX’s \% comment character) or for commands. The editor currently doesn’t have any spell-checking support. The default preamble panel of the \TeX/La\TeX\ Settings dialog also uses these settings.

In FlowframTk version 0.7, this editor window was also used for changing the preamble text, but as from version 0.8, the preamble editor has been switched to a pane attached to the canvas that can remain open while you’re editing the image. This pane uses these settings, except for the default width and height, which is now governed by the size of the canvas window and the location of the divider. By default, the preamble pane is to the right of the canvas, but you can change this using the radio buttons in the Canvas/Preamble Split area.

Look and Feel Settings

Java displays GUI elements, such as buttons and menus, according to the selected “look and feel”. There are a number of different look and feels that may, or may not, be available on your platform. Some of the look and feels don’t support certain features such as the click-to-collapse setting on the divider bar in split panes, including the divider between the canvas and the preamble pane. The Look & Feel tab has a drop-down list with the list of available look and feels. For example, Figure 3.25 has the “Metal” look and feel selected. You can change this to a different look and feel, but you must restart FlowframTk for the change to be implemented.

Some example look and feels are shown in Figure 3.26. Note that the main window’s title bar and outer border isn’t governed by Java’s look and feel, but by the operating system’s window manager. For example, I’ve used different window themes whilst taking snapshots of FlowframTk for this manual, which is why the colour and format of the title bar for the main window and for the dialog boxes vary.

In addition to changing the look and feel, you can also change how the buttons that have icons are displayed. By default, the buttons with icons have a bordered style, with a different icon image for the up, down, rollover and disabled states, but if you don’t like them, you can select a different type from the Style area. Each type has some sample buttons displayed on the right. They don’t perform any actions, but you can press them to try them out. The button types come in the following flavours:

- **Bordered** This is the default button type described above. These buttons have distinctive up and down states regardless of the look and feel.
- **Small Bordered** Similar to bordered but a smaller version.
- **Plain** This has a single icon image for the button. The up and down look is dealt with by the look and feel. This means that if the selected look and feel doesn’t draw an up or down effect, you won’t be able to see the button state.
- **Small Plain** Similar to plain but a smaller version.
- **Highlights** This is like plain but there is a second icon for the down state of radio and check buttons that is like the up state but has a highlighted background. This means that you can now see a difference between the up and down states for the radio and check buttons when used with a look and feel style that doesn’t draw an up or down effect.
Figure 3.25: Configuration UI Dialog Box (Look and Feel Settings)
Figure 3.26: Look and Feel Examples: (a) Metal; (b) Nimbus; (c) CDE/Motif; (d) GTK+. 
Small Highlights  Similar to highlights but a smaller version.

Bordered Switches  Uses the plain type for press buttons and the bordered type icons for radio and check buttons. Unlike the default bordered style, in this case the bordered icons also include the look and feel’s up and down effect (where supported).

Small Bordered Switches  Like bordered switches but a smaller version.

Some of these styles also display a textual label, which may be above, below, to the left or to the right of the icon. Alternatively, you can just select the text only option.

If you prefer to have a different style for the dialog windows, you can uncheck the As General Button Style button, which will display a set of button styles that you can apply to the dialog windows. For example, Figure 3.27 shows the dialog window from Figure 3.16 with the small icons and trailing text dialog button option.

As with the look and feel setting, you must restart FlowframTk before the changes can be implemented.

3.3 Configuration Directory

When you quit FlowframTk, the settings will be saved in FlowframTk’s configuration directory. This directory is determined (and created if necessary) as follows:

- If the environment variable JDRSETTINGS exists and is a directory, that directory is used.
- If FlowframTk detects the existence of the old Jpgfdraw’s configuration directory, that will be used. If the file jpgfdraw.conf exists in that directory but the file flowframtk.conf doesn’t exist, FlowframTk will load the settings from jpgfdraw.conf and then save the new settings to flowframtk.conf. If you like, after you have quit FlowframTk, you can remove the now unneeded file jpgfdraw.conf and rename the directory .flowframtk or flowframtk-settings, as appropriate.
- If the directory ⟨home⟩/flowframtk exists and is a directory, that directory is used (where ⟨home⟩ indicates the user’s home directory as given by the Java user.home property).
- If the directory ⟨home⟩/flowframtk-settings exists and is a directory, that directory is used.
- If the operating system (as identified by the Java os.name property) is a version of Windows and the directory ⟨home⟩/flowframtk-settings can be created, that directory is used.
- For other operating systems, if the directory ⟨home⟩/.flowframtk can be created, that directory is used.
- If the directory settings/⟨user⟩ or settings can be created in FlowframTk’s installation directory, that directory will be used (where ⟨user⟩ is the current user’s user name). This is sub-optimal and not recommended as it may be removed when upgrading to a new version.
Figure 3.27: Dialog Buttons with Small Icons and Trailing Text
If none of the above, an error will occur and you will need to set the environment variable `JDRSETTINGS` to a sensible location with read and write permissions.

The configuration directory may also contain:

- the list of recent files (written by FlowframTk when it quits normally);
- the accelerator settings `accelerators.prop` (written by FlowframTk when it quits normally);
- the maths-mode and text-mode character mapping files, `mathmappings.prop` and `textmappings.prop` (written by FlowframTk when it quits normally);
- the `preamble` file `preamble.tex` (created by you, if you want it, in any text editor) used by some of the export functions (see §3 Default Preamble);
- the `languages.conf` file that stores the language settings used for the resources and manual;
- the `startup.conf` file that stores the names of the fonts used by the startup splash screen;
- the `latexfontmap.prop` file (created by you, if you want it, in any text editor) that contains any font mappings (see subsection 9.5.1).

In addition, the configuration directory is used to save the log file, `flowframtk.log`, in the event that Shift-F11 is used (or Debug → Write Log if the command line option `-debug` is used). The emergency save all function `Ctrl-F11` (or Debug → Dump All if the command line option `-debug` is used) will create a subdirectory (using the current date and time to construct the name) and will save all open images to that directory with filenames of the form `image(n).jdr`.

---

4or simply `latexfontmap` without an extension for compatibility with Jpgfdraw
4 The Basics

The main FlowframTk window is shown in Figure 4.1.

FlowframTk uses a multiple-document interface (MDI). This means that you can have multiple images loaded in separate child windows, without having to start up new instances of FlowframTk. Most of the buttons and menu items will only be applied to the child window that currently has the focus. If there are no child windows, or if they have all been minimized, then the relevant buttons and menu items will be disabled. The only exceptions are the non-canvas specific items.

4.1 The Canvas

The canvas is the white area (that may optionally have a grid) in each of FlowframTk’s child windows on which you create your picture. It shares a child window with the preamble editor pane. The canvas and preamble areas are separated by a divider that can be adjusted to allow one side to take up more room in the window. This can be done by dragging the divider. With some look and feels, the divider has small triangular buttons which you can click on to collapse or expand one side, but not all have this function nor can some of them completely hide the preamble pane (such as the GTK+...
4.2 THE TOOLBARS

Look and Feel). You can also use the TeX/LaTeX → Preamble Editor menu item to show the preamble pane.

In select mode (but not when you’re editing or distorting a shape) you can drag and drop image files or text onto the canvas to add to the current image. In text or maths mode you can only drag and drop text onto the canvas. If you attempt to drop a file instead, you will get a new text area containing the file’s path (or URI).

4.2 The Toolbars

There are two toolbars. The horizontal toolbar positioned at the top of the main window, which allows you to manipulate objects on the canvas (as well as the save, load and new buttons) and the vertical toolbar positioned to the left of the main window, which you can use to create new paths and text areas. If a toolbar is too wide/tall, scroll buttons will appear.

You can show or hide the toolbars or change the location of the vertical toolbar so that it appears on the right of FlowframTk’s main window using the Borders tab in the Configure User Interface dialog.

The preamble pane has its own toolbar with buttons to edit the preamble text.

4.3 The Rulers

There are two rulers. The horizontal ruler positioned above the canvas which marks out the $x$-ticks, and the vertical ruler positioned to the left of the canvas which marks out the $y$-ticks. The gap between tick marks can be changed using the Settings → Grid → Grid Settings menu item.

You can show or hide the rulers using the menu item Settings → Show Rulers. You can adjust their size and number format using the Borders tab in the Configure User Interface dialog box. When the rulers are visible, the grid unit is displayed in the corner between the rulers. You can double-click on this corner to open the grid settings dialog.

4.4 The Status Bar

![Figure 4.2: The Status Bar](image)

Current Position  | Storage Unit  | Grid Lock State  | Current Magnification  | Subject Help  | Information
---|---|---|---|---|---
Image Modified  | Zoom Up  | Zoom Down  | 100%  | Click at first corner, move mouse and end

0.07 cm 4.22 cm
The status bar (Figure 4.2) is positioned along the bottom of the main window. This has the following elements:

- The current position of the pointer (or the pointer’s last position before it was moved away from the canvas). You can double-click on this area to open the Go To dialog.

- The storage unit. You can double-click on this to open the storage unit selector.

- The file status area. If the current picture has been modified, it will display the word “Modified”, otherwise it will be blank.

- The grid lock indicator. This shows if the grid lock is on or off. You can double-click on this area to toggle the grid lock setting.

- The current magnification. You can adjust this value by clicking on the plus or minus icons to move up or down the pre-defined list of zoom settings. Alternatively, in the area between them where the magnification value is displayed, you can menu-click to popup a menu or double-click to open the magnification settings dialog.

- A help button that you can click on to open the manual at the section related to the current operation. This button is only present when the current operation has a section in the manual.

- A brief message about the currently selected tool or operation. If the message is too long to fit in the provided area, you can double-click on it to open a dialog window with the full message (Figure 4.3).

![Information Dialog](image)

Figure 4.3: The Information Dialog

You can show or hide the status bar, or elements within the bar, using the Configure User Interface dialog. You can also use this dialog to change the font used in the status bar.
5 The File Menu

You can use the File menu to create a new picture, load a picture from a JDR or AJR file, save the current picture, export the current picture to a supported format (such as a \LaTeX file), assign a description to the current picture, print the current picture or quit FlowframTk.

5.1 New

To start a new picture, select File → New. This will open a new child window. You can switch between child windows using the Window menu.

5.2 Open

To load a JDR or AJR file, select File → Open. If there is already a picture in the current child window, a new child window will open to display the file. Note that although FlowframTk can export to other formats, it can only load JDR and AJR files.

If you load an image that contains a link to a bitmap and the bitmap is no longer in the same location, you will be prompted for a new link or you can discard the link. Note that if you select a new link, the \LaTeX link will also be updated. If there is insufficient memory in the JRE to load a bitmap, FlowframTk will revert to draft mode for that bitmap.

On some systems you may be able to drag and drop JDR or AJR files from a filer window onto FlowframTk’s internal desktop (the grey background of FlowframTk’s main window) and this will load each file into FlowframTk. If you drag and drop a bitmap it will be equivalent to creating a new image and then inserting the bitmap.

For example, in Figure 5.1(a) three JDR files and a PNG file have been selected and then dragged onto FlowframTk’s desktop, Figure 5.1(b). This results in four child windows, Figure 5.1(c), where one of them is a new untitled image with the link to the bitmap inserted.

If you want to open an image in a new child window using drag and drop, make sure you drop onto FlowframTk’s desktop. If you drop a file onto a text area, such as the preamble pane or the text field used to create a new text area then the filename (or URI) will be inserted instead. If you drop onto a canvas, the file contents will be added to the current image (in the case of a JDR or AJR file) or a link will inserted into the current image (in the case of a bitmap file). You can only drop a file onto the canvas in select mode (and no objects are being distorted or edited).

5.3 Recent Files

To load a recently used JDR or AJR file, use the sub menu File → Recent Files. A maximum of ten files, starting with the most recently used are listed. Note that loading a file from this list will change the open file chooser directory to that file’s directory.
Figure 5.1: Drag and Drop onto FlowframTk’s Internal Desktop
5.4 Image Description

You can use the File → Image Description dialog box to give the image a description. The description is not visible in the image, but is saved as a comment when you export the image to a \LaTeX document (see §5.6.4 Export to Single-Paged Document). If you have the Add \pdfinfo to exported \LaTeX documents option selected in the Document Settings tab of the \TeX/\LaTeX Configure Settings dialog box, the image description will be added to an exported \LaTeX document in the \Title attribute of the \pdfinfo argument.

5.5 Save and Save As

You can save the current picture in FlowframTk’s native JDR (binary) or AJR (ASCII) format using either File → Save (if it already has a name) or File → Save As (if you want to specify the filename). I strongly recommend that you save your work frequently. There is no auto-save function. The JDR format can store higher precision values than the AJR format.

See also:
- §5.6 Export

5.6 Export

Note that FlowframTk can’t load the files that it can export, so I strongly recommend that you first save the picture as a JDR or AJR file before exporting it, in case you wish to edit it later.

The File → Export menu allows you to export your image. There are essentially four types of export:

1. Export to PNG.
   This just creates a PNG file with the image as shown on the canvas (without the grid or annotations) clipped to the image’s bounding box. This export ignores all \LaTeX settings.

2. Export to \LaTeX Package or Class.
   This creates a .cls or .sty file that uses the flowfram package to create the page layout defined by the image through the functions in the \TeX/\LaTeX → Flow Frames menu.

3. Export to a pgfpicture environment.
   This creates a .tex file with the pgf code required to draw the image so that it can be included in a \LaTeX document through the \input command.

   This includes the export to \LaTeX document or encapsulated \LaTeX document as well the export to PDF, PostScript or SVG functions. These functions all create a .tex file that contains a complete \LaTeX document, including document class and document environment.
5.6.1  EXPORT TO PNG

5.6.1 Export to PNG

The export to PNG function is used when the file filter is set to PNG File (*.png) in the export dialog box. All LaTeX related settings are ignored by this function.

After specifying the file name (and confirming overwrite, if necessary) the Export to PNG dialog box is shown (Figure 5.2) where you can specify if the image should have a transparent background and if the image should be cropped.

If the Transparent Background box is checked, all colours will be converted to ARGB (alpha, red, green, blue) and the background will be transparent. If this box isn’t checked, all colours are converted to RGB and the background is set to white.

If the Crop box is checked, the exported file will be cropped to the image’s bounding box otherwise the image will be the same size as the canvas.

Figure 5.2: Export to PNG Settings

5.6.2  Export to a Class or Package

The export to class or package function is used when the file filter is set to Class (*.cls) or Package (*.sty) in the export dialog box. This creates a L\TeX{} class or package that loads the flowfram package. The pgf package is also used to create borders and backgrounds, where required. Note that only the objects that have been identified as static, flow or dynamic frames will be exported.

The early-preamble text is added before the start of the package option declarations, which provides a means to add extra package options, if required. The mid-preamble text will be placed after the class or packages are loaded and the end-preamble text is placed at the end of the class or package. The default preamble is not used.

Any occurrences of \usepackage in the image preamble will be converted to \RequirePackage on export.

If the file name has the extension .cls, a class is assumed, otherwise a package will be created. If a class file is created, the underlying class (loaded with \LoadClass) is as indicated by the document class setting, as described in §3.2.7 Setting the Document Class and Normal Font Size.

See also:

- §3.2.7 TeX Settings Dialog
- §10.1 Adding Commands to the Preamble
- §10.4 Creating Frames for Use with the flowfram Package
- §11.1 Step-by-Step Example: A House
5.6.3 EXPORT TO PGF

The export to PGF function is used when the file filter is set to pgf environment (*.tex, *.ltx) in the export dialog box. This creates a \LaTeX file containing a \texttt{pgfpicture} environment, which can then be included into a \LaTeX document using \texttt{\input}. The start of the file will include comments with code between an \texttt{\iffalse}...\texttt{\fi} block that may be required in your preamble. If necessary, copy that block into your document’s preamble.

See also:

- §3.2.7 TeX Settings Dialog
- §10.1 Adding Commands to the Preamble
- §11.1 Step-by-Step Example: A House
- §11.4 Step-by-Step Example: An Artificial Neuron

5.6.4 Export to Single-Paged Document

The export to PGF function is used when the file filter is set to LaTeX document (*.tex, *.ltx), Encapsulated LaTeX document (*.tex, *.ltx), Portable Document Format (*.pdf), PostScript (*.eps, *.ps) or Scalable Vector Graphics (*.svg) in the export dialog box.

In the case of the LaTeX document (*.tex, *.ltx) filter, a .tex file is created with the code for a single-paged \LaTeX document containing the image, where the page size is set to the canvas page size.

In the other cases, a .tex file is created with the code for a single-paged \LaTeX document containing the image, where the page size is set to the image’s bounding box. (If the bounding box is smaller than the baselineskip, the page height is set to the baselineskip, according to the given normal size for the image.)

The export to PostScript, PDF or SVG options all then run either just \texttt{pdflatex} or \texttt{latex} followed by \texttt{dvips} or \texttt{dvisvgm} to create the required format. The .tex file (and its associated temporary files) are then deleted. In the case of PostScript or SVG, if the image contains any bitmaps, FlowframTk will attempt to convert them to EPS, where necessary. If the exported file has unexpected results or fails to be created, try exporting to an encapsulated \LaTeX document and then manually running \texttt{pdflatex} or \texttt{latex}, as the issue may be due to the conversion process or it may be due to an unrecognised command or syntax error in a text area or text-path. \textbf{Note that PostScript does not support transparency.}

If a default preamble has been set (see §3 Default Preamble) the code will be included in the .tex file’s preamble. This is in addition to the contents of the image’s early-, mid- and late-preamble. For example, I have set the default preamble to:

\begin{verbatim}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\end{verbatim}
I recommend that at the very least you have the inputenc and fontspec packages in your default preamble (or fontspec if you use XeLaTeX).

If your image includes \LaTeX commands that require a particular package, you will need to add these packages to the image preamble. This is done automatically by the mapping function, if it has been enabled. See §10.1 Adding Commands to the Preamble for further details.

FlowframTk will automatically add \usepackage{pgf} to the preamble and other packages such as geometry and ifpdf. It will also add
\usepgflibrary{decorations.text}
in case the image contains any text-paths.

Changes caused by differences in the way that FlowframTk renders text areas with the way that \LaTeX typesets them can cause the image to be clipped if the bounding box has been underestimated. If this is a problem, you can switch on the Use typeblock as bounding box for pgfpicture option and use the typeblock function to mark your preferred bounding box.

For example, in Figure 5.3 I have a text area with the alternative \LaTeX text set to:

\[ \displaystyle f(\Upupsilon; \eta) = \frac{1}{2}\eta \sum_k \Upupsilon_k \cdot \Upupsilon_k \]

Below this is a path for illustrative purposes. When viewed in FlowframTk, as shown in Figure 5.3(a), the text area and path are the same widths, but when the image is exported to PDF, shown in Figure 5.3(b), the equation generated by the alternative text is wider that its representation on the canvas and has consequently been clipped (both the top of the fraction and the right end of the equation) because it exceeds the image bounding box that was computed by FlowframTk. In Figure 5.3(c), a rectangle has been added to the image. This now extends the image bounding box, so when the image is now exported to PDF, as shown in Figure 5.3(d), the equation is no longer clipped, but the new rectangle is now visible, which may not be desirable. There are two ways to deal with this. The first is to give the rectangle a transparent line colour (in addition to the transparent fill colour) but now it can only been detected on the canvas when it’s selected. The second method is to set the typeblock to the area of that rectangle (see §10.4.2 Defining the Typeblock). The easiest way to do this is to select the rectangle, use the TeX/\LaTeX \rightarrow Flow Frames \rightarrow Set Typeblock menu item to open the Typeblock dialog box, and click on the Compute Margins From Selected Path button. Then delete the rectangle. The typeblock is now shown as a grey rectangle in Figure 5.3(e). Now make sure that the Use typeblock as bounding box for pgfpicture setting is on. Redoing the export to PDF now produces the image shown in Figure 5.3(f).

See also:

- §3.2.7 TeX Settings Dialog
- §10.1 Adding Commands to the Preamble
- §9.5.6 Anchor
5.6.4 EXPORT TO SINGLE-PAGED DOCUMENT

\[ f(\mathbf{\Upsilon}; \eta) = \frac{1}{\eta} \sum_k \mathbf{u}_k \cdot \mathbf{u}_k \]

Figure 5.3: Exported Text Areas Can Overflow Bounding Box: (a) image as shown on canvas; (b) image exported to PDF (equation has been clipped); (c) rectangle added to image; (d) image from (c) exported to PDF; (e) typeblock added and rectangle removed; (f) image from (e) exported to PDF.
5.7 Print

You can print the current image using File → Print which will open the printer dialog box. If no printer is found, the error message “No printer services found” will be displayed. If this happens, check that the printer is switched on and connected to the computer. The print function uses the canvas’s rendering hints and draws the image as it’s displayed on the canvas (at 100% magnification and without the grid or annotations).

5.8 Message Window

You can display the message window using the File → Show Messages item. This usually just lists the files that have been opened, saved or exported, but warnings are sometimes written there as well. This window is opened during a read or write operation. When an external application is spawned, the abort button becomes enabled, which you can use to kill the spawned process if required.

5.9 Close

You can close the current child window, either by clicking on the child window’s close icon or by selecting File → Close. If there is any unsaved data, FlowframTk will ask for confirmation before discarding the window (see Figure 5.4). In this dialog box you can:

- click on the discard button next to the image name to discard the image;
- click on the save button next to the image name to save the image;
- click on the cancel button at the bottom of the dialog box to cancel the close operation.

![Figure 5.4: Confirm Discard Dialog (1 Modified Image).](image)

An image will only be marked as unmodified if it has been saved as a JDR or AJR file. If you have exported your image to another file type, I recommend that you also save it as a JDR file as well, in case you want to edit it later.

Note that you must finish or discard any path that is under construction before you can close an image.
5.10 Quit

To quit FlowframTk either use the menu item File → Quit or click on the close icon on the main window. All child frames will be closed. If any child frame contains unsaved data, you will be asked for confirmation before the window is discard. If there is only one modified image, the dialog box is as for the close operation shown in Figure 5.4, otherwise it's as shown in Figure 5.5, where each modified file is listed.

![Save Image? dialog box]

Figure 5.5: Confirm Discard Dialog (2 Modified Images).

As with the close operation, for each listed file, you can:
- click on the discard button next to the image name to discard the image;
- click on the save button next to the image name to save the image.

Alternatively you can:
- click on the save all button to save all the listed files;
- click on the discard all button to discard all the listed files and quit;
- click on the cancel button at the bottom of the dialog box to cancel the quit operation.
6 Creating New Objects

New paths and text areas can be created using FlowframTk’s construction mode, which can be obtained using any tool except the select tool. The tools can be selected using either the vertical toolbar or the Tools menu. Once paths and text areas have been created they can then be edited or transformed or combined to form a text-path object. You can also apply patterns to paths or text-paths.

Whilst constructing a line path or curve path, you can:

- Finish the path by pressing the Enter key or by double-clicking (instead of single-clicking) on the final vertex or by selecting Tools → Finish or by clicking on the finish button. Note that transferring the focus to another FlowframTk child window or selecting a new tool whilst you are constructing a path, will complete the current path.

- Cancel the current path by pressing the Shift-Escape key or by selecting Tools → Abandon or by clicking on the cancel button.

- Make a gap in the current path: once you have clicked on the vertex where you want the gap to start, select Tools → Gap or click on the gap button or press Ctrl-M, then click on the canvas where you want the gap to end.

  The undo/redo mechanism is disabled while you are constructing a path, however while you are creating a line path or a curve path, you can delete the previous segment using the Backspace key.

  Note that FlowframTk won’t allow you to create a path whose total width and height are both less than 1.002bp. This is to prevent accidentally creating a tiny path that can’t be seen but contributes to the total image dimensions. This restriction only applies when creating paths and does not apply to editing paths.

  Note that the path attributes will only be set once the path has been completed. Whilst the path is under construction you will only see a draft version (see Figure 6.1). If you want a path with a mixture of line and curve segments, first construct a path with only one type of segment (e.g. lines), and then use the edit path function to convert the required segments.

  If you are unable to use the mouse, you can move the pointer using Navigate → Go To which will display the dialog box shown in Figure 6.2. Enter the x and y coordinates in the x and y fields if you are using a rectangular grid, or enter the angle and radius in the Angle and Radius fields, if you are using a radial grid. The function key F4 will emulate a single mouse click in construction mode.

See also:

- §8.6 Editing Control Points
- §8.7 Symmetric Shapes
- §8.29 Converting a Path or Text-Path into a Pattern
CHAPTER 6. CREATING NEW OBJECTS

Figure 6.1: Path attributes are only set once the path is completed: (a) path under construction; (b) path completed.

Figure 6.2: Go To Co-ordinate Dialog Box
6.1 Line Paths

To construct an open line path, select the open line tool, either by clicking on the open line button or by selecting Tools → Open Line (Ctrl-L).

To construct a closed line path, select the closed line tool, either by clicking on the closed line button or by selecting Tools → Closed Line (Ctrl+Shift-L).

Use the primary mouse button to click on each vertex defining the path. To complete the path, do one of the following:

- Double-click instead of single-clicking on the final vertex: this performs the combined function of defining the vertex and finishing the path. If you use this method, be careful not to accidentally create two coincident vertices at the end point, or it will cause a problem for any mid or end marker that you apply.

- Single-click on the final vertex and then complete the path by pressing the Enter key or by clicking on the finish button or by selecting Tools → Finish.

If you have used the closed line tool, the path will automatically be closed by inserting a line between the end vertex and the initial vertex.

See also:

- §6.3 Rectangles
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §8.6 Editing Control Points
- §11.1 Step-by-Step Example: A House
- §11.9 Step-by-Step Example: A House With No Mouse

6.2 Curve Paths

To construct an open curve path, select the open curve tool, either by clicking on the open curve button or by selecting Tools → Open Curve (Ctrl-K).

To construct a closed curve path, select the closed curve tool, either by clicking on the closed curve button or by selecting Tools → Closed Curve (Ctrl+Shift-K).

Use the primary mouse button to click on each vertex in the path. There is no way to specify the location of the control points defining the curvature of the path whilst the
path is under construction, however, once the path has been completed, it is possible to move these control points using the edit path function.

To complete the path, do one of the following:

- **Double-click** instead of single-clicking on the final vertex: this performs the combined function of defining the vertex and finishing the path. If you use this method, be careful not to accidentally create two coincident vertices at the end point, or it will cause a problem for any mid or end marker that you apply.

- **Single-click** on the final vertex and then complete the path by pressing the Enter key or by clicking on the finish button or by selecting Tools → Finish.

If you have used the closed curve tool, the path will automatically be closed by inserting a curve between the end vertex and the initial vertex.

See also:

- §6.4 Ellipses
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §8.6 Editing Control Points
- §11.4 Step-by-Step Example: An Artificial Neuron

### 6.3 Rectangles

To construct a rectangle, select the rectangle tool either by clicking on the rectangle button or by selecting Tools → Rectangle (Ctrl-R).

Use the primary mouse button to click where you want the first corner to go, then move (not drag) the mouse to the opposite corner, and click or press the Enter key to complete the path.

Note that this function is just a shortcut to using the closed line function. Once the rectangle is created, it is simply another closed path, and can be edited in exactly the same way.

See also:

- §6.1 Line Paths
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style

1You may, of course, want to do this intentionally, in which case ignore this caveat.
6.4 Ellipses

To construct an ellipse, select the ellipse tool either by clicking on the ellipse button or by selecting Tools → Ellipse (Ctrl-E).

Use the primary mouse button to click on the centre point of the ellipse, and then move (not drag) the mouse until the ellipse has reached the desired dimension, and click or press the Enter key to complete the path. If you want to create a circle, I recommend that you first lock the grid or use the Navigate → Go To menu item.

Note that this function is just a shortcut to using the closed curve function. Once the ellipse is created, it is simply another closed path, and can be edited in exactly the same way.

See also:
- §6.2 Curve Paths
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §8.6 Editing Control Points
- §11.3 Step-by-Step Example: Cheese and Lettuce on Toast

6.5 Text

Text areas can be created to annotate images. Each text area has text that’s displayed on the canvas but may have alternative text to use when exporting to a \LaTeX file. (This includes the export functions that create a temporary \LaTeX file, such as the export to PDF function.) There are two tools to create a text area: the text tool and the maths tool. These affect the default alternative text for the new text area in different ways. You can later edit the alternative text, if the default isn’t suitable.

The maths tool (which can be selected either by clicking on the maths tool button or by selecting Tools → Maths) will automatically insert the math-shift $ symbol at the start and end of the alternative text. In addition, if the Auto escape maths symbols setting is on, certain characters will be replaced by a command (or commands) in the alternative \LaTeX text. If these commands require a
package, the mapping function will automatically add the package to the image’s early-preamble. The mapping function will first search the early-preamble code to check if the package is already present, but it doesn’t check the mid- or late-preamble code or the code in the default preamble.

The text tool (which can be selected either by clicking on the text tool button or by selecting Tools → Text) will only create an alternative \LaTeX{} text if the Auto escape text symbols setting is on and there is an appropriate mapping. Again, if these \LaTeX{} commands require a package, the mapping function will automatically add the package to the image’s early-preamble.

In either case, once you have selected the required tool, click with the primary mouse button at the position where you want the text to start. This will produce a shaded area with a cursor in which you can type no more than a single line of text (Figure 6.3). Clicking inside this shaded area will move the cursor around the text area under construction.

![Sample text area](image)

**Figure 6.3: Text Area Construction Field**

When you want to complete a text area, press Enter (which will start a new text area on the line below) or click anywhere on the canvas outside of the current text area (which will start a new text area at the new location) or use the finish button or Tools → Finish. Selecting another tool whilst a text area is under construction will finish the current text area, unless you’re switching between the text and maths tools. (If you do switch between the text and maths tools, the alternative \LaTeX{} text is only created when you finish the text area, so the mappings applied will be governed by the tool currently selected when you completed the text area.)

Once a text area has been completed, the only way to edit it is via the edit text function. If you click the mouse on the location of a completed text area (while the text/maths tool is selected) you will simply create a new overlapping text area.

If your operating system supports drag and drop, you can also drag and drop text onto the canvas. If the drop point is inside the text area construction field, the dropped text will be inserted into the field (newline characters will be converted to spaces). If the drop point is outside the text area construction field, a new text area will be created for each line of dropped text. The mapping applied to the dropped text will be according to the currently selected text tool. If text is dropped onto the canvas in select mode, the text mappings (not maths mappings) will be applied. If a file is dropped onto the canvas in text- or maths-mode, the file path (or URI) will be added as a new text area.

**Figure 6.4** illustrates drag and drop to create new text areas. In Figure 6.4(a) I have four lines of text selected in a text editor. The second line simply contains two space
characters (which aren’t visible). These four lines of text are then dragged onto the canvas, Figure 6.4(b), and dropped. The drop location (the location of the pointer when the mouse button was released) is directly on the canvas, not on the text area construction field (which currently isn’t visible). This creates three new text areas, Figure 6.4(c). The line solely consisting of white space hasn’t created a text area but has contributed to the vertical offset of the following text area. In Figure 6.4(d), the same three lines of text are dragged onto the text area construction field and dropped at the cursor, Figure 6.4(e). This has inserted the dropped text into the text area construction field. The new line characters have been converted to spaces and the text area construction field is awaiting further input.

Whilst a text area is under construction, you can activate the text area popup menu, illustrated in Figure 6.5, with a menu-click (or use the context-menu key).

The text area popup menu provides the following functions:

**Copy (Ctrl-C)**
Copies selected text to the clipboard.

**Cut (Ctrl-X)**
Cuts selected text to the clipboard.

**Paste (Ctrl-V)**
Pastes text from the clipboard.

**Select All (Ctrl-A)**
Selects all the text.

**Insert Symbol (Insert)**
Opens the Insert Symbol dialog box if you want to enter a symbol that doesn’t appear on your keyboard.

The Insert Symbol dialog box (see Figure 6.6) has a field at the top which contains the text currently in the text area. If you know the hexadecimal Unicode value for the character you want to insert, you can type the number into the Unicode box and press the Select button $\checkmark$ to insert it into the text area at the caret.

On the right hand panel below the Unicode field there is an enlarged image of the selected character. If there’s an associated mapping it will be displayed below the image (see Figure 6.6), but remember that this mapping may change if you switch between the text and maths tools before completing the text area.

Alternatively, you can use the button panels on the left to select the character you want to insert into the text field. Use the left hand list to display the require Unicode block and either click on the button with the required character on it to insert and display the symbol or hold the shift key down while you click to just display the symbol in the right hand panel without inserting it into the text field. The available Unicode blocks and symbols are govern by the language configuration setting in the Configure User Interface dialog.

Once the text area has been finished (by clicking on the finish button or by pressing return or by switching to a non-text tool) any packages that are required by the mappings will be added to the early-preamble pane, as shown in Figure 6.7. Note that the canvas and the preamble panes have separate undo/redo managers so if you undo a new text area it will remove the new text area but won’t remove the modification to the preamble. You will need to switch to the early-preamble panel and use its undo button or popup menu item.
Figure 6.4: Drag and Drop Text: (a) drag initiated on some selected text in another application; (b) selected text dragged onto canvas; (c) the text that was dropped onto the canvas in (b) has been converted into two text areas; (d) the selected text from (a) is now dragged onto the text area construction field; (e) the dropped text has been inserted into the construction field.
6.5 TEXT

Figure 6.5: Text Area Popup Menu

Figure 6.6: Insert Symbol Dialog Box

Figure 6.7: Package Required by Mapping Added to the Early Preamble
Note that the text in your pgfpicture environment may not look exactly the same as in FlowframTk due to font differences as well as the translation of \LaTeX{} commands.

See also:

- §8.8 Editing Text Areas
- §9.5.6 Anchor
- §3.2.7 TeX Settings Dialog
- §10.1 Adding Commands to the Preamble
- §9.4 Text Colour
- §9.5 Text Style
- §8.30.1 Converting a Text Area, Text-Path or Pattern to a Path
- §8.31 Splitting Text Areas
- §5.6.4 Export to Single-Paged Document
- §11.4 Step-by-Step Example: An Artificial Neuron
- §11.9 Step-by-Step Example: A House With No Mouse
7 Bitmaps

FlowframTk is primarily a vector graphics application, however it is possible to insert a raster graphics image (bitmap) into your picture for background effects or if you want to annotate a bitmap (as was done in Figure 6.6 in the previous section). Note that FlowframTk does not save the actual raster graphics data in either the JDR or the AJR file, but instead it creates a link to the original file. You can’t edit the actual bitmap data in FlowframTk. However you can scale, rotate or shear the link. If you change the location of the file containing the bitmap, when FlowframTk reloads the JDR or AJR file it will prompt you for the new location or discard the link.

If you use another application to edit the bitmap whilst you have a picture with a link to it displayed in FlowframTk, you will need to select Bitmap \(\rightarrow\) Refresh to update the image.

To insert a bitmap into your picture, first make sure you are using the select tool (and no shapes are being edited or distorted), and then select the menu item Bitmap \(\rightarrow\) Insert Bitmap and a dialog box will appear in which you can choose the required bitmap. The bitmap will initially appear in the top left hand corner of the canvas but can be moved to a new location. If your operating system supports drag and drop, you can also drag a bitmap file onto the canvas (in select mode) and it will be inserted at the drop location.

If there is insufficient memory in the JRE to load a bitmap, FlowframTk will revert to draft mode to display that bitmap. For example, in Figure 7.1 several photos have been inserted into an image. Since photos tend to be quite large, there is insufficient memory to load the final photo, so it is displayed in draft mode instead. Note that draft mode will also be used when printing or when exporting to PNG. Since \LaTeX\ files only contain a link to the bitmap, draft mode should not affect exporting to \LaTeX\ files or to formats that use \texttt{latex} or \texttt{pdflatex} as an intermediate step.

Note that the amount of memory available to any Java application is set at startup. The default maximum value is usually around 64Mb but can be changed via the JRE command line options. If you run FlowframTk from the shell script \texttt{flowframtk}, then you can set the environment variable \texttt{JVMOPTS} to change the default configuration. See section 3.1 for further details. If you are running FlowframTk from Windows, you will need to check the JRE documentation.

7.1 Properties

To change a bitmap’s properties, select the required bitmap and select the Bitmap \(\rightarrow\) Properties menu item. This will open up a dialog box shown in Figure 7.2. If you want to change the path name to the bitmap, you can either type it directly into the filename field or click on the Browse button. You can also change the transformation matrix applied to the bitmap link.

If you want to export your picture to a \LaTeX\ file or to a format that uses \texttt{latex} or \texttt{pdflatex} as an intermediate step, the \LaTeX\ command can either be \texttt{\pgfimage} or \texttt{\includegraphics} and is specified in the LaTeX Command field. The command argument in either case must use a forward slash / as the directory divider. If the Auto checkbox is selected, this substitution will be performed automatically by the export function. Alternatively, you can unselect the Auto checkbox which will enable the \LaTeX\ image path field in which you can enter the argument to be used by the
7.1 PROPERTIES

Figure 7.1: Bitmaps are displayed in draft mode when there is insufficient memory in the JRE. The area taken up by the image is displayed as a semi-transparent light grey rectangle with the bitmap's file name in square brackets.

Figure 7.2: Bitmap Properties Dialog
image command. If you use the export to PostScript or SVG function, FlowframTk will attempt to create an EPS version of the bitmap (if it doesn’t already exist) since latex (as opposed to pdflatex) can’t include bitmap formats, such as PNG and JPEG.

See also:

- §3.2.6 Bitmap Settings
8 Selecting and Editing Objects

In order to edit an object, you must be in select mode. To do this either click on the select button or use the menu item Tools → Select (Ctrl-P). An object can be selected using any of the following methods:

- Click on it with the primary mouse button.
- Double-click the primary mouse button to select the object behind the current object.
- Use Control-click (i.e. click whilst holding down the control key) if you want to add an object to the current selection.
- Click on an empty part of the canvas and drag. A dashed rectangle will appear. When you release the mouse button, any objects within that region will be selected. (If you have the shift key depressed, only those objects which are completely inside the dashed rectangle will be selected, but make sure you release the mouse button before releasing the shift key.)
- Use Navigate → Select (Shift-F5) to select the next object in the stack. (Starting from the frontmost object and heading towards the back.) This will cycle back to the start when it reaches the end of the stack.
- Use Navigate → Skip (F6) to deselect the selected object closest to the backmost object, and select the next object in the stack (heading towards the back). This will cycle back to the start when it reaches the end of the stack. If you have more than one object selected, the remaining objects will stay selected.
- Use Navigate → Add Next (Shift-F6) to add the next object in the stack to the selection (starting from the front and heading towards the back). This will cycle back to the start when it reaches the end of the stack.
- Use Navigate → Find By Description or Navigate → Add By Description to select an object by its description. (If an object hasn’t been given a description, a generic description will be supplied instead.) The former will deselect all other objects, the latter will add the object to the current selection.
- Use Edit → Select All (Ctrl-A) to select all objects.

When an object is selected, a dashed red/grey rectangle will be displayed around it. (This rectangle may optionally have hotspot regions.) Note that individual elements of a group can not be selected independently of the group. When you select a group, you will only see a dashed red/grey rectangle around the bounding box of the group, not around the individual elements of the group.

To deselect an individual object, click on that object whilst depressing the shift key. To deselect all objects, click on an empty part of the canvas, or use Edit → Deselect All (Ctrl+Shift-A). Selecting another tool will also deselect all objects.

In select mode, you can also menu-click to activate the select popup menu. The contents of this menu vary according to what types of objects have been selected, if any (see Figure 8.1).
8.1 MOVING AN OBJECT

Figure 8.1: Popup menus in select mode depend on what objects have been selected: (a) no objects selected; (b) only text-paths have been selected; (c) only paths have been selected; (d) only text areas have been selected; (e) only bitmaps have been selected; (f) groups or a selection of different object types have been selected.

In select mode you can drag and drop JDR or AJR files onto the canvas (provided your operating system supports drag and drop) which will add all the objects from those files to the current image. The new objects will be added to the current selection. You can’t drag and drop if a shape is being edited or distorted.

If text is dropped onto the canvas in select mode, the text mappings (not maths mappings) will be applied. If a file is dropped onto the canvas in text- or maths-mode, instead of select mode, the file path (or URI) will be added as a new text area.

8.1 Moving an Object

To move an object or objects, first select the objects you want to move and then do one of the following:

- Depress the primary mouse button somewhere inside the selection, and drag the mouse. Release the mouse button when the objects have reached their required location. If you only want to move the object by a very small amount, and your mouse is very sensitive or you have difficulties with fine motor co-ordination, depress the mouse button and instead of dragging use the arrow keys to move the pointer.

- Use Edit → Move By to show the Move By dialog box (Figure 8.2). In the field marked x enter the horizontal displacement, and in the field marked y enter the vertical displacement. For example, to move the selected objects 10 units to the right and 20 units down, type 10 in the x field and 20 in the y field. To move left or up, use a negative value.
8.2 Cut

To cut a selection of objects to the clipboard, use Edit → Cut. Note that it will be stored on the clipboard as a JDRGroup Java object, not as text or raster graphics, so you won’t be able to paste it into a different application. If you want to cut a piece of text from a text area, you will need to use the edit text area function. Note that the preamble panes have their own cut button.

8.3 Copy

To copy a selection of objects to the clipboard, use Edit → Copy. Note that it will be stored on the clipboard as a JDRGroup Java object, not as text or raster graphics, so you won’t be able to paste it into a different application. If you want to copy a piece of text from a text area, you will need to use the edit text area function. Note that the preamble panes have their own copy button.

8.4 Paste

To paste a selection of objects from the clipboard, use Edit → Paste. If you want to copy text from another application, and paste it into a text area in FlowframTk, you will have to create a new text area, and use the text area popup menu to paste the text into the text area. If you want to paste plain text into an existing text area, you will need to use the edit text area function. Note that the preamble panes have their own paste button.

8.5 Object Description

You can assign a description to an object using the Edit → Object Description menu item. This will display the dialog box shown in Figure 8.3. Type the description into the text field, and click on Okay or press Enter.

The description will not appear in the image, but it can be used to locate and select objects on the canvas using the Navigate → Find By Description or Navigate → Add By Description menu items. The description may also be used as a comment when exporting images, depending on the file type. Note that if you assign a description to a group, you will lose the description if you later ungroup it.
8.6 Editing Control Points

To move, delete or add control points, open or close paths, or to convert segments from one form (line, gap, cubic Bézier) to another, first select the path, and then either click on the edit path icon or select Edit → Path → Edit Path (Ctrl-I). (Note that you should not have any other objects selected.) The path will then be displayed in draft format. The currently selected control point and the currently selected segment will appear in red. The other control points will be orange.

A text-path object can have its underlying path edited in the same way as a normal path, but in edit mode you will also see the text (without anti-aliasing). Note that you can not edit a path if it belongs to a group; you must first ungroup it.

Use one of the following methods to select a control point:

- **Click** on the control point. (If two or more points coincide with the location of the mouse, the point with the lowest index will be selected.) Remember that if the grid lock is on, mouse clicks will be translated to the nearest tick mark, so even if the pointer is positioned over a control point, the nearest tick mark may be outside the control point bounds. If you want to use the mouse to select and move a control point, make sure that you first click to change the selection before initiating a drag or you may move the wrong control.

- **Press F6 or Shift-F6** until the required control point is selected. (You will need to use this method if two or more control points are in the same location and you don’t want the one with the lowest index. You will also need to use this method if the grid lock is on and the control point’s bounding box doesn’t lie on a tick mark.)

Use one of the following methods to move a control point:

- **Use the mouse to drag the point to its new location.** (You can initiate dragging outside of the selected control point, which is useful if the grid lock is on or the controls are cluttered together.)

- **Use the edit path popup menu** (F3) and select Co-ordinates (F7). Enter the new co-ordinates in the dialog box. (You will need to use this method if the grid lock is on and you want to move the point by an interval that is not a multiple of the gap between tick marks.)

- **Use the edit path popup menu** and select Snap To Grid to move the control point to the nearest tick mark.
8.6 EDITING CONTROL POINTS

To exit edit mode deselect the edit path tool (Ctrl-I). If you have the Canvas click to
exit option checked in the Graphics section of the Configure User Interface dialog, then
you can also exit edit path mode by clicking the mouse on the canvas outside of any of
the path’s control points.

Whilst a path is in edit mode, you can use the edit path popup menu which provides
functions to select or edit control points or the segments that they define. The following
functions are available:

Next Control (F6)
Select the next control point. This is an alternative to using the mouse to select
the point.

Previous Control (Shift-F6)
Select the previous control point.

Delete Point (Delete)
Delete the currently selected control point. (This function is not available for
control points that govern the curvature of Bézier segments, the controls on the
line of symmetry for symmetric paths or the pattern adjustment controls.) If the
control point is the first or last point in an open path it will delete the corre-
sponding segment, otherwise it will replace two adjacent segments with a single
segment. If the path is open and only has one segment, or if the path is closed and
has two segments, deleting a control point will delete the path or the text-path
object.1

Add Point (Insert)
Add a new control point in the middle of the currently selected segment (thus
replacing a single segment with two segments). This will actually add three new
points if the segment is a Bézier curve as it will also create the required curvature
control points.

Convert To Line
Convert a curve segment or a gap to a line segment.

Convert To Curve
Convert a line segment or a gap to a curve segment. The curvature control points
will be positioned so that the segment forms a straight line. These can then be
moved as required.

Convert To Move
Convert a line or curve segment to a gap.

Path Symmetry
This submenu can be used to add symmetry to the selected shape. (See §8.7
Symmetric Shapes for further details.)

Continuity

If the selected segment is a Bézier curve this submenu provides functions that
adjust the curvature control point to ensure that the gradient at the nearest join is

---

1The text will also be lost when the text-path is deleted.
8.6 EDITING CONTROL POINTS

Continuous. This menu isn’t available if it’s not possible to do this (for example, if the nearest join is an end point).

There are two items in this submenu that are only enabled if the selected control point is a curvature control. The Continuity $\rightarrow$ Equidistant function will move the control point so that it has the same gradient direction and magnitude as the gradient vector on the other side of the join. The Continuity $\rightarrow$ Relative function will move the selected curvature control so that it has the same direction as the gradient on the other side of the join, but its magnitude will remain unchanged.

For example, in Figure 8.4 the path was originally an open line path with three line segments. The middle segment was selected and converted to a Bézier curve using the Convert To Curve function (Figure 8.4(a)). The Continuity $\rightarrow$ Relative function was then used to change the starting gradient of the Bézier segment to make a smooth join between the first two segments (Figure 8.4(b)). The Bézier curve’s third control point, which governs the end curvature, was selected, and the Continuity $\rightarrow$ Relative function was again used to change the end gradient of the Bézier segment to make a smooth join between the last two segments (Figure 8.4(c)).

The toggle menu item Anchor is only available when a control point on the join between two Bézier curves has been selected. If this item is selected, when you adjust one of the adjacent curvature control points, the corresponding curvature control on the other segment will be adjusted to maintain continuity. An anchor image will appear in the control joining the two segments when this setting is on (as shown in Figure 8.5).

Open Path Menu

Open a closed path. There are two options available:

- **Remove Last Segment**
  Opens the path, removing the last segment (Figure 8.6(b)).

- **Keep Last Segment**
  Opens the path, but keeps the last segment (Figure 8.6(b)).

Close Path Menu

Close an open path. There are three options available:

- **Close With Line**
  Close the path with a line between the last and first control points of the original path (Figure 8.7(a)).

- **Close With Curve**
  Close the path with a Bézier curve between the last and first control points such that the curve is continuous at the join between the first and last segments of the original path (Figure 8.7(b)).

- **Merge Ends**
  Close the path, merging the last control point of the original path with the first control point (Figure 8.7(c)).

Co-ordinates (F7)

This menu item will display a dialog box in which you can set the control point’s
8.6 Editing Control Points

Figure 8.4: Making the join between segments continuous: (a) the middle segment of an open line path has been converted into a Bézier curve; (b) the gradient at the start of the curve is now the same as the gradient at the end of the previous segment; (c) the gradient at the end of the curve is now the same as the gradient at the start of the next segment.

Figure 8.5: Continuity Anchor
8.6 EDITING CONTROL POINTS

Figure 8.6: Opening a path: (a) the original closed path; (b) the path in (a) was opened, removing the final segment; (c) the path in (a) was opened, keeping the last segment.

Figure 8.7: Closing a path: (a) the original path; (b) the path in (a) was closed with a line; (c) the path in (a) was closed with a curve continuous at the join between adjacent segments; (d) the path in (a) was closed, merging the end points.
8.7 SYMMETRIC SHAPES

$x$ and $y$ values (instead of dragging the point to the required location). Note that rounding errors may occur if the unit used in this dialog doesn’t have a convenient conversion factor with the storage unit.

Snap To Grid (Ctrl+Shift-S)
Move the currently selected control point to the nearest tick mark.

Break path
Break the path into two separate paths at the end of the currently selected segment (not at the currently selected control point). If the object is a text-path, the new text-paths will both have the same text (that is, the text is not broken between them).

See also:
- §8.22 Reversing a Path’s Direction
- §8.23 Merging Paths
- §8.24 Path Union
- §8.25 Exclusive Or Function
- §8.26 Path Intersection
- §8.27 Path Subtraction
- §8.30 Converting to a Path
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.3 Line Style
- §11.2 Step-by-Step Example: Lettuce on Toast
- §11.5 Step-by-Step Example: Bus
- §11.9 Step-by-Step Example: A House With No Mouse

8.7 Symmetric Shapes

A shape can have symmetry added to it using the Path Symmetry submenu of the edit path popup menu described in the previous section.

Take care with closed symmetric paths. Unexpected results may occur, particularly if the path contains any gaps. This may cause the stroked or filled shape to appear unsymmetric. For example, Figure 8.8(a) shows the original (non-symmetric path). This was then given a line of symmetry and the path appears symmetric, as shown in Figure 8.8(b). In Figure 8.8(c), two of the line segments have been converted to gaps. The shape still appears symmetric although the filled area has changed, but in Figure 8.8(d) the path has been closed with a line so although the control points that make up right side of the complete path are a reflection of the original points on the left side, the shape no longer appears symmetric.

The Path Symmetry submenu provides the following functions:
Figure 8.8: Symmetric Path with Gaps: (a) the original path; (b) symmetry has been added; (c) two line segments have been replaced with gaps; (d) the path has been closed.
8.8 EDITING TEXT AREAS

Has Symmetry
If this menu item is selected, symmetry will be added to the path. For example, Figure 8.9(a) shows a path in edit mode, and Figure 8.9(b) shows the path with symmetry applied to it. There are now two extra control points (coloured blue). These points govern the line of symmetry. In Figure 8.9(c), these two controls have been moved.

If you later decide to remove the symmetry, deselect Path Symmetry → Has Symmetry.

Adding symmetry to a closed shape may cause unexpected results as the shape will be first opened (without removing the last segment), the symmetry will be added, and then the symmetric shape will be closed, merging the end points.

Anchor Join
When you add symmetry to a path, the final control point of the underlying path is anchored to the line of symmetry. That is, it can only move along the line defined by the two blue control points. To remove the constraint, deselect this menu item. In Figure 8.9(d), the Anchor Join item was deselected, and the end control was then moved away from the line of symmetry.

Note that this function places a gap (move) segment between the end control and its symmetric counterpart, which will produce an unsymmetric effect if the path is then closed. This gap can be changed to a line or curve, using Convert To Line or Convert To Curve, as described in §8.6 Editing Control Points. In Figure 8.9(e), the join has been changed to a curve. Unlike the Bézier curves in the non-symmetric paths, this curve only has one curvature control.

Anchor Start Control
This menu item is only available for closed symmetric paths. If you close a symmetric path using the Merge Ends function, the first control point of the underlying path will be anchored to the line of symmetry. The Path Symmetry → Anchor Start Control menu item will remove this constraint.

For example, Figure 8.10(a) shows a closed symmetric path (a closed version of Figure 8.9(e)). The anchor constraint on the first control was then removed and the control was moved to the left (Figure 8.10(b)). As with the join segment (above) the closing segment between the start control and its reflection can be changed to a curve with one curvature control (Figure 8.10(c)).

See also:

- §8.29 Converting a Path or Text-Path into a Pattern
- §11.10 Step-by-Step Example: A Lute Rose

8.8 Editing Text Areas

To insert or delete characters from a text area or text-path first select the text area or text-path, and then select Edit → Text → Edit text (Ctrl+Shift-I). (Note that you should

\[2\text{The line of symmetry extends infinitely though the two controls, but only the part of the line between the two points is actually displayed in edit mode.}\]
Figure 8.9: Adding Symmetry to a Path: (a) original path; (b) symmetry added to path in (a) the two blue controls govern the line of symmetry; (c) the line of symmetry has been moved, altering the overall appearance of the shape; (d) the end anchor constraint has been removed and the end control has been moved away from the line of symmetry; (e) the joining segment has been converted to a curve with only one curvature control.
Figure 8.10: Closed symmetric path: (a) the symmetric path in Figure 8.9(e) has been closed — the first control is now anchored to the line of symmetry; (b) deselecting the close anchor constraint allows the start control to be moved away from the line of symmetry; (c) the segment closing the symmetric path has been changed to a curve.
not have any other objects selected.) This will display the Edit Text dialog box (Figure 8.11(a)) in which you can modify the text as appropriate. If you are editing the text of a text-path, there will be an extra panel visible, shown in Figure 8.11(b).

Note that you can not edit a text area or text-path if it belongs to a group. Deleting all the characters within a text area or text-path isn’t permitted and will result in the error message “Empty string”.

![Figure 8.11: Edit Text Dialog Box: (a) regular text area; (b) text-path](image)

The text area popup menu is available in the top text field allowing you to Select All the text, Cut or Copy selected text to the clipboard, Paste text from the clipboard, or insert a symbol using the Insert Symbol menu item. This is the same as the popup menu used when creating a new text area.

If you want to specify alternative text to appear in a LaTeX document, click on the button marked Different, and enter the alternative in the bottom field (see Figure 8.11(b)). The text area popup menu is not available in this field, but you can still use Ctrl-A, Ctrl-C, Ctrl-X and Ctrl-V to select all the text, copy to the clipboard, cut to the clipboard or paste from the clipboard, respectively. Note that the exported text may occupy a larger or smaller area in the LaTeX document than it does in FlowframTk, so you may also need to change the anchor or set the image margins (see §5.6.4 Export to Single-Paged Document).

You can use the Re-Map button to generate the alternative text in the bottom field by applying mappings to the text in the top field. If the original alternative text starts and ends with a dollar $ symbol, the maths-mode mappings will be used, otherwise the text-mode mappings will be used. If the original alternative text is empty, you can just type a dollar symbol in it and click on the Re-Map button to generate a maths-mode mapping. The original alternative text will be completely replaced by the text from the top field with the appropriate mappings applied. You can then edit this if necessary.

The LaTeX export functions use the \texttt{pgf} text decoration to implement text-paths. This allows you to insert declarations, such as \texttt{\LaTeX}, part way through the text by placing them between delimiters. By default these delimiters are the vertical bar (pipe) character | but this can be changed in the Left Delimiter and Right Delimiter fields (see Figure 8.11(b)). Note that the vertical anchor setting is ignored by the \LaTeX export functions. It’s best to avoid maths in text-paths. See the \texttt{pgf} manual for further details about text decorations.
The alternative text may not be used by export functions if the text-path has been made an outline or the text area/text-path has a gradient paint. The export behaviour under those circumstances is dependent on your \LaTeX{} text settings.

See also:
- §3.2.7 TeX Settings Dialog
- §6.5 Text
- §9.4 Text Colour
- §9.5 Text Style
- §8.31 Splitting Text Areas
- §8.30.1 Converting a Text Area, Text-Path or Pattern to a Path
- §11.4 Step-by-Step Example: An Artificial Neuron

## 8.9 Combining a Text Area and Path to Form a Text-Path

A text area and a path can be combined to form a text-path. The underlying path will not be visible (except in path edit mode) and the text will run along the path. If the original text area was in outline mode, the new text-path will also be in outline mode, possibly with a fill colour, depending on the original text area and path fill colours. (If the original text area didn’t have a fill colour, the path fill colour will be applied.)

The horizontal anchor determines whether the text should start at the first control point of the underlying path or if it should be centred along the path or if it should be right aligned at the end control point. The vertical anchor determines whether the base, bottom, top or middle of the text should be aligned on the path. However, the vertical anchor isn’t implemented by the \LaTeX{} export functions. Note that if the text is longer than the path, the text will be truncated.

For example, the text area and path in Figure 8.12(a) are combined to form a text-path. The original text area’s horizontal anchor was set to left, so the text along the path starts at the first control point in Figure 8.12(b). In Figure 8.12(c) the horizontal anchor has been changed to centre, and in Figure 8.12(c) the horizontal anchor has been changed to right.

Once a path has been combined with a text area, the path line style attributes are lost as the path is only used as a guide to position the text. Most path functions, such as path union, are applied to the underlying path and the text is adjusted to follow the new path. Transformations using the rotate, scale and shear functions are applied to the underlying path not the text. You can either transform the text using the transformation functions before combining it with a path or transform it after combining by changing the text transformation matrix.

Note there is a difference between applying symmetry to a text-path and converting a text area and symmetric shape to a text-path. For example, consider the text area and path in Figure 8.13(a). If you first combine them to form a text-path (Figure 8.13(b))
8.9 COMBINING A TEXT AREA AND PATH TO FORM A TEXT-PATH

Figure 8.12: Combining a text area and path to form a text-path: (a) the original text area and path; (b) the resulting text-path with left horizontal anchor; (c) centred anchor; (d) right anchor. (The text-paths are in edit mode to show the underlying path.)
and then add symmetry (Figure 8.13(c)), the result is a text-path where the text is reflected across the line of symmetry. Conversely, applying symmetry to the path first (Figure 8.13(d)) and then combining with the text area yields a text area where only the underlying path has symmetry (Figure 8.13(e)).

A similar effect applies with other types of composite shapes.

Restrictions apply to text-paths with the export functions as some text-path effects aren’t emulated in \LaTeX, such as the vertical anchor, gradient paint and outlines. You can determine the behaviour on export via the \TeX Configuration settings.

See also:
- §8.8 Editing Text Areas
- §8.28 Separating a Text-Path into a Text Area and Path
- §8.29 Converting a Path or Text-Path into a Pattern

8.10 Text Outlines

A text area or text-path can be rendered as an outline by selecting it and then using the Edit → Text → Outline menu item. For example, Figure 8.14(a) shows a standard text area and Figure 8.14(b) shows that text area rendered as an outline. If the outline mode is set, you can apply a fill colour using Edit → Fill Colour.

Note that although text-paths can be rendered with an outline in FlowframTk, the \LaTeX export functions can’t emulate this and will either export the text-path without the outline setting or will export it as a path (in which case the alternative text will be ignored) depending on your \TeX Configuration Setting.

8.11 Reducing to Grey Scale

Line colours, fill colours and text colours can be reduced to grey scale using Edit → Adjust Colour → Reduce to Grey Scale. Only selected paths and text areas will be affected. If you want to reduce a bitmap to grey scale you will need to use a bitmap editor.

See also:
- §8.13 Fade
- §8.12 Colour Space Conversions
- §8.11 Reducing to Grey Scale
- §8.14 Removing Translucency
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.4 Text Colour
8.11 REDUCING TO GREY SCALE

Figure 8.13: Symmetric text-paths: (a) original text area and path; (b) text area and path in (a) have been combined to form a text-path; (c) the text-path in (b) has had symmetry applied to it in edit path mode; (d) the path in (a) has had symmetry applied to it; (e) the text area and symmetric path in (d) have been combined to form a text-path.

SAMPLE

Figure 8.14: Text Outline: (a) original text area; (b) outline.
8.12 Colour Space Conversions

Line colours, fill colours and text colours can have their colours converted to a different colour space using the functions \texttt{Edit \rightarrow Adjust Colour \rightarrow Convert to CMYK}, \texttt{Edit \rightarrow Adjust Colour \rightarrow Convert to RGB} and \texttt{Edit \rightarrow Adjust Colour \rightarrow Convert to HSB}.

\begin{itemize}
  \item \texttt{Note that colour space conversions are not exact. You may not end up with the desired effect.}
\end{itemize}

See also:
\begin{itemize}
  \item \S8.13 Fade
  \item \S8.12 Colour Space Conversions
  \item \S8.11 Reducing to Grey Scale
  \item \S8.14 Removing Translucency
  \item \S9.1 Line Colour
  \item \S9.2 Fill Colour
  \item \S9.4 Text Colour
\end{itemize}

8.13 Fade

Line colours, fill colours and text colours can be faded (transparency increased) using \texttt{Edit \rightarrow Adjust Colour \rightarrow Fade Alpha}. Only selected \texttt{paths} and \texttt{text areas} will be affected. If you want to fade a \texttt{bitmap} you will need to use a bitmap editor that provides that function.

See also:
\begin{itemize}
  \item \S8.11 Reducing to Grey Scale
  \item \S8.12 Colour Space Conversions
  \item \S8.14 Removing Translucency
  \item \S9.1 Line Colour
  \item \S9.2 Fill Colour
  \item \S9.4 Text Colour
\end{itemize}

8.14 Removing Translucency

Line colours, fill colours and text colours can have the translucency removed using \texttt{Edit \rightarrow Adjust Colour \rightarrow Remove Translucency}. Only selected \texttt{shapes} and \texttt{text areas} will be affected. This function sets the paint to none (completely transparent) if the alpha value is less than 0.5 otherwise it sets the alpha value to 1 (opaque). For example, Figure 8.15(\textit{a}) shows three shapes: a filled rectangle with alpha set to 100\%, a blue
8.15 MOVING AN OBJECT UP OR DOWN THE STACKING ORDER

Objects are painted on the page according to the stacking order. This means that objects can partially or wholly obscure other objects in the same location. For example, in Figure 8.16(a) the green rectangle is at the bottom (back) of the stack \((z = 0)\), the blue circle is in the middle of the stack \((z = 1)\) and the yellow triangle is at the top (front) of the stack \((z = 2)\). The stacking order has been reversed in Figure 8.16(b), with the green rectangle now at the top (front) of the stack \((z = 2)\) and the yellow triangle now at the bottom (back) of the stack \((z = 0)\).

Each new object is automatically added to the front when it is created, but objects can also be moved to the front either using the move to front button.

See also:
- §8.13 Fade
- §8.11 Reducing to Grey Scale
- §8.12 Colour Space Conversions
- §9.1 Line Colour
- §9.2 Fill Colour
- §9.4 Text Colour

Note that PostScript doesn’t support transparency so the alpha channel will be ignored if you export to PostScript.
8.16 Rotating Objects

Selected objects can be rotated either by clicking on the rotate button or by selecting Transform → Rotate (Ctrl-W). This will display a dialog box in which you can specify the angle of rotation.

Notes:

- Individual objects will be rotated relative to the centre of the object.
- Objects within a group will be rotated relative to the centre of the group.
- Rotating a text-path will rotate the path and the text will adjust to follow the transformed path.
- Rotating a text area and path and then combining them to form a text-path is not the same as first combining and then rotating.

To illustrate this, in Figure 8.17(a) there are three objects selected. The selection is then rotated 90°. The result is shown in Figure 8.17(b).
In Figure 8.18, the three objects in Figure 8.17 were first grouped (Figure 8.18(a)) and then rotated 90° (Figure 8.18(b)).

In Figure 8.19, the path and text area in Figure 8.19(a) are combined into a text-path, shown in Figure 8.19(b). This text-path is then rotated by 90° resulting in Figure 8.19(c). Note that this is different from first rotating the original path and text area, shown in Figure 8.19(d), and then combining them to form a text-path, shown in Figure 8.19(e).

If you prefer to rotate an object using the mouse, you first need to enable the hotspots. Then drag the bottom left hotspot to rotate. Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed.

See also:

• §8.20 Grouping and Ungrouping Objects
• §8.17 Scaling Objects
• §8.18 Shearing Objects
Figure 8.19: Rotating a text-path: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) text-path in (b) rotated by 45 degrees; (d) text area and path in (a) rotated by 45 degrees; (e) rotated text area and path in (d) combined to form a text-path.
8.17 SCALING OBJECTS

Selected objects can be scaled either by clicking on the scale button or by selecting Transform $\rightarrow$ Scale (Ctrl-Z). This will open up a dialog box in which you can specify the scale factor. (There is a choice of scaling just the $x$ dimension, just the $y$ dimension or both dimensions.)

Notes:

- Individual objects will be scaled relative to the top left corner of the object’s bounding box.
- Objects within a group will be scaled relative to the top left corner of the group’s bounding box.
- Scaling a text-path will scale the path and the text will adjust to follow the transformed path. Note that the text itself will not be scaled.
- Scaling a text area and path and then combining them to form a text-path is not the same as first combining and then scaling.

To illustrate this, in Figure 8.20(a) there are three objects selected. The selection is then scaled by a factor of 2. The result is shown in Figure 8.20(b).

In Figure 8.21, the three objects in Figure 8.20 were first grouped (Figure 8.21(a)) and then scaled by a factor of 2 (Figure 8.21(b)).

In Figure 8.22, the path and text area in Figure 8.22(a) are combined into a text-path, shown in Figure 8.22(b). This text-path is then scaled by a factor of 2 resulting in Figure 8.22(c). Note that this is different from first scaling the original path and text area, shown in Figure 8.22(d), and then combining them to form a text-path, shown in Figure 8.22(e).

If you prefer to scale an object using the mouse, you first need to enable the hotspots. Then drag the bottom centre hotspot to scale vertically, the bottom right
8.18 SHEARING OBJECTS

Figure 8.21: A group consisting of three objects scaled by a factor of 2: (a) before, (b) after.

Selected objects can be sheared either by clicking on the shear button or by selecting Transform → Shear (Ctrl-H). This will open up a dialog box in which you can specify the shear factors. The shearing transformation is given by:

\[
\begin{pmatrix}
1 & s_x \\
\frac{s_y}{s_x} & 1
\end{pmatrix}
\begin{pmatrix}
x \\
y
\end{pmatrix}
= 
\begin{pmatrix}
x + s_x y \\
y + s_y x
\end{pmatrix}
\]

Notes:

- Individual objects will be sheared relative to the bottom left corner of the object’s bounding box.
- Objects within a group will be sheared relative to the bottom left corner of the group’s bounding box.

See also:

- §8.20 Grouping and Ungrouping Objects
- §8.16 Rotating Objects
- §8.18 Shearing Objects
- p28 Hotspots
- §8.9 Combining a Text Area and Path to Form a Text-Path
- §10.4.5 Scale Object to Fit Typeblock
8.18 SHEARING OBJECTS

Figure 8.22: Scaling a text-path: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) text-path in (b) scaled by a factor of 2; (d) text area and path in (a) scaled by a factor of 2; (e) scaled text area and path in (d) combined to form a text-path.
• Shearing a text-path will shear the path and the text will adjust to follow the transformed path. Note that the text itself will not be sheared.

• Shearing a text area and path and then combining them to form a text-path is not the same as first combining and then shearing.

• Shearing a pattern will shear the underlying path not the complete shape.

To illustrate this, in Figure 8.23(a) there are three objects selected. The selection is then sheared with shear factors $s_x = 1$ and $s_y = 0$. The result is shown in Figure 8.23(b).

In Figure 8.24, the three objects in Figure 8.23 were first grouped (Figure 8.24(a)) and then sheared with shear factors $s_x = 1$ and $s_y = 0$ (Figure 8.24(b)).

Figure 8.23: Two selected objects sheared horizontally: (a) before, (b) after.

Figure 8.24: A group consisting of two objects sheared horizontally: (a) before, (b) after.

In Figure 8.25, the path and text area in Figure 8.25(a) are combined into a text-path, shown in Figure 8.25(b). This text-path is then sheared with shear factors $s_x = 1$ and $s_y = 0$ Figure 8.25(c). Note that this is different from first shearing the original path and text area, shown in Figure 8.25(d), and then combining them to form a text-path, shown in Figure 8.25(e).

In Figure 8.26(a), a path created using the ellipse tool has been converted into a rotational pattern with two replicas. This pattern is then sheared with shear factors
8.18 SHEARING OBJECTS

Figure 8.25: Shearing a text-path: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) text-path in (b) sheared horizontally; (d) text area and path in (a) sheared horizontally; (e) sheared text area and path in (d) combined to form a text-path.
8.18 SHEARING OBJECTS

\( s_x = 1 \) and \( s_y = 0 \), shown in Figure 8.26(b). This is different from the effect obtained by applying the same shear factors to a complete path rather than a pattern. Figure 8.26(c) is a full path version of Figure 8.26(d). This path is then sheared using the same factors and the result is shown in Figure 8.26(d).

Figure 8.26: Shearing a pattern: (a) a pattern consisting of an ellipse that has 2 rotational replicas; (b) the pattern in (a) has been sheared horizontally; (c) the pattern in (a) has been converted to a full path; (d) the path in (c) has been sheared horizontally.

If you prefer to shear an object using the mouse, you first need to enable the hotspots. Then drag the top right hotspot to shear vertically or the top left hotspot to shear horizontally. Note that even if you have more than one object selected, only the object whose hotspot you are dragging will be transformed.

See also:
- §8.20 Grouping and Ungrouping Objects
- §8.16 Rotating Objects
- §8.17 Scaling Objects
- p28 Hotspots
- §8.9 Combining a Text Area and Path to Form a Text-Path
8.19 Distorting Shapes

A selected path (not a composite shape) can be distorted using the Transform → Distort menu item. While this toggle button/item is on, the path is in distortion mode. This has four round controls that are initially located at each corner of the path’s bounding box. These controls can be moved to distort the path. Note that this modifies the location of the path’s control points. The stroke attributes, such as the line width, aren’t modified. Once you have finished distorting the shape, uncheck the Transform → Distort menu item (or the button on the horizontal toolbar) or click anywhere outside the (original) bounding box.

For example, Figure 8.27(a) shows a circle in edit mode. In Figure 8.27(b), the edit mode is now off and the circle is selected. In Figure 8.27(c), the distortion mode has now been switched on. The round distortion controls are initialised to each corner of the bounding box. The controls that define the path aren’t visible. (Note that the rendering hints have been set to speed and no anti-aliasing while in distortion mode.)

In Figure 8.27(d), three of the round distortion controls have been moved. The original bounding box is still visible, even though it no longer encompasses the distorted shape. In Figure 8.27(e), the distortion mode has been switched off and normal select mode has resumed. The modified path is now showing with its new bounding box. The distortion moved the path’s control points, as can be seen when the path is put back into edit mode in Figure 8.27(f). If this path is returned to distortion mode, the distortion controls will be reinitialised to the corners of the new bounding box. You can’t invert the distortion to restore the path to its original shape.

8.20 Grouping and Ungrouping Objects

A group is a collection of objects that are treated as though they are a single entity. When you select a group, you will only see the bounding box of the entire group, not the bounding boxes of each individual object within the group. If a group is rotated, scaled or sheared, each object within the group will maintain its relative position. Objects within a group may also be aligned. Note that a group can not be edited. Grouping and ungrouping objects may change the stacking order.

To group objects, first select all the objects you want in the group, and then either click on the group button or select the menu item Transform → Group.

To ungroup a group, first select the group, and then either click on the ungroup button or select the menu item Transform → Ungroup. Note that this function is not recursive: if a group contains other groups when you ungroup the outer group, the inner groups will remain. Any description assigned to a group will be lost when it’s ungrouped.

Note that if you ungroup an object containing flowframe related data, the flowframe information will be lost. If you group objects containing flowframe data, and then assign that group flowframe data, any flowframe data assigned to the contents of that group will be removed.
Figure 8.27: Distorting a Path: (a) original path in edit mode; (b) original path selected; (c) distortion mode on; (d) distortion in progress; (e) distorted shape (distortion mode off); (f) distorted shape in edit mode.
8.21 Aligning Objects

It is only possible to align objects that form part of a group. Objects within a group can be aligned vertically or horizontally using the sub menu Transform → Justify.

Note that alignment is not recursive: if a group contains another group, the contents of the sub group will not be aligned, each element in the sub group will be moved by the same amount.

Transform → Justify → Left
Move all objects within the group so that the left edge of each object’s bounding box lies along the left edge of the group’s bounding box. (See Figure 8.28(b).)

Transform → Justify → Centre
Move all objects within the group so that they are centred horizontally within the group’s bounding box. (See Figure 8.28(c).)

Transform → Justify → Right
Move all objects within the group so that the right edge of each object’s bounding box lies along the right edge of the group’s bounding box. (See Figure 8.28(d).)

Transform → Justify → Top
Move all objects within the group so that the top of each object’s bounding box lies along the top of the group’s bounding box.

Transform → Justify → Middle
Move all objects within the group so that they are centred vertically within the group’s bounding box.

Transform → Justify → Bottom
Move all objects within the group so that the bottom of each object’s bounding box lies along the bottom of the group’s bounding box.

If the Auto Adjust Anchor checkbox in the TeX Configuration Settings Dialog is selected, any text areas that are contained in a group that is justified will automatically have their anchors changed. For example, in Figure 8.28 one of the objects is a text area. If the auto anchor update facility is enabled, the text area in Figure 8.28(b) will have its horizontal anchor changed to Left, in Figure 8.28(c) it will have its horizontal anchor changed to Centre and in Figure 8.28(d) it will have its horizontal anchor...
Figure 8.28: Aligning a group consisting of three objects: (a) before; (b) left justified; (c) centre justified; (d) right justified.
8.22 REVERSING A PATH’S DIRECTION

changed to Right. Similarly, applying a vertical alignment will change the vertical anchor to one of: Top, Centre or Bottom. Note that there is no way of aligning text areas along their baseline. Tip: Sometimes you might want to centre an object relative to another thinner object. In this case it’s better to create a rectangle centred on the thin object that encompasses all the objects you want to justify. Include this rectangle in the group, justify, ungroup and then delete the rectangle. For example, the image shown in Figure 8.29(a) has a text area below the middle line. It would look better if the text was centred below the line, so I grouped the middle line and text area and justified them using Transform $\rightarrow$ Justify $\rightarrow$ Centre. The result is shown in Figure 8.29(b). Although the text and line are now centred relative to each other, the line was moved to the centre of the text area, not the other way round. This was not what was intended. Instead, in Figure 8.29(c), I created a new rectangle that is centred on the line. Since the line is on a tick mark and the grid lock is on, it is relatively easy to create this rectangle (much easier than trying to move the text area to manually align it). I then grouped the rectangle, the middle line and the text area and justified them using Transform $\rightarrow$ Justify $\rightarrow$ Centre. The result is shown in Figure 8.29(d). The justified objects were then ungrouped and the rectangle was deleted to produced Figure 8.29(e).

See also:

• §8.20 Grouping and Ungrouping Objects
• §3.2.7 TeX Settings Dialog
• §11.4 Step-by-Step Example: An Artificial Neuron

8.22 Reversing a Path’s Direction

The direction of a path or text-path can be reversed using Transform $\rightarrow$ Reverse Path. For example, the path in Figure 8.30 has a bar start marker, pointed arrow mid-markers and a \LaTeX style arrow end marker. Figure 8.30(a) shows the original path, and Figure 8.30(b) shows the reversed path. Note that all the control points are in the same place, but their ordering has changed.

In Figure 8.31, the text-path in Figure 8.31(a) is reversed to form Figure 8.31(b). Note that the text now starts from the right instead of the left, since the first control point is now on the right, and it is upside-down.

8.23 Merging Paths

Multiple shapes can be merged into a single shape using the menu item Transform $\rightarrow$ Merge Paths. Note that this is not the same as grouping. Moves (gaps) will be placed between the last control point of one path and the first control point of the next path. Any pattern in the selection will be first converted to a full path before merging.

Once the shape has been merged, it can then be edited. If the original shapes had different styles, the new shape will retain the style of the first shape (the lowest one in the stack). For example, in Figure 8.32(a) there are two paths with different styles.

\footnote{However it is possible that the baseline may coincide with the bottom of the text area if the text area doesn’t contain any characters with descenders.}
Figure 8.29: Aligning a wider object relative to a thinner object: (a) original image; (b) middle line and text area have been grouped and justified; (c) rectangle added to original image centred on the middle line; (d) rectangle, middle line and text area have been grouped and justified; (e) justified objects have been ungrouped and the rectangle has been deleted.
8.23 MERGING PATHS

Figure 8.30: Reversing the direction of a path: (a) original path; (b) reversed path — the vertices are in the same location, but the order has been reversed.

Figure 8.31: Reversing the direction of a text-path: (a) original text-path; (b) reversed text-path — the vertices are in the same location, but the order has been reversed so the text starts from the other end.

Figure 8.32(b) shows the single path created from merging the two original paths. Since the first path used the even-odd winding rule, the new shape has a hole in it.

Figure 8.32: Merging two paths: (a) the first path has a solid line pattern, a green fill colour and even-odd winding rule, and the second path has a dashed line pattern and a yellow fill colour; (b) resulting merged path has a solid line pattern, green fill colour and even-odd winding rule.

The same applies if one or more of the selected objects is a text-path. For example, in Figure 8.33(a) there are two text-paths. These are merged to form a single text-path shown in Figure 8.33(b). Note that the text from the second text-path is lost. The resulting path is shown in edit mode in Figure 8.33(c) to illustrate the underlying path. A mixture of paths and text-paths can be merged. The resulting object will be a text-path if the first object to be merged is a text-path, otherwise it will be a path.

Paths are merged according to their stacking order. For example, in Figure 8.34(a) there are two paths, both with a bar start marker, and an arrow end marker. The path
Figure 8.33: Merging two text-paths: (a) the first path is on the left and the second path is on the right; (b) resulting merged path; (c) resulting merged path in edit mode to illustrate the underlying path.
on the right is further back in terms of the stacking order. (That is, it gets painted on the canvas before the other path.) Figure 8.34(b) shows the result of merging the two paths — the left hand path has been appended to the right hand path. Figure 8.34(c) shows the same two paths as in Figure 8.34(a) except that now the left path is the backmost object. There is no visible difference between Figure 8.34(a) and Figure 8.34(c), but the result of merging the paths in Figure 8.34(c) (see Figure 8.34(d)) is different to Figure 8.34(b) — the right hand path has been appended to the left hand path.

Figure 8.34: Paths are merged according to the stacking order: (a) two straight line paths where the path on the right is at the back of the stack; (b) new single path resulting from merging the two paths in (a); (c) same as (a) but the path on the left is at the back of the stack; (d) new single path resulting from merging the two paths in (c).

See also:
- §8.24 Path Union
- §8.25 Exclusive Or Function
- §8.26 Path Intersection
- §8.27 Path Subtraction
- p78 Breaking a Path
- §8.22 Reversing a Path’s Direction
Multiple shapes can be combined into a single shape by performing a union on all the selected shapes using the menu item Transform → Path Union. At least two shapes must be selected to perform this function. As with the merge path function, the new shape has the same styles as the backmost path in the selection.

For example, in Figure 8.35(a), there are three overlapping paths. In Figure 8.35(b) the paths have been replaced by a single path created using the path union function. For comparison, the same three paths in Figure 8.35(a) were replaced using the merge function. The result is shown in Figure 8.35(c).

![Figure 8.35: Path union: (a) original paths (the rear path has an orchid fill colour, 2bp line width and round join style); (b) the three paths in (a) have been replaced by a single path using the path union function; (c) for comparison, the three paths in (a) have been replaced by a single path using the merge paths function.](image)

In Figure 8.36, a text-path and a path are combined: Figure 8.36(a) shows the original objects and Figure 8.36(b) shows the resulting object. In this case, the resulting object is a text-path since the backmost path in Figure 8.36(a) was the text-path object.

Any pattern in the selection will first be converted to a full path before the union is applied. For example, in Figure 8.37, two patterns are combined: Figure 8.37(a) shows the original patterns (both have a rotational pattern with 2 replicas) and Figure 8.37(b)
8.25 **EXCLUSIVE OR FUNCTION**

Multiple shapes can be combined into a single shape by performing an exclusive or (XOR) operation on all the selected shapes using the menu item Transform → XOR Paths. At least two shapes must be selected to perform this function. As with the merge path function, the new shape has the same styles as the backmost path in the selection and patterns will be converted to full paths.

For example, in Figure 8.38(a), there are three overlapping paths. The rear path has a non-zero winding rule. In Figure 8.38(b) the paths have been replaced by a single path created using the exclusive OR function. For comparison, the same three paths in Figure 8.38(a) were replaced using the merge function. The result is shown in Figure 8.38(c). Both paths in Figure 8.38(b) and Figure 8.38(c) use a non-zero winding rule, since that was used by the rear path in Figure 8.38(a).

See also:
- §8.23 Merging Paths
- §8.25 Exclusive Or Function
- §8.26 Path Intersection
- §8.27 Path Subtraction
- p78 Breaking a Path
- §8.22 Reversing a Path’s Direction
- §11.5 Step-by-Step Example: Bus

---

**8.25 Exclusive Or Function**

Multiple shapes can be combined into a single shape by performing an exclusive or (XOR) operation on all the selected shapes using the menu item Transform → XOR Paths. At least two shapes must be selected to perform this function. As with the merge path function, the new shape has the same styles as the backmost path in the selection and patterns will be converted to full paths.

For example, in Figure 8.38(a), there are three overlapping paths. The rear path has a non-zero winding rule. In Figure 8.38(b) the paths have been replaced by a single path created using the exclusive OR function. For comparison, the same three paths in Figure 8.38(a) were replaced using the merge function. The result is shown in Figure 8.38(c). Both paths in Figure 8.38(b) and Figure 8.38(c) use a non-zero winding rule, since that was used by the rear path in Figure 8.38(a).

See also:
- §8.23 Merging Paths
Figure 8.37: Pattern union: (a) original patterns; (b) patterns in (a) have been combined to form a full path; (c) result shown in edit mode.
Figure 8.38: Exclusive OR function: (a) original paths (the rear path has a non-zero winding rule, orchid fill colour and round join style); (b) the three paths in (a) have been replaced by a single path using the exclusive OR function; (c) for comparison, the three paths in (a) have been replaced by a single path using the merge paths function.
8.26  PATH INTERSECTION

- §8.24 Path Union
- §8.26 Path Intersection
- §8.27 Path Subtraction
- p78 Breaking a Path
- §8.22 Reversing a Path’s Direction

8.26  Path Intersection

Multiple shapes can be combined into a single shape by performing an intersection on all the selected shapes using the menu item Transform → Path Intersect. At least two shapes must be selected to perform this function (or one of each), and at least two of the shapes (or underlying path in the case of a text-path) must overlap. As with the merge path function, the new shape has the same styles as the backmost path in the selection and patterns are converted to full paths.

For example, in Figure 8.39(a), there are three overlapping paths. In Figure 8.39(b) the paths have been replaced by a single path created using the path intersect function.

![Figure 8.39: Path intersection function: (a) original paths (the rear path has an orchid fill colour and round join style); (b) the three paths in (a) have been replaced by a single path using the path intersect function.](image)

See also:

- §8.23 Merging Paths
- §8.24 Path Union
- §8.25 Exclusive Or Function
- §8.27 Path Subtraction
- p78 Breaking a Path
- §8.22 Reversing a Path’s Direction
8.27 Path Subtraction

Multiple shapes can be combined into a single shape by performing a subtraction on all the selected shapes using the menu item Transform → Subtract Paths. At least two shapes must be selected to perform this function. The new shape is the backmost selected shape with the other selected shapes subtracted from it. Any patterns in the selection will be converted to full paths.

For example, in Figure 8.40(a), there are three overlapping paths. In Figure 8.40(b) the paths have been replaced by a single path created using the path subtraction function.

The new path will be a text-path if the backmost selected object was a text-path and the text will adjust to fit the new underlying path. For example, in Figure 8.41(a), there is a text-path and a path. The text-path is the backmost path. In Figure 8.41(b), the two objects have been replaced by a single text-path using the path subtraction function.

![Figure 8.40: Path subtraction function](a) original paths (the rear path has an orchid fill colour and round join style); (b) the three paths in (a) have been replaced by a single path using the path subtraction function.

![Figure 8.41: Subtracting from a text-path](a) original text-path and path; (b) the path has been subtracted from the underlying path of the text-path.

See also:
8.28 SEPARATING A TEXT-PATH INTO A TEXT AREA AND PATH

A text-path can be separated into a group containing the text area and path that made up the text-path. Note that any line styles that were applied to the path before combining it with the text area will be lost, and the resulting path will use the default styles with the line colour the same as the text colour from the text-path.

For example, in Figure 8.42 the text area and path in Figure 8.42(a) are combined to form the text-path in Figure 8.42(b). The text-path is separated into a group containing a text area and a path. Note that the new path has lost the line style shown in Figure 8.42(a) and is now the same colour as the text.

You may have noticed from Figure 8.42 that the fill colour has been retained. This is because it may be needed if the outline mode is on. If a non-outline text-path is switched to outline mode with a filled interior, that colour will be applied to the new path, as illustrated in Figure 8.43.

See also:

- §8.9 Combining a Text Area and Path to Form a Text-Path
- §8.31 Splitting Text Areas
- §8.30.1 Converting a Text Area, Text-Path or Pattern to a Path

8.29 Converting a Path or Text-Path into a Pattern

A path or text-path can be converted into a pattern using Transform → Pattern. You need to specify the number of replicates and whether or not the original path or text-path should be displayed. For example, if you specify 4 replicates and show the original, there will be 5 versions of the shape: the original and the 4 replicas. The following pattern types are available:

**Rotational** The replicates will be rotated around the original shape. For example, if you specify an angle of 90° and 4 replicas, the first replicate will be created by rotating a copy of the original by 90°, the second replicate by 180°, the third by 270° and the fourth replicate by 360°, which will superimpose it over the original.

The point of rotation is initially set to the centre of the original shape, but can be moved to a different location when the shape is in edit mode. (See Figure 8.44.)
Figure 8.42: Separating the text and path from a text-path: (a) original path and text area; (b) path and text area in (a) combined to form a text-path; (c) text-path in (b) separated into a group containing a text area and a path.
Figure 8.43: Separating the text and path from an outline text-path: (a) original path and outline text area; (b) path and outline text area in (a) combined to form an outline text-path; (c) outline text-path in (b) separated into a group containing an outline text area and a path.
Figure 8.44: A rotational pattern: (a) original path; (b) the path in (a) has a rotational pattern applied with 3 replicas, 90° angle of rotation, with the original path visible; (c) the pattern in (b) in edit path mode: the green control indicates the point of rotation; (d) the point of rotation has been move to the right, changing the shape of the pattern.
8.29 CONVERTING A PATH OR TEXT-PATH INTO A PATTERN

**Scaled** The replicates will be scaled versions of the original shape. There are two control points that govern the pattern: the anchor, which can be freely moved, and the offset, which is constrained to lie along the scaling axis. (See Figure 8.45.)

![Figure 8.45: A scaled pattern.](image)

Figure 8.45: A scaled pattern. The original path is the same as in Figure 8.44(a): (a) the path has a scaled pattern applied with two replicas, the horizontal scale factor set to 2 and the vertical scale factor set to 1.5; (b) the pattern in (a) in edit path mode: the green control is the anchor and the cyan control is the offset; (c) the anchor has been moved to the left.

**Spiral** The replicates will be placed in a spiral around the original with the given incremental angle. There are again two control points that govern the pattern: the anchor and offset, which can both be moved freely. (See Figure 8.46.)

![Figure 8.46: A spiral pattern.](image)

All patterns have two modes:

- **Single** the pattern is drawn as a single path (see Figure 8.47(b)).
- **Multi** the original and each replicate are drawn as separate independent shapes (see Figure 8.47(c)).

Note that a text-path created by applying text to a multi-mode pattern produces a different result to applying the same multi-mode pattern to a text-path. (See Figure 8.48.)

See also:
Figure 8.46: A spiral pattern. The original path is the same as in Figure 8.44(a): (a) the path has a spiral pattern applied with ten replicas, the increment angle set to $60^\circ$ and a gap of 50bp; (b) the pattern in (a) in edit path mode: the green control is the anchor and the cyan control is the offset; (c) the anchor has been moved down.
Figure 8.47: Patterns can either be single or multi-mode: (a) original path has a bar start marker, a triangle end-marker and a gradient fill paint; (b) the path in (a) has a rotational pattern applied with single mode set; (c) the same pattern as (b) but with multi-mode.
8.29 CONVERTING A PATH OR TEXT-PATH INTO A PATTERN

Figure 8.48: Text-path multi-mode patterns: (a) original text area and path; (b) text area and path in (a) combined to form a text-path; (c) a scaled multi-mode pattern is applied to the text-path with 2 replicas and scale factors 2.0 and 1.5; (d) the path in (a) has the same scaled multi-mode pattern applied; (e) the text area and pattern in (d) have been combined to form a text-path; (f) the pattern in (b) has been changed from multi-mode to single-mode.
8.30 CONVERTING TO A PATH

- §8.9 Combining a Text Area and Path to Form a Text-Path
- §11.10 Step-by-Step Example: A Lute Rose

8.30 Converting to a Path

It’s possible to convert the outline of a shape, text area or text-path to a path using the menu item Transform → Convert Outline To Path. Note that the convert to path function cannot be applied to groups or bitmaps.

8.30.1 Converting a Text Area, Text-Path or Pattern to a Path

To convert the outline of a text area, text-path or pattern to a path, first select the text area, text-path or pattern and select the menu item Transform → Convert Outline To Path. The text will then be converted to a group of paths where each path approximates the shape of the corresponding character. Converting a text area or text-path to a path allows you to:

- include the image in \LaTeX document when you don’t have the equivalent \LaTeX font;
- make a \parshape or \shapepar from the text’s outline.

Note that you will have to ungroup the paths before you can edit them. If you had a gradient paint text colour, the gradient will be applied to each path. You can however, merge the paths, which will apply a single gradient resembling the original text area (see Figure 8.49).

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{sample}
\caption{Converting a text area to a path: (a) original text area; (b) converted to a path; (c) ungroup and merge paths.}
\end{figure}

8.30.2 Converting an Outline to a Path

To convert the outline of a path to a path, first select the path and select the menu item Transform → Convert Outline To Path. For example, consider the path in Figure 8.50(a). This has a line width of 10bp, a circle start marker, a triangle end arrow, a gradient line colour and a yellow fill colour. Figure 8.50(b) shows this path in edit mode to show the path’s defining control points. In Figure 8.50(c), the path’s outline has been converted to a path. This new path now has a gradient fill colour with a line width of 1bp and no start or end arrows. The new path’s defining control points are shown in Figure 8.50(d).
8.30.2 CONVERTING AN OUTLINE TO A PATH

Figure 8.50: Converting an outline to a path: (a) the original path; (b) the original path’s defining control points; (c) the new path; (d) the new path’s defining control points.
8.31 Splitting Text Areas

A text area or text-path can be split into a group containing text areas each consisting of a single character. The original alternative \LaTeX\ text will be lost. (No mappings will be used.)

For example, in Figure 8.51(a) there is a single text area containing the seven characters that make up the word “Rainbow”. This text area was then converted into a group of seven text areas using Transform $\rightarrow$ Split Text. The group was then ungrouped (see Figure 8.51(b)) and each text area was then given a different text colour resulting in the image shown in Figure 8.51(c).

![Figure 8.51: Splitting a text area: (a) original text area; (b) split and ungroup; (c) apply separate colours to each of the new text areas.](image)

Note that if you split a text-path, you will lose the underlying path as the result will be a group of text areas. For example, the text-path shown in Figure 8.52(a) was split to create a group containing seven text areas.
8.31 SPLITTING TEXT AREAS

Figure 8.52: Splitting a text path: (a) original text path; (b) split and ungroup; (c) apply separate colours to each of the new text areas.
9 Path and Text Styles

The way a path is displayed is governed by the line colour, the fill colour, the line styles (such as pen width and markers) and the winding rule. The way a text area is displayed is governed by the text colour, font, transformation matrix and (if exporting to a LaTeX file) the anchor. The way a text-path is displayed is governed by the text colour, font, anchor, transformation matrix and the underlying path. (A text area or text-path may also be rendered as an outline optionally with a fill colour, see §8.10 Text Outlines.)

The current path colours and styles can be set using the Settings → Styles dialog box. This dialog box has a tabbed pane with five tabs. The tabs for setting the current path attributes are labelled: Line Colour, Fill Colour and Line Style. There is a sample panel on the right hand side illustrating the effects of the path settings you choose. The tabs for setting the current text area attributes are labelled: Text Colour and Font. There is a sample panel along the top illustrating the effects of the text area attributes you choose. Any subsequent new paths or text areas will be given the styles specified by the Settings → Styles dialog box. The current styles are saved when you exit FlowframTk, and will be in effect next time you use FlowframTk, unless you change the startup settings (see subsection 3.2.6).

To restore the default settings, click on the Default button located at the bottom right corner of the dialog box.

To change the style of an existing path, first select the path, and then use the Edit → Path sub menu: the line colour can be changed using the Edit → Path → Line Colour dialog box. The fill colour can be changed using the Edit → Fill Colour dialog box. The line style can be changed using the Edit → Path → Line Styles sub menu. If you have more than one path selected, the chosen attributes will be applied to all the paths in the selection. This is applied recursively through all paths within each selected group. Note that the Edit → Path dialog boxes only affect selected paths and do not affect new paths. You must use the Settings → Styles dialog box to set the current styles.

To change the style of an existing text area, first select the text area, and then use the Edit → Text sub menu: the text colour can be changed using Edit → Text → Text Colour and the text attributes can be changed using the Edit → Text → Font Style sub menu. If you have more than one text area selected, the chosen attributes will be applied to all the text areas in the selection. This is applied recursively through all text areas within each selected group. Note that the Edit → Text dialog boxes only affect selected text areas and do not affect new text areas. You must use the Settings → Styles dialog box to set the current styles.

9.1 Line Colour

The line colour is the colour used to draw the path’s outline. You can specify one of the following:

**Transparent** No colour (the outline is not drawn).

**Colour** A single colour is used for the outline. This can be specified as RGB (red green blue), CMYK (cyan magenta yellow black), HSB (hue saturation brightness) or grey scale. The alpha value changes the opacity (maximum value is solid, zero...
9.2 *FILL COLOUR*

is completely transparent and a value in between produces a semi-transparent effect).

**Gradient** A two-tone gradient is used for the outline. This requires a start colour and an end colour. The shading may be linear or radial: if linear, you need to specify a direction using one of the direction buttons; if radial, you need to specify the starting location using one of the buttons provided.

Note that the colours you see on the screen may not exactly match colours produced by your printer due to the non-invertible mapping between colour spaces.

The colours are specified as integer values between 0 and 100, or between 0 and 359 in the case of hue. You can type in the number in the appropriate box or use the slider bars or you can click on one of the predefined colour buttons.

If you use one of the export functions, note:

- Gradient paint line colour will be implemented by exporting the line as a filled outline. There may be slight differences in the resulting shading. In particular, the \LaTeX export functions will average the start and end colour alpha channels over the whole shading.
- PostScript doesn’t support transparency
- All colours will be converted to RGB when exporting to a PNG file, and the background will be set to white.

**9.2 Fill Colour**

The fill colour is the colour used to fill the path’s interior (the interior is defined by the winding rule). It’s also used to fill a text area or text-path outline.

You can specify one of the following:

**Transparent** No colour (the path or outline is not filled).

**Colour** A single colour is used to fill the path or outline. This can be specified as RGB (red green blue), CMYK (cyan magenta yellow black), HSB (hue saturation brightness) or grey scale. The alpha value changes the opacity (maximum value is solid, zero is completely transparent and a value in between produces a semi-transparent effect).

**Gradient** A two-tone gradient is used for the outline. This requires a start colour and an end colour. The shading may be linear or radial: if linear, you need to specify a direction using one of the direction buttons; if radial, you need to specify the starting location using one of the buttons provided.

Note that the colours you see on the screen may not exactly match colours produced by your printer due to the non-invertible mapping between colour spaces.

The colours are specified as integer values between 0 and 100, or between 0 and 359 in the case of hue. You can type in the number in the appropriate box or use the slider bars or you can click on one of the predefined colour buttons.
Note that when using one of the \LaTeX export functions, there may be differences in shading. In particularly, the start and end colours will have their alpha values averaged over the whole shading.

See also:

- §11.1 Step-by-Step Example: A House

9.3 Line Style

The line style is made up of the following attributes: line thickness, dash pattern, cap style, join style, markers and winding rule.

9.3.1 Line Thickness (or Pen Width)

The line thickness is the width of the line defining the path’s border. This value is specified in the Pen Width box.

9.3.2 Dash Pattern

A path can be drawn either as a solid line or with a dash pattern. Select the Solid Line button for a solid line or select the Dashed Line button for a dash pattern. The latter will enable the Offset, Dash and Gap fields. The offset is the distance from the starting vertex of the path to the start of the first dash. The dash pattern will then repeat line and gap pairs, where the line length is given by the Dash field and the gap length is given by the Gap field.

A dash-dot pattern can be obtained by selecting the Secondary checkbox and entering the secondary dash length and gap length. For example, in Figure 9.1 path (a) has a solid line; path (b) has a dash pattern with an offset of 0bp, dash length of 10bp and gap length of 5bp; path (c) is the same as path (b) except that the dash pattern has an offset of 10bp; path (d) has no offset, a primary pair of dash length 10bp and gap length 5bp, and a secondary pair of dash length 1bp and gap length 5bp which gives a dash-dot pattern.

\begin{itemize}
  \item \textbf{(a)} \ 
  \begin{tabular}{c}
  \hline
  10bp solid line.
  \end{tabular}
  \item \textbf{(b)} \ 
  \begin{tabular}{c}
  --- 10bp \ 5bp 5bp
  \end{tabular}
  \item \textbf{(c)} \ 
  \begin{tabular}{c}
  --- 10bp \ 5bp 5bp
  \end{tabular}
  \item \textbf{(d)} \ 
  \begin{tabular}{c}
  . . \ 10bp \ 5bp \ 5bp .
  \end{tabular}
\end{itemize}

Figure 9.1: Example dash patterns: (a) solid line; (b) dash length 10bp and gap length 5bp; (c) dash length 10bp, gap length 5bp and 10bp offset; (d) primary dash length 10bp with gap length 5bp and secondary dash length 1bp with gap length 5bp.

9.3.3 Cap Style

The cap style can be one of: butt, round or square. (See Figure 9.2.)
9.3.4 Join Style

The join style can be one of: mitre, round or bevel. (See Figure 9.4.) If a mitre join style is selected, you can also specify the mitre limit, which must be a value greater than or equal to 1.0.

9.3.5 Markers

The start, mid and end markers are placed on the start, mid-point and end vertices, respectively. Some of the markers require a size, some of them are dependent on the line width and some of them require a size as well as being dependent on the line width.
Markers on existing paths can be set using the menu item Edit → Path → Line Styles → All Styles, and clicking on the Select button next to the appropriate marker label. This will open up the marker dialog box. Alternatively, if the start, mid and end markers all need to be the same, the menu item Edit → Path → Line Styles → All Markers can be used to set them all at the same time.

Enabling or Disabling a Marker

To enable a marker, select the Use Marker radio button, or to disable a marker, select the No Marker radio button. Selecting the Use Marker radio button will enable the marker type selector.

Marker Types

Marker types are divided into six categories: arrow style markers, partial arrow markers, data point style markers, bracket style markers, decorative markers and cap style markers. Note that the cap style markers do not replace the line cap style, but are in addition to the line cap style. However the cap style markers generally look best in combination with the butt cap line style.

Available markers are listed in Table 9.1 (arrow style markers), Table 9.2 (partial arrow markers), Table 9.3 (data point style markers), Table 9.4 (bracket style markers), Table 9.5 (cap style markers) and Table 9.6 (decorative markers).

Table 9.1: Available marker styles and dependencies for arrow style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointed</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Pointed 60</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Pointed 45</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Cusp</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>LaTeX</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Alt LaTeX</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>
### MARKERS

<table>
<thead>
<tr>
<th>Style</th>
<th>Required</th>
<th>Dependent</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt LaTeX Open</td>
<td>N/A</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Triangle</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triangle Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Equilateral Filled</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Equilateral Open</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Hooks</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Table 9.2: Available marker styles and dependencies for partial arrow style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hook Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Hook Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 60 Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 60 Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 45 Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Pointed 45 Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Cusp Up</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Half Cusp Down</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Table 9.5: Available marker styles and dependencies for cap style markers. (Line width=10bp, marker size=5bp, butt cap style.) The cap style markers are designed to be flush against the line, so they are only clearly visible for thick lines. Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Round Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triangle Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Inverted Triangle Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Chevron Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Inverted Chevron Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Fast Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Inverted Fast Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Continued on Next Page
Continued from Previous Page

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ball Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Double Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Triple Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Club Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Forward Triple Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Backwards Triple Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Forward Double Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Backwards Double Leaf Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Bulge Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Cutout Bulge Cap</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

**Marker Size**

The Size box will be enabled for only the resizeable markers. This box can be used to vary the marker size, but some markers also depend on the line width, so the size box is only meant as a general guide.

**Repeating Markers**

Markers can be doubled or tripled by selecting the Double or Triple radio boxes. To go back to a single marker, select the Single radio box. Figure 9.5 illustrates single,
Table 9.3: Available marker styles and dependencies for data point style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dot Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Dot Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Box Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Box Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Cross</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Plus</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Asterisk</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Open 5 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Filled 5 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Open 6 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Filled 6 Pointed Star</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Up Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Up Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Down Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Triangle Down Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Rhombus Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Rhombus Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Pentagon Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Pentagon Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Hexagon Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Hexagon Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Octagon Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Octagon Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Filled Semicircle</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Open Semicircle</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
</tbody>
</table>
Table 9.4: Available marker styles and dependencies for bracket style markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Line Width Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Square Bracket</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td>[</td>
</tr>
<tr>
<td>Bar</td>
<td>N/A</td>
<td>Dependent</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Round Bracket</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td>(</td>
</tr>
<tr>
<td>Brace</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td>()</td>
</tr>
<tr>
<td>Alt Square</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td>[</td>
</tr>
<tr>
<td>Alt Bar</td>
<td>Required</td>
<td>Dependent</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Alt Round</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td>(</td>
</tr>
<tr>
<td>Alt Brace</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td>{</td>
</tr>
</tbody>
</table>

double and triple repeat markers for a path with a \LaTeX style end arrow. Note that the markers are placed along the gradient vector which means that they may not lie on the actual path. (See Figure 9.6.)

---

Figure 9.5: Repeat markers: (a) single, (b) double, (c) triple.

Figure 9.6: Repeat markers are placed along the gradient vector.

Reversing Markers

Markers can be reversed by selecting the Reversed checkbox. (See Figure 9.7.)

Composite Markers

A marker can be combined with another marker by selecting the Composite checkbox which will enable the secondary marker tab. If the Overlay checkbox is selected, the
Table 9.6: Available marker styles and dependencies for decorative markers. (Line width=2bp, marker size=8bp, butt cap style.) Markers are shown in red to distinguish them from the line.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Size?</th>
<th>Dependent?</th>
<th>Centred on Vertex?</th>
<th>Sample</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circle</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Diamond</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Circle Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Diamond Open</td>
<td>N/A</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Scissors Up Filled</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Scissors Down Filled</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Scissors Up Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Scissors Down Open</td>
<td>Required</td>
<td>Dependent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Right Heart Filled</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Right Heart Open</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Heart Filled</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Heart Open</td>
<td>Required</td>
<td>Independent</td>
<td>No</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Snowflake</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Star Chevron Open</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
<tr>
<td>Star Chevron Filled</td>
<td>Required</td>
<td>Independent</td>
<td>Yes</td>
<td><img src="image" alt="Sample" /></td>
</tr>
</tbody>
</table>

Figure 9.7: Reversed markers: (a) single reversed, (b) double reversed, (c) triple reversed.
primary and secondary markers will be positioned so that their origins coincide, otherwise the secondary marker will be offset from the primary marker (see also Marker Offset below). Figure 9.8 shows two examples of composite markers: in Figure 9.8(a) the start and end markers are formed from a pointed arrow primary marker of size 5bp and a composite bar secondary marker, while in Figure 9.8(b) the start and end markers are formed from an open semicircle primary marker of size 5bp with an overlaid reversed filled semicircle secondary marker of size 5bp.

![Fig 9.8](image)

Figure 9.8: Examples of composite markers: (a) a bar primary marker with a pointed secondary marker of size 5bp; (b) an open semicircle primary marker of size 5bp overlaid with a reversed filled semicircle secondary marker of size 5bp.

**Marker Orientation**

If the Auto Orientation box is checked, the marker will be rotated so that the marker’s $x$-axis lies along the path’s gradient vector (start markers point in the opposite direction). If this box is not checked, the marker will be rotated according to the angle specified (in degrees) in the box next to the Auto Orientation box.

**Marker Offset**

If the Auto Offset box is checked, the marker’s offset from the vertex will be computed automatically. (The primary marker will be placed with its origin coinciding with the vertex, but the secondary marker will be offset from the primary marker according to whether any duplicate markers have been specified and according to the line width.) If this box is not checked, the marker will be offset according to the length specified in the adjoining box. Examples: in Figure 9.9(a) both the start and end markers have been set to the \LaTeX style marker with an offset of $-10bp$, and in Figure 9.9(b) both the start and end markers are composite markers formed from a bar primary marker and a pointed secondary marker, where the secondary marker’s offset has been set to 2bp. Note that setting the secondary marker’s offset to 0 is equivalent to using the overlay function.

Note that markers are placed along the path’s gradient vector, so the marker may not necessarily lie on the path. For example, in Figure 9.10, a marker with offset 10bp has been placed at the end of a Bézier curve. The marker’s offset has moved it along the gradient vector, away from the curve.

**Repeat Gap**

If the Auto Repeat Gap box is checked, the gap between repeat markers is given by 7 times the line width. If this box is not selected, the gap will be given by the length specified in the adjoining box. For example, in Figure 9.11(a) a line has an end marker with a triple arrow with the auto repeat function selected. Since the line width is 1bp, the gap between the markers is 7bp. In Figure 9.11(b) the line width is 2bp, so the gap between the markers is 14bp. In Figure 9.11(c), the line width is 1bp and the repeat
9.3.6 WINDING RULE

Figure 9.9: Disabling the marker auto offset: (a) a negative offset makes the marker protrude off the end of the line; (b) the secondary marker has an offset of 2bp so that it is only slightly behind the primary marker.

Figure 9.10: Changing a marker’s offset moves it along the gradient vector.

gap has been set to 10bp and in Figure 9.11(d) the line width is 2bp again with a repeat gap of 10bp.

Figure 9.11: Repeat gap: (a) line width of 1bp and auto repeat gap; (b) line width of 2bp and auto repeat gap; (c) line width of 1bp and repeat gap set to 10bp; (d) line width of 2bp and repeat gap set to 10bp.

Marker Colour

If the Colour As Path box is checked, the marker will have the same colour as the path. If you want the marker to have a specific colour, you should check the Specific Colour box, which will enable the colour panel. Note that if the marker has been assigned a specific colour, it will remain unchanged if you change the line colour of the path, otherwise it will change with the path. For example, Figure 9.12 shows a path with a transparent line colour and blue start, mid and end markers.

Primary and secondary marker colour settings are independent of each other. For example, in Figure 9.13 the start and end markers are composite markers formed from a filled yellow pentagon primary marker and an open pentagon secondary marker. The secondary marker colour is set to the line colour, so if the line colour is changed the pentagon outline will change accordingly, but the filled pentagon will remain yellow.

9.3.6 Winding Rule

The winding rule describes how a path is filled (if it has a fill colour). The winding rule can be either even-odd or non-zero. Figure 9.14 illustrates the difference between
Figure 9.12: Marker colour may be independent of the line colour: this path has a transparent line colour and blue start, mid and end markers.

Figure 9.13: Primary and Secondary Markers are Independent

the two winding rules. A path was constructed with a gap between the outer and inner rectangles. Figure 9.14(a) shows the effect using the even-odd winding rule and Figure 9.14(b) shows the effect using the non-zero winding rule. The winding rule is also used when extracting the parameters for \parshape and \shapepar.

Figure 9.14: Winding rules (arrows indicate direction of path): (a) even-odd, (b) non-zero.

See also:
- §11.3 Step-by-Step Example: Cheese and Lettuce on Toast

9.4 Text Colour

The text colour can be one of the following:

**Transparent** No colour. A transparent text area is not painted on the canvas, but it does have a bounding box. When exporting to a \LaTeX document, transparent
9.5 **TEXT STYLE**

Text areas have their text set in the argument of `\phantom`.

**Colour** A single colour. This can be specified as RGB (red green blue), CMYK (cyan magenta yellow black), HSB (hue saturation brightness) or grey scale. The alpha value changes the opacity (maximum value is solid, zero is completely transparent, and a value in between produces a semi-transparent effect.

**Gradient** A two-tone gradient is used for the outline. This requires a start colour and an end colour. The shading may be linear or radial: if linear, you need to specify a direction using one of the direction buttons; if radial, you need to specify the starting location using one of the buttons provided.

FlowframTk can’t implement paint shadings for text when using one of the \LaTeX-related export functions. You can choose how FlowframTk should treat text paint shadings via the TeX Configuration Settings.

Note that the colours you see on the screen may not exactly match colours produced by your printer due to the non-invertible mapping between colour spaces.

The colours are specified as integer values between 0 and 100, or between 0 and 359 in the case of hue. You can type in the number in the appropriate box, or use the slider bars, or you can click on one of the predefined colour buttons.

### 9.5 Text Style

The text style consists of the font attributes and (if you are exporting to a \LaTeX file) an anchor. The current text styles can be set via the Settings → Styles menu. The style for existing text areas or text-paths can be set via the Edit → Text → Font Style submenu.

#### 9.5.1 Font Family

Use Edit → Text → Font Style → Family to change just the font family for selected text areas or text-paths. To change the current font family to apply to new text areas, use Settings → Styles and select the tab labelled Font.

The drop-down list labelled Font Family (see Figure 9.15) provides a list of locally available fonts. You can select the required font from this list.

Select the font family to use in FlowframTk

The \LaTeX command to set the required font family is selected automatically, but can be edited as required

Figure 9.15: Setting the Font Family
When you select a font family, FlowframTk guesses at the appropriate \LaTeX font family declaration. This is used if you export your image as a \LaTeX file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font family declaration that is not listed. Alternatively you can clear the value (by deleting the family declaration) to use the current document font family.

Note that FlowframTk only guesses at a \LaTeX alternative when you select a new font family from the Font Family drop-down list. If there is a particular mapping that you always want, you can create a file called \texttt{latexfontmap.prop} in FlowframTk's configuration directory. Each line in this file should be in the form:

\begin{verbatim}
⟨font name⟩=⟨LaTeX declaration⟩
\end{verbatim}

where ⟨font name⟩ is the name of the font family (e.g. URW Chancery L) and ⟨LaTeX declaration⟩ is the code\(^1\) used to set the font in a \LaTeX document. Blank lines or lines starting with a hash (#) are ignored. For example, on my computer I have the font “URW Chancery L”. If I select this font, the \LaTeX equivalent will default to \texttt{\rmfamily}. However, it would be more appropriate for the \LaTeX declaration to select the PSNFSS chancery font. Therefore, I can use my favourite text editor to create a file called \texttt{latexfontmap.prop} with the line

\begin{verbatim}
URW Chancery L=\fontfamily{pzc}\selectfont
\end{verbatim}

and save it in FlowframTk’s configuration directory. Next time I start FlowframTk, it will load this mapping and use it whenever I select “URW Chancery L” from the font name selector. Alternatively, you can use a regular expression. For example:

\begin{verbatim}
.*\[Cc\]hancery.*=\fontfamily{pzc}\selectfont
\end{verbatim}

This will select \texttt{\fontfamily{pzc}\selectfont} for any font that contains either “Chancery” or “chancery” in its name. It is however faster to use the exact name.

See also:

- §9.5.6 Anchor

### 9.5.2 Font Size

Use Edit \rightarrow Text \rightarrow Font Style \rightarrow Size to change just the font size for selected text areas or text-paths. To change the current font size to apply to new text areas, use Settings \rightarrow Styles and select the tab labelled Font.

You can enter the font size in the field labelled Font Size (see Figure 9.16).

When you specify a font size, FlowframTk guesses at the appropriate \LaTeX font size declaration. The normal size is taken from the value given in the Document Settings dialog box (unless you have unchecked the Use relative font size declarations checkbox in the \TeX/LaTeX Settings Dialog). This is used if you export your image as a \LaTeX file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font size declaration that is not listed. Alternatively you can clear the value (by deleting the size declaration) to use the current document font size. Note that \verb|\veryHuge|, \verb|\VeryHuge| and

---

\(^1\)This code should be in the form of a declaration (sets the font “from this point onwards”) not a text block command (a command that sets its argument in the given font).
9.5.3 **FONT SERIES**

Enter the font size to use in FlowframTk. The \LATEX command to set the required font size is selected automatically but can be edited as required.

\texttt{\verb|\Huge|} are not standard commands, but are defined in the \texttt{a0poster} class file. FlowframTk will only select these commands if the normal font size is 25pt. Remember that if you want to use very large sizes in your \LaTeX document, you will need to use scalable fonts rather than the default Computer Modern.

Note that if you change the \texttt{\verb|\normalsize|} value, you will need to reselect the font size for each of the text areas already present unless the checkbox marked \texttt{Update all LaTeX font size declarations in current image} is selected in the Document Settings dialog box.

See also:
- §9.5.6 Anchor
- §3.2.7 Setting the Document Class and Normal Font Size
- §3.2.7 TeX Settings Dialog

### 9.5.3 Font Series

Use Edit \rightarrow Text \rightarrow Font Style \rightarrow Series to change just the font series for selected text areas. To change the current font series to apply to new text areas, use Settings \rightarrow Styles and select the tab labelled Font.

You can set the font series to medium (normal) or bold by selecting the appropriate item from the drop-down list labelled Font Series (see Figure 9.17).

![Figure 9.17: Setting the Font Series](image-url)

Enter the font size to use in FlowframTk. The \LATEX command to set the required font size is selected automatically but can be edited as required.

![Font Size](image-url)
9.5.4 Font Shape

When you select a font series, FlowframTk guesses at the appropriate \LaTeX{} font series declaration. This is used if you export your image as a \LaTeX{} file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font series declaration that is not listed. Alternatively you can clear the value (by deleting the series declaration) to use the current document font series.

9.5.4 Font Shape

Use Edit \rightarrow Text \rightarrow Font Style \rightarrow Shape to change just the font shape for selected text areas or text-paths. To change the current font shape to apply to new text areas, use Settings \rightarrow Styles and select the tab labelled Font.

You can set the font shape to upright (normal) or italic by selecting the appropriate item from the drop-down list labelled Font Shape (see Figure 9.18).

![Figure 9.18: Setting the Font Shape](image)

Select the font shape to use in FlowframTk. The \LaTeX{} command to set the required font shape is selected automatically, but can be edited as required.

When you select a font shape, FlowframTk guesses at the appropriate \LaTeX{} font shape declaration. This is used if you export your image as a \LaTeX{} file. If FlowframTk has guessed incorrectly, you can select a different command from the combo box on the right, or you can edit it if you require a font shape declaration that is not listed. Alternatively you can clear the value (by deleting the shape declaration) to use the current document font shape.

9.5.5 Text Transformation Matrix

In addition to scaling, rotating and shearing a text area, you can also directly modify the transformation matrix using Edit \rightarrow Text \rightarrow Transformation Matrix. The transformation matrix for a text area is applied relative to the top left corner of the canvas. The transformation matrix for a text-path is applied relative to the point along the underlying path where each character should be positioned.

Once a text area has been combined with a path to form a text-path, the text can only be transformed by editing the transformation matrix. For example, Figure 9.19 shows a text-path in edit mode (so that you can see the underlying path) with different values of the transformation matrix. In Figure 9.19(a), the transformation matrix is set to the identity matrix, shown in Figure 9.19(b). In Figure 9.19(c), the transformation matrix is set as shown in Figure 9.19(d), (the vertical translation has been set to 10, which is in terms of the storage unit). The text is no longer flush against the path. In
Figure 9.19(e), the transformation matrix has been set as shown in Figure 9.19(f), (the horizontal shear element has been set to $-1$).

The transformation matrix can be reset via the Transform $\rightarrow$ Reset Matrix menu item. This will reset the scale and shear factors (but not the translation) for text areas, and will reset all elements for text-paths.

### 9.5.6 Anchor

For a text-path, the anchor is used to determine where the text should be positioned along the underlying path. Changing the anchor for a text-path will change the way it is displayed in FlowframTk (as illustrated in Figure 8.12 on page 85). For a text area, the anchor is only used when you export the image to a L\LaTeX file and changing it will not change the way the text area is displayed in FlowframTk. The vertical anchor for text-paths is not supported when exporting to a L\LaTeX file.

If you export your image to a L\LaTeX file, the font used in the document is unlikely to completely match the font used in FlowframTk. As a result, text may appear wider or narrower in the resulting L\LaTeX document than in the image displayed in FlowframTk. This may result in the text appearing as though it has shifted position. (Particularly when the text area contains L\LaTeX commands.) To reduce this effect, you can specify what part of the text should be considered as the anchor. To illustrate this, consider the image shown in Figure 9.20. An image was created in FlowframTk containing some text bordered by a rectangle with an additional line along the text area’s baseline: Figure 9.20(a) shows how the image appears in FlowframTk. The font used is the generic serif font and the text takes up the entire box. The image was then exported to a L\LaTeX file with various anchor settings. The L\LaTeX document set the Roman font via:

\begin{verbatim}
\usepackage{mathptmx}
\end{verbatim}

This is a slightly narrower font than the font used in FlowframTk, so the text no longer fills the box. In Figure 9.20(b), the anchor was set to (left, base); in Figure 9.20(c), the anchor was set to (centre, base); in Figure 9.20(d), the anchor was set to (right, base). Notice that the base line for the text remains as it was in FlowframTk, but the horizontal placement of the text varies.

In this example, the height of the text in the L\LaTeX document is only slightly smaller than that of the font used by FlowframTk, so the vertical anchor setting does not make that much difference, but there is still a slight shift: in Figure 9.20(e), the anchor was set to (left, bottom); in Figure 9.20(f), the anchor was set to (left, centre); in Figure 9.20(g), the anchor was set to (left, top).

Note that in the above example, the L\LaTeX document used a scalable font (via the mathptmx package). The default Computer Modern font is not scalable. It is therefore possible that the required size is not available, in which case L\LaTeX will substitute the closest available font size. For example, in Figure 9.21, the image created in the previous example is again illustrated with anchor at (left, base). Figure 9.21(a) shows the original image in FlowframTk using the generic serif font; Figure 9.21(b) shows the image exported to a L\LaTeX document that uses the mathptmx package; Figure 9.21(c) shows the image exported to a L\LaTeX document that uses the default Computer Modern font. The large font size (40) is not available in the Computer Modern font, so the closest available font size is used instead, which in this example has resulted in a significant change in size.

As mentioned earlier, if a text area contains L\LaTeX commands, this may also result in a horizontal or vertical shift. Consider an image that contains some maths. Fig-
9.5.6 ANCHOR

Figure 9.19: Text-path transformation matrix: (a) the text-path with transformation matrix shown in (b); (c) the text-path with transformation matrix shown in (d); (e) the text-path with transformation matrix shown in (f).
Figure 9.20: The effect of converting from system fonts to \TeX fonts: (a) image in \texttt{FlowframTk} using the generic serif font. The image was then exported to a \LaTeX document with the anchor set to: (b) left, base; (c) centre, base; (d) right, base; (e) left, bottom; (f) left, centre; (g) left, top.

Figure 9.21: The font used by the \LaTeX document may result in considerable differences from the original image: (a) image in \texttt{FlowframTk}; (b) image in \LaTeX document using \texttt{mathptmx} package; (c) image in \LaTeX document using non-scalable Computer Modern font.
9.5.6 ANCHOR

Figure 9.22(a) shows the image as it appears in FlowframTk. The red line path is aligned along the left edge and along the baseline of the text. The text area has been assigned the following alternative text to be used when exporting to a \texttt{L\LaTeX} file:

$$f(x) = \frac{(x-a_1)^2}{a_2}$$

Figure 9.22(b) shows how the image appears in a \texttt{L\LaTeX} document when the anchor is set to (left, base), and Figure 9.22(c) shows how the image appears in a \texttt{L\LaTeX} document when the anchor is set to (left, bottom).

Figure 9.22: Text area containing maths: (a) image in FlowframTk; (b) image as it appears in a \texttt{L\LaTeX} document with anchor set to (left, base); (c) image as it appears in a \texttt{L\LaTeX} document with the anchor set to (left, bottom); (d) text area contents.

The default anchor is (left, base). This can be changed using the Edit $\rightarrow$ Text $\rightarrow$ Font Style $\rightarrow$ Anchor menu. The sample panel will display a small red dot to indicate the position of the anchor. If you enable the automatic anchor update facility, the anchor will be changed when you align groups containing text areas.

Note that this difference in font size between the image viewed in FlowframTk and the \texttt{L\LaTeX} alternative means that exporting to an encapsulated \texttt{L\LaTeX} document can cause the text to be clipped. (This also applies to the export functions that use the export to encapsulated \texttt{L\LaTeX} document function as an intermediate step, such as the export to PDF function.)

Note that if the text area is transformed then the anchor will have the same transformation. See, for example, Figure 9.23.

See also:

- §3.2.7 TeX Settings Dialog
- §5.6 Export
Figure 9.23: The text area’s transformation matrix will also be applied to the anchor: 
(a) original image in FlowframTk. The image was then exported to a \LaTeX file with anchor: 
(b) left, base; (c) centre, base; (d) right, base.
• §11.4 Step-by-Step Example: An Artificial Neuron
• §11.9 Step-by-Step Example: A House With No Mouse
10 \TeX/L\LaTeX

This chapter covers functions that are specific to \TeX\ or \LaTeX\ users. These functions can be obtained via the \TeX/L\LaTeX\ menu. The only functions that are relevant to Plain \TeX\ users are those relating to \parshape\ and \shapepar/\Shapepar. The \flowfram\ package is a \LaTeX\ \texttt{2e}\ package. Although the \pgf\ package is available for \TeX\ formats other than \LaTeX, \FlowframTk\ currently only exports images using \LaTeX\ syntax.

10.1 Adding Commands to the Preamble

The export to single-paged document functions create a complete \LaTeX\ document, including the document class and preamble. The generated \texttt{.tex}\ file has the form:

\begin{verbatim}
\documentclass[⟨cls size opt⟩]{⟨class-name⟩}
\usepackage{ifpdf}
⟨Default Preamble⟩
\usepackage{pgf}
\usepgflibrary{decorations.text}
⟨Early-Preamble⟩
\usepackage[⟨options⟩]{geometry}
⟨Mid-Preamble⟩
pagestyle{empty}
⟨Definition of \jdroutline⟩
\usepackage{⟨image code⟩}
⟨Late-Preamble⟩
\begin{document}\noindent
\jdrimagebox{⟨image code⟩}
\end{document}
\end{verbatim}

The document class ⟨class-name⟩ and base font size ⟨cls size opt⟩ are obtained from the Document Settings tab of the \TeX/L\LaTeX\ Settings dialog.

As shown above, the \pgf, \geometry\ and \ifpdf\ packages are automatically added to the preamble, and the \pgf\ \texttt{decorations.text}\ library is also loaded, in case the image contains any text-paths. \FlowframTk\ also defines a command called \jdroutline\ that’s used for any outline text areas (but not text-paths, as outline text-paths are not supported by the \LaTeX\-related export functions.) The other command automatically defined in the preamble is \jdrimagebox, which is used in case the image turns
out to be slightly larger than calculated. (This could be caused by rounding errors, or
the difference in fonts, as discussed in §9.5.6 Anchor.) The \texttt{pgfpicture}
environment is placed inside the argument of \texttt{jdrimagebox} to prevent spurious blank pages
occurring.

In addition \texttt{\pdfinfo} is added with the creation date and optionally a title if the
\texttt{Add \pdfinfo to exported LaTeX documents} option is selected in the \TeX/LaTeX
\texttt{Settings} dialog. (The title is obtained from the image description, see §5.4 Image
Description.) The relevant code is placed after the early-preamble code and before the
definition of \texttt{jdroutline}. The conditional \texttt{ifpdf} is used so that \texttt{\pdfinfo} is
only used with PDFLaTeX.

The \texttt{(Default Preamble)} code is set using the \texttt{Default Preamble tab} of the \TeX/LaTeX
\texttt{Settings} dialog box. This is general code that applies to all images that are exported to
a LaTeX document.

The \texttt{(Early-Preamble)}, \texttt{(Mid-Preamble)} and \texttt{(Late-Preamble)} code are assigned to
a specific image, and can be used to add any additional preamble code required for
that image. For example, if any of the text areas have alternative text that contains a
command that isn’t part of the \LaTeX kernel, the early-preamble can include the code
to load the package that defines the command or the mid- or late-preamble can include
the command definition. If the mappings are switched on, any required packages for
mapped symbols will automatically be added to the early preamble.

The early-, mid- and late-preamble code can be edited in the preamble panel at-
tached to the side of the \texttt{canvas} (see Figure 10.1). There is a divider between these two
areas that can be moved to adjust the visible size of each area, allowing one area to
take up more or less room than the other. You can also use the \TeX/LaTeX $\rightarrow$ Preamble
Editor menu item to open the preamble panel to its preferred width.

For some look and feels, the divider has small icons that you can click on to move
the divider part way across the child window or click again to move it all the way across
so that one of the panels is no longer visible. However, for some look and feels, it’s not
possible to completely hide the preamble panel.

The preamble panel has three tabbed panes, for the early-, mid- and late-preamble
code. Each pane has the same layout with a horizontal toolbar and an editor area
below it in which you can type the code. The buttons on the toolbar have the following
functions:

- **Undo and redo edits.** Each pane has its own independent undo/redo manager.

- **Cut or copy text from the editor area to the clipboard and paste text from the
  clipboard to the editor area.**

- **Find, find again and replace.** The find button opens the search dialog and the
  replace button opens the search and replace dialog.

- **Open the manual at this section.**

You can also open a *popup menu* by clicking with the context-menu mouse button
or using the context-menu key.
10.1 ADDING COMMANDS TO THE PREAMBLE

Figure 10.1: The Preamble Panel
The editor area has syntax highlighting. You can change the colours used or switch off the highlighting using the TeX Editor dialog.

The late-preamble tab is shown in Figure 10.2, where a command has been defined:

\newcommand*{\bvec}[1]{\boldsymbol{#1}}

This command has been used in the alternative text for one of the text areas on the canvas. The dialog box showing this alternative text is also visible.

The image’s early-, mid- and late- preamble code is stored in JDR/AJR files, but not for versions less than 1.9, so make sure you use the latest file version when you save your image. (This is done automatically if you use File → Save.) JDR/AJR version 1.8, introduced in FlowframTk version 0.7, only stores the early-preamble code. FlowframTk version 0.8 (JDR/AJR v1.9) introduced mid-preamble and late-preamble panels. The original preamble panel (which was previously just in a dialog window) is now referred to as the “early-preamble”.

If you use the export to package or document class functions, the early-preamble code will be inserted before the option declarations, which allows you to add extra options, if required. The mid-preamble code is inserted after the underlying class or package has been loaded, and the end-preamble code is inserted at the end of the file, just before \endinput. Any instances of \usepackage found in the preamble code will be replaced by \RequirePackage during the export. Note that the default preamble isn’t used by the export to package or class functions.

See also:
10.2 Computing the Parameters for \parshape

\TeX's \parshape command can be used to change a standard rectangular shaped paragraph into a non-rectangular shape. The \parshape command has the following format:

\parshape\langle n \rangle \langle i_1 \rangle \langle l_1 \rangle \ldots \langle i_n \rangle \langle l_n \rangle

where \langle i_1 \rangle is the indent for the first line and \langle l_1 \rangle is the length of the first line, etc. This command should be placed at the start of the paragraph, and is only applied to that paragraph. If there are more than \langle n \rangle lines in the paragraph, the specification for the \langle n \rangle th line will be used until the end of the paragraph. If there are less than \langle n \rangle lines in the paragraph, the shape will be truncated. See The TeXbook [1] for further details.

Since each line in the paragraph is constructed from only indent and line width information, only certain types of shapes can be specified by a \parshape. If you imagine horizontal scan lines passing through the shape, each scan line should not be able to intersect the boundary of the shape more than twice.

Before you use FlowframTk to determine the parameters for \parshape, you must first ensure that you have set the normal font size to the value used in your document. See, for example, Figure 11.80 (in section 11.7) which illustrates what happens when you fail to do this.

To determine the parameters for a \parshape, create your shape as a single path. Select this path, and use the menu item TeX/LaTeX \parshape. This will open up a dialog box in which you can specify whether you want to use the outline defined by the actual path, or whether you want to use the outline defined by the line style.

For example, Figure 10.3(a) shows a path which consists of a single line segment (shown in Figure 10.3(b)), but with a line thickness of 52bp, butt cap and an equilateral triangle start marker of size 80bp. If you select the Use Path option, FlowframTk will attempt to construct the parameters from the actual path (ignoring the line style) which it will not be able to do, as the path has no area. If you select the Use Outline option, FlowframTk will construct the parameters from the outline as seen on the screen. These parameters can be saved to a file, and used in a TeX or \LaTeX document to create a shaped paragraph (Figure 10.3(c)).

Another example is shown in Figure 10.4. In this example, the path was constructed using the ellipse tool. If you select the Use Path option, FlowframTk will compute the parameters used to create the paragraph shown in Figure 10.4(b). In this example, you will not be able to use the Use Outline option as this will attempt to create an annulus defined by the path's border, which can't be done by \parshape (but can be done by \shapepar, although it is not recommended for such a narrow line width).

Whilst the parameters are being computed, the horizontal scan lines used by FlowframTk will appear on screen, and if successful, a dialog box will appear for you to save the \parshape command to a file. You can then input this file at the start of the appropriate paragraph in your TeX or \LaTeX document. For example, if you save the
10.2 computing the parameters for \parshape

An example bit of text shaped like an arrow. It’s too thin for long words, but gives you an idea of what can be done. It can be tricky to get just the right amount of text to get the shape ok.

Figure 10.3: Parshape Use Outline: (a) path consisting of single line segment with 52bp line width, butt cap and 80bp filled equilateral triangle start marker; (b) the actual path defined in (a) without the line style applied; (c) \parshape parameters constructed from the outline (a) used to create an arrow shaped paragraph in a \LaTeX{} document.

This example has an elliptical shape. The parameters were constructed from the definition of the path, not the outline defined by the line style of the path. The paragraph indentation was suppressed at the start using \noindent to help keep the desired shape. Again it needs to have just the right amount of text to fill the entire shape, unlike paragraphs created using \shapepar which expand or shrink to fit the shape.

Figure 10.4: Parshape Use Path: (a) the path; (b) \parshape parameters constructed from the path (a) used to create an elliptical shaped paragraph in a \LaTeX{} document.
\input myparshape
This is the start of the paragraph...

or if you are using LATEX you would need to do:

\input{myparshape}\%
This is the start of the paragraph...

You may want to suppress the paragraph indentation using \noindent:

\noindent This is the start of the paragraph...

The distance between the scanlines is given by the value of \baselineskip for the normal font size. For example, if the normal font size is 10pt, \baselineskip will be 12pt, and this will be the distance used between the scanlines. It is therefore important that you set the value for the normal font size before using this function.

See also:

- §3.2.7 Setting the Document Class and Normal Font Size
- §10.4.3 Defining a Frame

10.3 Computing the Parameters for \shapepar or \Shapepar

The \parshape command is fairly limited. You need the right amount of text in the paragraph to get the shape right, and you can’t have cut out sections. These two things can be overcome using the \shapepar or \Shapepar commands defined in the shapepar package. The syntax for these commands is complex and those interested should read the shapepar documentation. As with \parshape, the shape is constructed using horizontal scan lines. If you want gaps to appear in your shape, make sure to set the winding rule to even-odd. If in doubt, give the path a fill colour; the area that is filled will contain the text of the paragraph, and the area that isn’t filled won’t.

FlowframTk defaults to using \Shapepar rather than \shapepar, but you can change this in the TeX/LaTeX Configuration Dialog.

To determine the parameters for \Shapepar/\shapepar, create your shape as a single path. Select this path, and use the menu item TeX/LaTeX → Shapepar. As with \parshape, a dialog box will open allowing you to select whether you want to use the path itself to define the shape or whether you want to use the path’s outline to define the shape. For example, Figure 10.5(a) shows a path with a 40bp line width. The \shapepar parameters were constructed first from the path (Figure 10.5(b)) and then from the outline (Figure 10.5(c)).

As with the parshape function, the horizontal scan lines used by FlowframTk will appear on screen, and if successful, a dialog box will appear for you to save the \Shapepar/\shapepar command to a file. You can then input this file at the start of the appropriate paragraph in your TeX or LATEX document. For example, if you save the command to a file called, say, myshapepar.tex, then if you are using plain TeX you would need to do:
This example has a circular shape and uses the `\shapepar` command defined in the `shapepar` package. The parameters were constructed from the path. Since this uses `\shapepar` rather than `\parshape`, the shape will expand or shrink to fit the text. The resulting paragraph will therefore not necessarily be the same size as the original path.

Here is a little bit of text as an example. In this example, the parameters came from the path. The lines are quite thin so \LaTeX has some problems finding good line breaks.

Figure 10.5: Shapepar example: (a) the path; (b) parameters constructed from the path and included in a \LaTeX document to produce a shaped paragraph; (c) parameters constructed from the path’s outline and included in a \LaTeX document to produce a shaped paragraph.
\input myshapepar
This is the start of the paragraph...

or if you are using \LaTeX you would need to do:
\input{myshapepar}%
This is the start of the paragraph...

Remember to include the \texttt{shapepar} package:
\begin{itemize}
\item \texttt{\input shapepar.sty} (plain \TeX)
\item \texttt{\usepackage{shapepar}} (\LaTeX)
\end{itemize}

See also:
\begin{itemize}
\item §3.2.7 Setting the Document Class and Normal Font Size
\item §3.2.7 \TeX\ Settings Dialog
\item §11.5 Step-by-Step Example: Bus
\item §10.4.3 Defining a Frame
\end{itemize}

\section{Creating Frames for Use with the flowfram Package}

FlowframTk can be used to help construct frames for use with the flowfram package.\footnote{The flowfram package can be downloaded from \texttt{CTAN}.} If you are unfamiliar with this package, please ensure you read the user manual (\texttt{ffuserguide.pdf}).

\subsection{The flowfram Package: A Brief Summary}

The \texttt{flowfram} package is a \LaTeX\ package that allows the user to construct frames in a document, such that the document text flows from one frame to the next in the order that the frames were defined. The mechanism is much the same as that used to create the columns when using the standard two column mode, but the columns are of arbitrary width, height and position.

Imagine that you have a number of rectangular sheets of transparent paper. You start writing on the first sheet until it’s filled, then you put it aside and start writing on the next until that one’s filled as well, and so on. When you’ve filled all the sheets, pick up the first one and glue it onto your page in your desired location, then pick up the next one and glue that onto the page, and so on. If you’ve glued one sheet down so that it overlaps another, the text on the top sheet will obscure the text on the lower sheet.

There are three types of frame defined by the \texttt{flowfram} package: “flow” frames which are the main type of frame. These are the frames in which the document text is placed and they are analogous to the transparent sheets of paper example described above. The other two types of frame are called “static” and “dynamic”. The contents of these frames has to be set explicitly using one of the commands or environments provided by the \texttt{flowfram} package.
The contents of the static frames are typeset once (when the contents are set) and it remains unchanged until the user explicitly resets the contents. (Static frames have an associated box defined via \newbox in which the contents are stored.) The contents of the dynamic frames are re-typeset on each page for which the frame is defined. (The contents are stored in a macro rather than in a box.)

So, for example, if on page 1 of your document, you set the contents of a static frame to contain the command \thepage, the contents of that frame will always display a 1 (no matter what page it appears on), since that was the value of \thepage when the contents were set. If, on the other hand, you use a dynamic frame, the contents will be re-typeset on every page, so it will display the relevant page number.

Each frame has an associated label which uniquely identifies it for a given frame type, and the frame can optionally have a border. Frames also have an associated page list indicating on which pages the frame should appear. The page list can be one of the keywords all, odd, even or none, or it can be a comma separated list of pages or page ranges (e.g. \(<4,7,9,10-14,>20\)). By default, the flowfram package assumes these numbers refer to the decimal value of the page counter (so 9 means the frame is visible on page 9, on page ix, on page IX, or even on page nine, if you’ve redefined \thepage to use a number string). The flowfram package provides the option pages=absolute, which indicates that the page lists refer to the absolute page number rather than the value of the page counter. So if your document pages are numbered, say, 1, i, ii, iii, 1, 2, 3, then the absolute page 3 is the page numbered ii, since it’s the third page of the document.

The flowfram package stacks the frames on the page in the following order: static, flow and dynamic, each in the order in which they were defined. For example, if you define a flow frame called left, then define a static frame called title, then a dynamic frame called header and lastly a flow frame defined right, then the flowfram package will stack the frames in the following order: title, left, right and header. This means that the static frames can be used for background effects.

When exporting to a package or class file, FlowframTk will define the frames according to its own stacking order. However, it will allow you to position, say, a static frame above a flow frame when displayed on the canvas. The object with the static frame data may obscure the other object when viewed in FlowframTk, but it will appear in the background when displayed in the document.

To clear all data relating to the flowfram package, select the menu item TeX/LaTeX → Flow Frames → Clear All.

See also:

- §11.6 Step-by-Step Example: A Poster
- §11.7 Step-by-Step Example: A Newspaper
- §11.8 Step-by-Step Example: A Brochure

10.4.2 Defining the Typeblock

The typeblock is the main area of the page where the text goes. The dimensions of the typeblock are given by the \textwidth and \textheight. It’s possible to define frames that are positioned outside of the typeblock, but the typeblock provides a frame of reference and, unless otherwise instructed, the page header and
10.4.2 DEFINING THE TYPEBLOCK

footer will be placed above and below the typeblock according to \TeX’s standard page layout design.

Note that the twoside class option will typically shift the typeblock on the even (verso) pages (via the \evensidemargin length) whereas the oneside class option won’t. Different classes have different default settings. For example, the article and report classes default to oneside but the book class defaults to twoside. This setting also affects the running headers and footers.

In FlowframTk, you specify the typeblock using the \TeX/LaTeX → Flow Frames → Set Typeblock menu item. This opens up a dialog box in which you can enter the margins between the paper edge and the typeblock. You can either type the lengths into the supplied fields or, if you have a path selected, you can get FlowframTk to calculate the margins for a typeblock that fits the path’s bounding rectangle by clicking on the Compute Margins From Selected Path button. (This button is disabled if no path is selected.)

For example, Figure 10.6(a) shows a path that has been created using the rectangle tool on the Tschichold grid. This was then selected and the Typeblock dialog was opened. The Compute Margins From Selected Path button was clicked which then filled in the values for the margins.

It’s possible you might want to round the left and top margins to the nearest unit. In which case you can do so by editing the Left and Top fields. Additionally, you might want to adjust the right margin so that the typeblock width is rounded to, say, the nearest whole mm or whole or half pc. To do this, type in the required value in the Adjust width to nearest field (for example 1pc) and click on the Adjust Width button. For example, I changed the left margin to 66pt and the top margin to 94pt. The Adjust width to nearest was already set to 1pc, so I left it at that and clicked on the Adjust Width button. This filled in the right and bottom margins as shown in Figure 10.6(c).

You can also adjust the bottom margin so that the typeblock height is rounded to the nearest baselineskip or another value such as 1in. To round to the nearest baselineskip, make sure the Baselineskip button is selected otherwise make sure the Other button is selected and enter the required amount in the field. Then click on the Adjust Height button. For example, in Figure 10.6(d) the bottom margin has been adjusted to ensure the typeblock height is rounded to the nearest baselineskip.

Note that rounding errors may occur caused by the conversion between units. If you later change the normalsize, you may need to readjust the typeblock height.

Finally, if you use the twoside class option, you can get FlowframTk to adjust the value of \evensidemargin. Even Page Shift is the difference between \evensidemargin and \oddsidemargin. If the value in the Even Page Shift field is non-zero, when you export to a class or package, FlowframTk will add the commands:

\setlength\evensidemargin{\oddsidemargin}
\addtolength\evensidemargin{⟨h-shift⟩}

where ⟨h-shift⟩ is the length specified in the Even Page Shift field. If you specify a zero length, \evensidemargin won’t be adjusted, but the typeblock may not be displayed correctly when you display even pages in FlowframTk. Remember that \evensidemargin is ignored if you use the oneside class option.

If you find it a bit complicated to work out the appropriate shift, you can use the Compute button, which will work out the shift assuming a symmetric page layout. For example, in Figure 10.6(e) I clicked on Compute and it altered the value in the Even Page Shift field.
10.4.2 DEFINING THE TYPEBLOCK

Figure 10.6: Setting the typeblock: (a) a rectangle has been drawn on a Tschichold grid; (b) the margins computed from the selected rectangle; (c) the top and left margins were manually rounded to the nearest point by the user and then the adjust width function was used which changed the right margin; (d) the adjust height function was used to change the bottom margin; (e)
Once you have set the typeblock, it will appear on the screen as a light grey rectangle, labelled “typeblock”. In Figure 10.7 I removed the path I had used to calculate the typeblock (using Edit → Cut). The typeblock is slightly smaller than the path as a result of the adjustments made.

Figure 10.7: The typeblock is shown as a light grey rectangle: (a) verso; (b) recto

10.4.3 Defining a Frame

An object can be identified as a flow, static or dynamic frame as follows: select the object (it should be the only object selected) then select the \TeX/LaTeX → Flow Frames → Set Frame menu item. This will open up a dialog box in which you can specify the frame’s attributes. Initially only the Type field is enabled (as shown in Figure 10.8) since all the other fields aren’t valid for type None.

Make sure you set the typeblock before you set any frames. If you later adjust the typeblock, you may need to readjust the even shifts for all frames that may be displayed on verso pages.

The Frame Type

The frame’s type is specified using the drop-down list labelled Type. There is a choice of: Flow, Static, Dynamic or None. None indicates that the object has no associated flowframe data, which means that the object will not be saved if the image is exported to a \LaTeX package or class.

The Frame Label

Each frame is assigned a label so that it can be referenced in the document. Each label must be unique for its given frame type. To assign a label to the selected frame, enter it in the box marked Label.
Figure 10.8: Frame Attributes Dialog Box
There are four dynamic frame labels that have a special meaning for FlowframTk: `header`, `footer`, `evenheader` and `evenfooter`. These indicate that the frame should be converted into the page header or footer frame (analogous to the `flowfram` package’s `\makedfheaderfooter` command). If you use any of these labels, when you export to a package or class file, FlowframTk will modify \LaTeX’s standard page style mechanism to hide the header and footer frames when you use the `empty` page style, hide just the header when you use the `plain` page style and hide just the footer when you use the `headings` page style. If you only define a header frame but no footer frame, FlowframTk will switch on the `headings` page style. If you only define a footer frame but no header frame, FlowframTk will switch on the `plain` page style. If you define both a header and a footer frame, FlowframTk will switch to its own custom page style called `flowframtk` that puts `\leftmark` or `\rightmark` in the header and `\thepage` in the footer. This custom page style is only defined if you have a header or footer frame. These labels only have a special significance for dynamic frames.

The `evenheader` and `evenfooter` labels are provided in case you want to have a different frame for even pages. This will typically only be necessary if you want a different border or frame dimensions for the header or footer on even pages, as the even page horizontal shift is usually sufficient.

**The Frame Border**

The `Border` drop-down list allows you to specify whether the frame has a border. If the option `As Shown` is set, then the object will be drawn as the frame’s border. If the option `None` is set, then the frame will not be given a border, and the object will be used only as an indication of the frame’s width, height and location (and possibly shape, see §10.4.4 The Frame Shape).

Note that all text areas are considered to be a part of the frame’s background, not the frame’s contents, and will only appear if the border `As Shown` setting is applied. Likewise for bitmaps. The border is not available for non-standard paragraph shapes.

**The Page List**

You can specify the page list on which the frame is defined, using the `Pages` combo box. Either select one of: All, None, Odd or Even, or you can type in a comma separated list of pages or page ranges (e.g. `1-10, 12, 14, >20`). The page references are as described in §10.4.1 The `flowfram` Package: A Brief Summary. Use the `flowframe pages` setting section of the `TeX/LaTeX Configuration Dialog` to specify whether the page list uses absolute or relative numbers.

**Margins**

The frame may have margins between the border and the area in which the contents are typeset. The margins are usually only relevant if you have specified the `As Shown` border option. The margins are not available for non-standard paragraph shapes.
10.4.3 DEFINING A FRAME

Alignment

You can change the vertical alignment of the contents of a static or dynamic frame using the Alignment drop-down list. This can be one of: Top, Middle or Bottom, which correspond to the settings `valign=t`, `valign=c` and `valign=b`, respectively, provided by \setdynamicframe and \setstaticframe. This facility is not available for flow frames.

Even Shift

By default, the frame location on even pages is the same relative to the typeblock as on odd pages. You can override this by specifying a shift to apply to the location when the frame is displayed on an even page. However, this setting only has an effect if you use the twoside class option. This is typically the default for classes such as book, but not for classes such as article or report. Typically, only the horizontal shift may be needed for two-sided documents, but if for some reason you require a vertical shift that option is provided. In most cases, the horizontal shift is used to create a symmetric page layout (by which I mean the frame locations are symmetric not the frame borders). For convenience, there’s a button labelled Compute Symmetric X Shift that will work out the appropriate horizontal shift to create a symmetric layout, given the current frame position and typeblock margins. If you later move the object or modify the margins you will need to update the horizontal shift.

If the typeblock has an even page shift, remember to take this into account when setting the even shift for the frames. You can check the frame’s position on even pages using the display page dialog.

Contents

As described in §10.4.1 The flowfram Package: A Brief Summary, the contents of static and dynamic frames need to be explicitly set using commands or environments provided by the flowfram package. For your convenience, FlowframTk provides a way for you to specify the contents and will use the appropriate commands when you export to a package or class file. To add or edit the contents, click on the Edit button, which will open FlowframTk’s little \TeX editor. Note that you can’t use verbatim text in the contents.

If your frame has been assigned the Dynamic type and has been given one of the special dynamic labels header, footer, evenheader or evenfooter, as described above, setting the contents has a different effect. The code you provide in the contents is inserted into the header or footer to enable you to modify the formatting. Note that you shouldn’t use commands like \thepage, as that will be done automatically. It’s best to stick to declarations, such as \bfseries, although the final command may be a text-block command, such as \textbf, as it is typically followed by \thepage or the header mark.

Once an object has been identified as a frame, a grey rectangle will appear on the screen indicating the area in which the contents of the frame will be typeset, along with the frame’s type, identification label and page list.
Note that if the object is a group, the frame information will be applied to the whole group. This means you can construct a frame border by grouping several objects, however, if you later ungroup this object, you will lose the frame information.

10.4.4 The Frame Shape

The text in flow frames is typeset using the standard rectangular format, but the contents of static or dynamic frames can be shaped using either \parshape or \shapepar. If you have selected a path, you can enable this by selecting either Parshape or Shapepar from the Shape drop-down list. Note that the shape option is not available for any other type of object.

If you use the Parshape or Shapepar options, it will only check if a set of valid parameters can be extracted from the path when you export the image as a \LaTeX class or package. (Otherwise it would have to re-evaluate the parameters every time you edit the path.) Note, however, that the paragraph shape in your document may not exactly match the shape you created in FlowframTk:

\parshape:

• If there are not enough words in the paragraph to fill the shape, the shape will be truncated.
• If there are too many words in the paragraph, the dimensions of the final line of the shape will be repeated for each subsequent line.

\shapepar:

• If there are not enough words in the paragraph to fill the shape, the shape will shrink.
• If there are too many words in the paragraph, the shape will expand.

To illustrate this, consider the layout shown in Figure 10.9. There are six identical circles arranged in two rows. Each circle has been identified as a static frame. Their bounding boxes can be seen as light grey rectangles. The top three circles have all been assigned a shape given by \parshape, while the bottom three circles have been assigned a shape given by \shapepar.

This layout was exported as a \LaTeX package based on the flowfram package, and was included into a document. Each of the static frames were filled with a varying amount of text. The leftmost circles do not have enough text to fill the designated area, while the rightmost circles have too much text. (See Figure 10.10.)

Note that when you use a non-standard paragraph shape, you can no longer specify the margins. Since the paragraph shape is defined by the path, the margins don’t have any meaning. If you want a border effect, you can make a slightly larger object behind, and set the border of the larger object to As Shown and the border of the smaller object to None, but remember that the overall effect will depend on the amount of text contained in the frame.
10.4.4 THE FRAME SHAPE

Figure 10.9: Layout containing six circles. All circles have been identified as static frames. The top three circles have been assigned a shape given by \parshape. The bottom three circles have been assigned a shape given by \shapepar.

Figure 10.10: The effects of too much and too little text. The top row uses \parshape: (top left) too little text truncates the shape; (top right) too much text replicates the dimension of the last line of the shape. The bottom row uses \shapepar: (bottom left) too little text shrinks the shape; (bottom right) too much text expands the shape. (The contents of the static frames were all set to a central vertical alignment.)
10.4.5 Scale Object to Fit Typeblock

In addition to the scaling function described in §8.17 Scaling Objects, if you have set the typeblock, you can scale selected objects so that they fit the typeblock area using the \TeX/\LaTeX \rightarrow Flow Frames \rightarrow Scale to Fit Typeblock menu item. Note that this may change the aspect ratio of the scaled objects.

10.4.6 Only Displaying Objects Defined on a Given Page

It is possible to display only those frames that are defined on a given page using the \TeX/\LaTeX \rightarrow Flow Frames \rightarrow Display Page dialog box. You can select to display those frames that are defined on all pages or just those that are defined on odd or even pages or you can specify a particular page number by selecting the Page radio button and entering the relevant page number in the text field. If you specify “0”, only those frames that have the None page setting will be displayed. Note that objects that have not been assigned flowframe data will always be displayed. The title bar will indicate how many objects have been hidden.

It’s generally best to apply transformations or edits with the All Pages setting on. If you move an object when the verso (even) page is displayed, the object’s recto position will be moved by the same amount. The only way to have a different verso position is to apply an even page shift in the \TeX/\LaTeX \rightarrow Flow Frames \rightarrow Set Frame dialog (or to apply an even page shift to the typeblock).
11 Step-by-Step Examples

The examples in this section illustrate various aspects of FlowframTk.

§11.1 A House
Illustrates the basics: how to create filled rectangles and a closed line path.

§11.2 Lettuce on Toast
Illustrates editing paths.

§11.3 Cheese and Lettuce on Toast
Illustrates merging paths.

§11.4 An Artificial Neuron
Illustrates line styles, text areas and justifying. Also illustrates how to specify different text to use when exporting to a \LaTeX file.

§11.5 Bus
Illustrates path functions, and using the shapepar function.

§11.6 A Poster
Illustrates how to use FlowframTk to create frames for use with the flowfram package.

§11.7 A Newspaper
Illustrates how to use FlowframTk to create non-standard shaped frames for use with the flowfram package.

§11.8 A Brochure
Illustrates how to use FlowframTk to create recto/verso header and footer frames for use with the flowfram package.

§11.9 A House With No Mouse
Illustrates how to create and edit pictures without using the mouse.

§11.10 A Lute Rose
Illustrates how to design a lute rose using a symmetric shape and rotational patterns.

11.1 A House

This example illustrates the basics. The aim is to create a simple image of a house (shown in Figure 11.3).

1. The main part of the house will be constructed from a rectangle, so select the rectangle tool.

2. Let’s make it a yellow brick house, so use Settings → Styles to select a yellow fill colour.

3. Click where you want the bottom left hand corner to go, and move (not drag) the mouse to the opposite corner (Figure 11.1(a)). Click to complete the rectangle. You will only see the fill colour once the rectangle has been completed (Figure 11.1(b)).
4. Next do the roof. Let’s make the roof using a triangle. For this you will need to use the closed line path tool. Select this tool using either the closed line button or the Tools → Closed Line menu item.

5. Let’s make it a red roof, so use Settings → Styles to select a red fill colour.

6. Click on each of the three vertices that form the triangle (Figure 11.2(a)). To complete the path, double click when you click on the third vertex, or click on the third vertex and then press Enter, or use the finish path button. You will only see the fill colour once the path has been completed (Figure 11.2(b)).

7. Lastly comes the door and windows. These are all rectangles, so follow the same procedure as above. Let’s make the door black and the windows white.
11.2 LETTUCE ON TOAST

Remember to set the fill colour before creating the rectangles (Figure 11.3).

To save the picture, select the File → Save As menu item (Figure 11.4).

To include the image in a LATEX document, select the File → Export menu item, and save it as a LATEX file (click on the File of Type drop-down list and select pgf environment (*.tex, *.ltx), and name the file e.g. house.tex Figure 11.5.) Remember to use the pgf package:

\usepackage{pgf}

and to include the image later in the document use \input, e.g.:

\begin{figure}
\centering
\input{house}
\caption{A House}
\end{figure}

11.2 Lettuce on Toast

This example illustrates how to edit paths. The aim is to create the picture illustrated in Figure 11.11.
11.2  LETTUCE ON TOAST

1. Let’s start with the toast first. To begin with create a rectangle with a brown fill colour. (If you are using the CMYK model, you can get brown from 0% Cyan, 81% Magenta, 100% Yellow and 60% Black. If you are using the RGB model, you can get brown from 40% Red, 8% Green and 0% Blue.) Create the rectangle shown in Figure 11.6.

2. Bread quite often has a curved top, so let’s edit the rectangle so that the top is slightly curved. To do this, select the rectangle, and then either click on the edit path button or select the Edit → Path → Edit Path menu item. This will display the path in edit mode (Figure 11.7(a)). Select the top segment, this will then be highlighted in red (Figure 11.7(b)).

3. Use the edit path popup menu to convert the line segment to a curve (Figure 11.8).

4. The segment now has two extra control points, these need to be moved to change the curvature (Figure 11.9(a)). Deselect the edit path tool (Edit → Path → Edit
11.2 LETTUCE ON TOAST

Figure 11.8: Lettuce on Toast Example — converting the top segment to a curve: (a) edit path popup menu; (b) segment converted to a curve.

Path or Ctrl-I) to exit the edit path mode (Figure 11.9(b)). Note that if you have the grid lock enabled, you may find it easier to temporarily disable it while you are editing the curvature control points.

Figure 11.9: Lettuce on Toast Example — finish editing the curve: (a) changing the curvature by moving the control points; (b) exit edit path mode.

5. To make the lettuce, select the closed curve tool, and set the fill colour to green. Make a rough outline of the lettuce leaf, clicking on each vertex, and double-click to close the path. Then, if necessary, edit the path to modify the control points (Figure 11.10).

6. Set the fill colour to transparent, and using the open curve tool, add in some paths to give the lettuce leaf some creases and edit as appropriate (Figure 11.11).

To save the picture, select the File → Save As menu item, and enter the filename.
11.3 CHEESE AND LETTUCE ON TOAST

To include the image in a LaTeX document, select the File → Export menu item, and save it as a LaTeX file (click on the File of Type drop-down list and select pgf \texttt{environment} \texttt{(*.tex, *.ltx)}, and name the file e.g. \texttt{lettuce.tex}. To include it in your LaTeX document, remember to use the pgf package:

```
\usepackage{pgf}
```

and to include the image use \texttt{\input}, e.g.:

```
\begin{figure}
\centering
\input{lettuce}
\caption{Lettuce on Toast}
\end{figure}
```

11.3 Cheese and Lettuce on Toast

This example illustrates how to merge paths. It extends the previous example Lettuce on Toast. The aim is to create the image shown in Figure 11.15.

1. Load the image you created in the lettuce on toast example, using the File → Open menu item, or clicking on the load image button.

2. To create the slice of cheese, select the rectangle tool, and set the fill colour to yellow. Make a rectangle, as illustrated in Figure 11.12.

3. This slice of cheese is going to have holes in it, and we need to be able to see the lettuce and toast through the holes. Since this is not a uniform colour, we can’t just, say, put green ellipses on top of the cheese as this won’t look right. Instead, we are going to create some ellipses, and then merge them into the yellow rectangle. To do this, first select the ellipse tool, and create some ellipses on top of the yellow rectangle (Figure 11.13).
11.4 An Artificial Neuron

This example illustrates setting line styles and adding text. The final image looks best as a \texttt{pgf} picture included in a \LaTeX\ document, as then you can use maths fonts.
11.4 AN ARTIFICIAL NEURON

1. The normal font size for my LaTeX document will be 10pt, so I first need to make sure this is set using the Settings → Configure TeX/LaTeX Settings menu item to open the TeX/LaTeX Settings dialog window. Make sure the Normal Font Size value is set to 10 in the Document Settings tab.

2. Select the rectangle tool, and create a rectangle, as shown in Figure 11.16.

3. Select the ellipse tool, and create a circle, as shown in Figure 11.17.

4. To make the logistic function symbol, select the open curve tool, and do a single segment (Figure 11.18(a)). Then use the edit path tool to adjust the curvature, as shown in Figure 11.18(b). (If you have enabled the grid lock, you may find it easier to disable it while you are editing the curvature control points.)

5. Next set the current line style to have an end arrow. Note that lines with end markers look best with a butt cap style, so this should also be set. This can be done as follows:

Use the Settings → Styles menu item to display the current styles dialog box. Select the tab labelled Line Style to display the line style panel. Select Butt from
11.4 AN ARTIFICIAL NEURON

11.4.1 AN ARTIFICIAL NEURON

Figure 11.18: Artificial Neuron Example — creating a sigmoidal curve: (a) adding an open curve segment; (b) edit segment to adjust curvature.

6. Select the open line tool, and add in the arrows as illustrated in Figure 11.21.

7. Use Settings → Styles to open the current styles selector, and set the font family to “Serif” and the font size to 10pt, and then press Okay. Select the maths tool, and add in the text, as illustrated in Figure 11.22. (I’ve used the Superscripts and
11.4 AN ARTIFICIAL NEURON

Figure 11.20: Artificial Neuron Example — End Marker Dialog Box

Subscripts block in the symbol selector to insert the subscripts.)

Figure 11.21: Artificial Neuron Example — Adding Arrows

Figure 11.22: Artificial Neuron Example — Adding Text

Since I have the maths tool with the maths-mode mappings on, the \LaTeX\ alternative text automatically has the maths-shift characters inserted and the Unicode subscripts have been converted to \textsubscript{1} etc. You can see the \LaTeX\ alternative text if you select the text area and use Edit → Text → Edit text. This will open up the edit text dialog box shown in Figure 11.23.

Now select all of the text on the left (\(x_1\), \(x_2\) and \(x_n\)) and use the Edit → Text → Font Style → All Styles dialog box to change the horizontal anchor parameter to Right. (Note that you will not see any difference to the image in FlowframTk.)

8. Select the maths tool and start a text area in the rectangle. I want to use a capital sigma to indicate a summation, and as I don’t know the magic combination of characters to access that symbol, I used the Insert Symbol dialog box. To do this, either use the popup menu and select Insert Symbol, or press the Ins key. The required symbol can now be selected from the dialog box (illustrated in Figure 11.24). This is the summation symbol (U+2211) from the Mathematical...
11.4 AN ARTIFICIAL NEURON

 Operators block, not the Greek capital sigma from the Mathematical Alphanumeric Symbols block.

9. Use the **Edit → Text → Font Style → All Styles** to change the font size to 25 and change both the anchor settings to **Centre**, see Figure 11.25. (You don’t need to change the anchor settings if you have the **automatic anchor update** setting enabled, as it will change when you justify the **text area** in step 10.)

As before, if you used the maths tool with the maths-mode mappings enabled, the **LaTeX** alternative text should already be correctly set, but you can check by selecting the **text area** and using the **Edit → Text → Edit text** menu item to open the **Edit Text** dialog box (Figure 11.26(b)).
11.4 AN ARTIFICIAL NEURON

Figure 11.26: Artificial Neuron Example — setting the equivalent \LaTeX symbol: (a) selected text; (b) setting \LaTeX equivalent.

10. The Σ would look much better if it was centred inside the rectangle. To do this select the Σ and the rectangle, then group them either by clicking on the group objects button or by using the Transform → Group menu item. Then select the Transform → Justify → Centre menu item, and then the Transform → Justify → Middle menu item. The text area should now be centred inside the rectangle (Figure 11.27).

Figure 11.27: Artificial Neuron Example — Justifying Objects

To include the image inside a \LaTeX document, save the image to a \LaTeX file using the File → Export menu item, and then include it in your document (assuming the file was called neuron.tex):

\begin{figure}
\centering
\input{neuron}
\caption{An Artificial Neuron}
\end{figure}
(Remember to use the \texttt{pgf} package.) The image will appear in the \LaTeX\ document as illustrated in Figure 11.28. (For best results use either PDF\LaTeX\ or \LaTeX\ and \texttt{dvips} as some dvi viewers may not be able to interpret the \texttt{pgf} specials.)

![Artificial Neuron Example — Image as it Appears in a \LaTeX\ Document](image)

**Figure 11.28: Artificial Neuron Example — Image as it Appears in a \LaTeX\ Document**

### 11.5 Bus

This example illustrates how to:

- break a path
- create a path union
- subtract paths
- Use the \texttt{shapepar} function to create a shaped paragraph in a \TeX\ or \LaTeX\ document.

1. If you have not already done so, enable the grid lock via Settings $\rightarrow$ Grid $\rightarrow$ Lock Grid.

2. Use Settings $\rightarrow$ Configure \TeX/\LaTeX\ Settings to display the \TeX/\LaTeX\ Settings dialog box and set the normal font size to the value that you will be using in your document (see Figure 11.29). In my document, I have used 10pt.

3. To create the bus outline, start with the ellipse tool, and create a circle (Figure 11.30).

4. Select the circle, and select the edit path tool. The control point at the start of the path is always the first selected control point when you select the edit tool (Figure 11.31(a)). Select the second segment in the path (Figure 11.31(b)).

5. Break the path using the edit path popup menu and selecting Break path (Figure 11.32(a)). You should now have two separate semi-circles (Figure 11.32(b)). If you find that the circle has been split unevenly (i.e. you have a quadrant and a three-quarters of a circle) then you selected the wrong segment. Don’t panic, just select Edit $\rightarrow$ Undo and try again.

6. Exit edit path mode. Move and rotate the top semi-circle so that it looks like Figure 11.33.
Figure 11.29: Bus Example — Setting the Normal Font Size

Figure 11.30: Bus Example — Create a Circle

Figure 11.31: Bus Example — Editing the Path
Figure 11.32: Bus Example — Break the Path

Figure 11.33: Bus Example — Move and Rotate Top Semi-Circle

Figure 11.34: Bus Example — Adding Lines
7. Select the open line tool and add in the two lines as shown in Figure 11.34.

8. Select all paths and use Transform → Path Union. You should now have just a single path.

9. Select this new path, and use the edit path tool to give the front end of the bus a slightly curved outline, as shown in Figure 11.35. (You may find it easier to temporarily disable the grid lock while you edit the path.)

10. Add the windows, as shown in Figure 11.36.

![Figure 11.35: Bus Example — Convert Line Segment to a Curve](image1)

![Figure 11.36: Bus Example — Add Windows](image2)

11. This next operation assumes that you haven’t changed the stacking order. The main outline of the bus must be at the rear. To ensure this, select the bus outline and use the move to back function.

12. Select all paths, and apply Transform → Subtract Paths. Set the fill colour to red using the Edit → Fill Colour dialog box. The windows should appear as holes. See Figure 11.37.

13. Make sure that the bus is selected. Select the TeX/LaTeX → Shapepar menu item. A dialog box will appear: select the Use Path option and click Okay. Scan lines will appear as FlowframTk works out the parameters. Once completed a file dialog box will appear. Give the file a name, e.g. busshape.tex.

14. If you are using LATEX, create a document that looks something like:

```latex
\documentclass{article}
\usepackage{shapepar}
\begin{document}
\input{busshape}\frenchspacing
The wheels on the bus go round and round...
\end{document}
```
15. If you are using plain \TeX, create a document that looks something like:

\input shapepar.sty
\input busshape.tex
\frenchspacing
The wheels on the bus go round and round...
\bye

16. The resulting shaped paragraph is shown in Figure 11.38.

The wheels on the bus go round and round, round and round, round and round. The wheels on the bus go round and round all day long. The wipers on the bus go swish swish swish, swish
swish swish, swish swish swish. The wipers on the bus go swish swish swish all day long. The horn on the bus goes beep beep beep, beep beep beep, beep beep beep. The horn on the bus goes beep beep beep all day long. The conductor on the bus says “any more fares?” “any more fares?” “any more fares?” The conductor on the bus says “any more fares?” all day long. The mummies on the bus go natter natter natter, natter natter natter, natter natter natter. The mummies on the bus go natter natter natter all day long. The children on the bus make too much noise, too much noise, too much noise. The children on the bus make too much noise all day long. The dogs on the bus go woof woof woof, woof woof woof, woof woof woof. The dogs on the bus go woof woof woof all day long.

Figure 11.38: Bus Example — Resulting Shaped Paragraph
11.6 A Poster

This example illustrates how to use FlowframTk to help construct frames for use with the flowfram package. The aim is to create a \LaTeX\ package based on the flowfram package that defines frames for use with a poster. For this example, I used the A4 landscape paper setting, but it can just as easily be applied to other paper sizes.

1. Set the grid to the unit of your choice using the Settings → Grid → Grid Settings dialog box. For example, I set the grid settings to major divisions of 1in, with 10 subdivisions. I also set the storage unit to 1in.

2. I recommend that you set the grid lock on (using Settings → Grid → Lock Grid), to help prevent having frames with slightly different widths, which will result in warnings from the flowfram package.

3. Set the typeblock, using the \TeX/LaTeX → Flow Frames → Set Typeblock menu item. I used 1in margins. You should now see the typeblock appear as a light grey rectangle on the page. (Note that you can not select or move the typeblock, you can only modify it using the \TeX/LaTeX → Flow Frames → Set Typeblock dialog box.) See Figure 11.39.

4. Select the rectangle tool, and create the rectangles shown in Figure 11.40. The top rectangle is going to be the title frame, the two tall rectangles on the left will be flow frames containing the main text for the poster, and the two short rectangles on the right will be dynamic frames that will contain a table and a figure. (To ensure that the two tall rectangles are the same size, you may prefer to use the copy and paste function.)
5. Switch to the select tool, and add a bitmap using Bitmap → Insert Bitmap, to give the poster a logo, and move it to the location shown (Figure 11.41).

6. Garish posters are not recommended, but to illustrate how to liven up the poster, set the fill colours for the rectangles using the Edit → Fill Colour dialog box. I also added two extra smaller rectangles on top of the right hand rectangles, to give a double border effect (Figure 11.42).

7. Select the top rectangle and the bitmap, and group them. Select the bottom right hand rectangles (green) and group them. Select the middle right hand rectangles (magenta) and group them.

8. Select the top group, and select the TeX/LaTeX → Flow Frames → Set Frame menu item. This will open up the dialog box shown in Figure 11.43. Set the type to Static, and call it “title”. Set the margins as desired. (I used 0.1in for all the margins, but you may want to use different values to ensure that the logo is inside the margins so that the frame’s text doesn’t overlap the image.)

9. Click on the Edit button to open the mini TeX editor and type in the following:

```latex
\title{A Sample Poster}
\author{Nicola Talbot}
\maketitle
\thispagestyle{empty}
```

as shown in Figure 11.44. (Since \maketitle sets the page style to plain, this sets it to empty as page numbers aren’t appropriate here.)

To close the editor either click on the “Okay” button (the one with the green tick) or press Shift-Enter.
Figure 11.41: Poster Example — Adding a Bitmap

Figure 11.42: Poster Example — Adding Some Colour
Figure 11.43: Poster Example — assigning frame information. (Note that the shape option is not available because the selected object is a group not a path.)

Figure 11.44: Poster Example — Adding Contents to a Static Frame
10. Similarly, make the left hand rectangle a flow frame with label “left” and the middle rectangle a flow frame with label “middle”. (Flow frames can’t be assigned contents, so the Edit button will now be disabled.)

11. Make the two remaining groups dynamic frames with labels “figure” and “table”. For these two, I used larger margins (0.2in) to compensate for the double border (Figure 11.45).

Again use the mini \TeX editor to set the contents. The “figure” frame’s contents are:

\begin{staticfigure}
\centering
Insert figure here!
\caption{A Sample Figure}
\label{fig:sample}
\end{staticfigure}

The “table” frame’s contents are:

\begin{statictable}
\caption{A Sample Table}
\label{tab:sample}
\centering
Insert table here!
\par
\end{statictable}
12. Move the slider between the canvas and the preamble panel, or use the menu item TeX/LaTeX → Preamble Editor to show the preamble panel. In the early-preamble tab, add the following:

```latex
\RequirePackage[utf8]{inputenc}
\RequirePackage[T1]{fontenc}
\RequirePackage{lmodern}
```

as shown in Figure 11.46. (You can use `\usepackage` instead of `\RequirePackage`. Any instances of `\usepackage` will automatically be converted to `\RequirePackage` if the image is exported to a class or package.)

![Poster Example — Adding Preamble Information](image)

Figure 11.46: Poster Example — Adding Preamble Information

13. Use the menu item File → Export to create a new \LaTeX{} package or class that defines these frames. Remember to select the Package (*.sty) file filter. I called my file `poster.sty` (Figure 11.47) which will create a package rather than a class.

14. Create a \LaTeX{} document that uses this package or class.

First, let’s suppose I’ve exported to a package. Since I used A4 landscape paper, it’s simplest use the `article` class file. If you use a larger size (e.g. A0), it would be more appropriate to use the `a0poster` class file.

I created the following file called `poster.tex`:

```latex
\documentclass{article}
%
% use new package created in this example:
\usepackage{poster}
```
11.6 A POSTER

\begin{document}

This is the main body of the poster. This text will appear in the first of the two flow frames. Once it has reached the end of the first flow frame, it will then continue in the second flow frame.

% Lots of text omitted

\end{document}

Now suppose I've exported to a class by using the Class (*.cls) filter in the export dialog. Then the start of my poster.tex file just uses this class:

% use new class created with this example:
\documentclass{poster}

\begin{document}

This is the main body of the poster. This text will appear in the first of the two flow frames. Once it has reached the end of the first flow frame, it will then continue in the second flow frame.

% Lots of text omitted

\end{document}

This is actually more convenient than creating a package.

15. To make the poster a PDF document, do:

\texttt{pdflatex poster.tex}

(Note that the \texttt{pgf} package is used to create the borders, so you will need to use a driver that understands the \texttt{special} commands used by the \texttt{pgf} package, such as PDF\LaTeX or \LaTeX and \texttt{dvips}.) The final document is illustrated in Figure 11.48.
11.7 A Newspaper

This example illustrates how to use FlowframTk to create a class or package based on the flowfram package, using non-standard shaped frames. The aim is to produce the document shown in Figure 11.79 on page 214.

1. In this example, my newspaper is going to be on A4 portrait paper, with a normal font size of 12pt, so the first thing to do is to select the paper size and orientation using Settings → Paper → A4 and Settings → Paper → Portrait, and set the value of the \baselineskip normal size font, using the Settings → Configure TeX/LaTeX Settings dialog box (see Figure 11.49). Select 12 from the drop-down list.

2. The 12pt font size has a corresponding \baselineskip of 14.5pt. For this example, it is more practical to have a grid that has intervals of this size, as it gives a guide as to how many lines there will be in each frame. Therefore I set the grid to have 145pt major divisions with 10 subdivisions. This means that each minor tick mark is at a distance of 14.5pt (one \baselineskip) from its neighbour. To do this select Settings → Grid → Grid Settings, and enter the values as shown in Figure 11.50.

3. To help reduce rounding errors, I’m also going to set the storage unit to 1pt. To do this select Settings → Configure Image Settings and change the storage unit in the Control Points tab, as shown in Figure 11.51.

4. Next set the typeblock. This nominally defines the paper margins, although it is possible to define frames outside this area. I used 58pt margins on all sides.

---

1This is of course only an approximate guide, as larger or smaller font sizes may be used in a frame, which will affect the total number of lines in the frame.
11.7 A NEWSPAPER

![Image of LaTeX Settings window]

Figure 11.49: Newspaper Example — Setting the \LaTeX\ Normal Font Size

![Image of Grid Settings window]

Figure 11.50: Newspaper Example — Setting the Grid

![Image of Configure Image Settings window]

Figure 11.51: Newspaper Example — Setting the Storage Unit
11.7 A NEWSPAPER

To do this, select \TeX/\LaTeX \rightarrow Flow Frames \rightarrow Set Typeblock which will display the dialog box shown in Figure 11.52. Enter the values shown and click on Okay or press Enter to continue. You should now see a pale grey rectangle displayed on the canvas denoting the typeblock.

![Figure 11.52: Newspaper Example — Setting the Typeblock](image)

5. The newspaper is going to have a static frame along the top of the typeblock that will contain the title of the paper. This isn’t going to have a border, but we will need to draw a rectangle to define the frame’s bounding box. So select the rectangle tool and draw a rectangle with opposing corners at (58pt,58pt) and (536.5pt,145pt). You should now see something like Figure 11.53.

6. Switch to the select tool, and select this rectangle. Select \TeX/\LaTeX \rightarrow Flow Frames \rightarrow Set Frame and enter the values shown in Figure 11.54(a). Note that the Border field has been set to None. The frame contents should be:

\begin{center}
\bfseries\Huge Fairy Tale Times
\end{center}
\hfill Issue 2. 7 December 2005.

This can be set by clicking on the Edit button, which will open the mini \TeX editor, shown in Figure 11.54(b).

7. Below the title, there will be two columns each with its own heading. I am going to make separate frames for the headings, and since the headings will be in a larger font, I shall give their frames a height of twice the $\backslash$baselineskip. Select the rectangle tool, and make two rectangles with opposing corners at:

- (58pt, 159.5pt) and (290pt, 188.5pt)
- (304.5pt, 159.5pt) and (536.5pt, 188.5pt)

You should now see something like Figure 11.55.

8. Switch to the select tool, and select the left hand frame, and assign the flowframe data shown in Figure 11.56. The frame contents contains the section command:

\section{Killer Wolf on the Loose}
Figure 11.53: Newspaper Example — Title Frame
9. Do the same for the right hand rectangle, but call it \textit{rightheading}. The frame contents contains the section command:

\section{Tragic Wall Accident}

10. The left hand column is going to angle around underneath the right hand column, as it will have more text in it. Select the \textit{closed line tool} and make a polygon with vertices at (58pt, 203pt), (58pt, 507.5pt), (536.5pt, 507.5pt), (536.5pt, 420.5pt), (290pt, 420.5pt) and (290pt, 203pt) as shown in Figure 11.57.

11. Switch to the \textit{select tool}, and select this L shaped polygon, and assigned the flowframe data shown in Figure 11.58. Note that the Alignment field has been set to \textit{Top} to ensure that if there is insufficient text to fill the frame, all blank space will go at the bottom of the frame, and thus help to keep the frame’s shape. I used \textit{Parshape} rather than \textit{Shapepar} to define the frame’s shape as I don’t want it to shrink and grow to fit the text.

The frame contents are quite long. You can either set the text in \textit{FlowframTk} or use one of \textit{flowfram}'s commands in the document. Here’s the full text:

The authorities are warning of a killer wolf on the loose. He has so far devoured an old grandmother and two pig brothers. He is described as being furry with big eyes and big teeth.

On Monday this week he broke into a house, and devoured an old lady. He then disguised himself as the old lady
11.7 A NEWSPAPER

Figure 11.55: Newspaper Example — Left and Right Heading Frames Added

Figure 11.56: Newspaper Example — Assigning Flowframe Data to Left Heading Frame
Figure 11.57: Newspaper Example — Added L Shaped Frame
in order to deceive her granddaughter. Luckily for the little girl a woodsman arrived in time to rescue her. Parents are being cautioned not to let their children wander about on their own, and to remind them not to talk to strangers.

The next day the wolf struck again, this time targeting two pig brothers who had most incautiously made their dwellings on the cheap using inadequate materials. The wolf also made an attempt on the third pig brother, but was unable to break into his house.

Police are appealing to the public for witnesses, and remind people to keep their doors securely fastened at all times.

‘‘Always ask to see identification,’’ said one police advisor, ‘‘and invest in improving the general security of your property.’’

Figure 11.58: Newspaper Example — Assigning Flowframe Data to L Shaped Frame

12. I’m going to illustrate the story in the right hand column. The image egg.png is supplied with the flowfram package but is also available in the examples subdirectory of FlowframTk’s installation directory. Use Bitmap → Insert Bitmap to insert the bitmap on the canvas. This will initially appear in the top left hand corner of the canvas. Move it over to the location shown in Figure 11.59, either by dragging it or by using Edit → Move By and specifying a horizontal (x) displacement of 472.8pt and a vertical (y) displacement of 206pt.

13. Set the flowframe data shown in Figure 11.60 to this bitmap. Note that you must set the Border setting to As Shown, otherwise the bitmap will not appear in the document.

14. Next comes the right hand frame. This is a polygon with a stepped area that goes around the bitmap. Select the closed line tool, and construct a polygon with vertices at: (304.5pt, 203pt), (304.5pt, 406pt), (536.5pt, 406pt), (536.5pt, 290pt),...
Figure 11.59: Newspaper Example — Added Image

Figure 11.60: Newspaper Example — Assigning Flowframe Data to Bitmap
(478.5pt, 290pt), (478.5pt, 261pt), (464pt, 261pt), (464pt, 232pt), (478.5pt, 232pt) (478.5pt, 217.5pt), (493pt, 217.5pt) and (493pt, 203pt) as shown in Figure 11.61.

Figure 11.61: Newspaper Example — Added Right Hand Polygon

15. Switch to the select tool, select this polygon and assign the flowframe data shown in Figure 11.62. Note that the Shape field has been set to Parshape and the Alignment field has been set to Top. Again, the contents of the frame are quite long and can either be set using FlowframTk or using one of flowfram’s commands in the document. I’m going to set the contents using FlowframTk, as above. The text is as follows:

An egg person tragically fell from a six foot wall yesterday afternoon and was smashed to pieces. The king’s cavalry rushed to the scene, but regretted that they were unable to help him.

Humpty Dumpty was believed to be sitting on the wall when he fell. Police have ruled out foul play, but
are advising people not to play on high walls, particularly those vulnerable members of the population suffering from eggshell syndrome.

*exclusive* interview with one of the King’s men on page 6.

![Flow Frames](image)

**Figure 11.62: Newspaper Example — Assigning Flowframe Data to Right Hand Polygon**

16. I’m going to add an L-shaped segment between the left and right blocks to clearly delineate them. Switch to the open line tool, and construct a path with vertices at: (297.25pt, 159.5pt), (297.25pt, 413.25pt) and (536.5pt, 413.25pt) as shown in Figure 11.63. (You’ll need to switch off the grid lock.)

17. Switch to the select tool, select this new path and assign the flowframe data shown in Figure 11.64. Make sure that you have set the Border field to As Shown.

18. Next comes a horizontal divider to separate the top two columns from the bottom columns (which will be created later). Select the open line tool, and construct a line with end points at: (58pt, 514.75pt) and (536.5pt, 514.75pt) as shown in Figure 11.65.

19. Switch to the select tool, select this line and assign the flowframe data shown in Figure 11.66.

20. Next comes another header frame. Select the rectangle tool, and construct a rectangle with opposing corners at: (58pt, 522pt) and (536.5pt, 551pt) as shown in Figure 11.67.

21. Switch to the select tool, select this rectangle, and assign the flowframe data as shown in Figure 11.68. The frame contents is another sectioning command:

\section{Relief as Missing Sheep Finally Return Home}
Figure 11.63: Newspaper Example — Added L Shaped Divider

Figure 11.64: Newspaper Example — Assigning Flowframe Data to L Shaped Divider
Figure 11.65: Newspaper Example — Added Horizontal Divider

Figure 11.66: Newspaper Example — Assigning Flowframe Data to Horizontal Divider
Figure 11.67: Newspaper Example — Added Lower Header

Figure 11.68: Newspaper Example — Assigning Flowframe Data to Lower Header
22. At the bottom of the page, I want to have two columns, with the text flowing from
the left hand column into the right hand column. This means that these frames
need to be flow frames. Select the rectangle tool, and construct two rectangles
with opposing corners at:

- (58pt, 565.5pt) and (290pt, 783pt)
- (304.5pt, 565.5pt) and (536.5pt, 783pt)

as shown in Figure 11.69.

![Figure 11.69: Newspaper Example — Added Lower Left and Right Rectangles](image)

23. Switch to the select tool, select the left lower rectangle and assign the flowframe
data shown in Figure 11.70. Similarly for the right hand lower rectangle.

24. I also want to have an image in the lower left hand frame. This is going to
be slightly more complicated as flow frames can not be assigned a shape like
the static and dynamic frames. The image I’m going to use is called sheep.png
and is provided with the flowfram package, but it is also available in the
examples subdirectory of FlowframTk’s installation directory. Use Bitmap→
25. Assign this bitmap the flowframe data shown in Figure 11.72.

26. As it stands, any text in the left flow frame will overlap the sheep image, so I’m going to construct a new polygon to go around the sheep image. This polygon will not form a frame, but will be used to construct the parameters of the \texttt{parshape} command, which can then be input at the start of the flow frame. To do this, select the closed line tool, and construct a polygon with vertices at: (116pt, 565.5pt), (116pt, 580pt), (101.5pt, 580pt), (101.5pt, 609pt), (58pt, 609pt), (58pt, 783pt), (290pt, 783pt) and (290pt, 565.5pt) as shown in Figure 11.73.

27. Select this polygon, and select the \texttt{TeX/LaTeX → Parshape} menu item. This will open the dialog box shown in Figure 11.74(a). Select the Use Path option and click Okay. Save to a file named \texttt{sheepcutout.tex} (Figure 11.74(b)).

28. Open the preamble pane using \texttt{preamble editor} using \texttt{TeX/LaTeX → Preamble Editor} or just move the divider across and set the early-preamble code as follows:

```
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
```

(see Figure 11.75) and the late preamble to

```
% suppress section numbering
\setcounter{secnumdepth}{0}
% set the paragraph indentation for static
% and dynamic frames
\setlength{\sdfparindent}{\parindent}
```
11.7 A NEWSPAPER

Figure 11.71: Newspaper Example — Added Sheep Bitmap

Figure 11.72: Newspaper Example — Assigning Flowframe Data to Sheep Bitmap
Figure 11.73: Newspaper Example — Added Polygon Defining Text Region

(a) 

(b)

Figure 11.74: Newspaper Example — computing `\parshape` parameters: (a) select “Use Path” option; (b) export dialog.
Figure 11.75: Newspaper Example — Setting the Early Preamble Code
Figure 11.76: Newspaper Example — Setting the Late Preamble Code
(See Figure 11.76.)

29. Construct a rectangle with opposing corners at: (551.0, 797.5) and (580.0, 826.5) as shown in Figure 11.77.

Figure 11.77: Newspaper Example — Constructing the Footer Frame

30. Following the same procedure as before, select this new rectangle and make it a dynamic frame with the label “footer” and middle alignment. Then click on the Compute Symmetric X Shift button to calculate the horizontal shift for even pages. Set the contents to just `\itshape` (see Figure 11.78).

31. Save the image as `newspaper.jdr` and then select the File → Export menu item. Select the Class (*.cls) filter, and save as `newspaper.cls`.

32. Use your favourite text editor to create a file called `news.tex` that looks like:

```latex
\documentclass{newspaper}

\begin{document}
```
Figure 11.78: Newspaper Example — Assigning the Footer Frame Data

% set the paragraph shape
\input{sheepcutout}
% suppress paragraph indentation
\noindent
There was much celebration yesterday morning when Little Bo Peep’s sheep finally returned home. They had been missing for more than a week.

``I just didn’t know where to find them,’’ the shepherdess stated, ‘‘but I was told to leave them alone and they’d come home.’’

% lots of text omitted
\end{document}

This file is also available in the examples subdirectory of FlowframTk’s installation directory.

33. The included images are PNG files, which means that if you are not using PDFLaTeX you will have to convert them to Encapsulated Postscript (EPS) to use LaTeX and dvips. Run news.tex through LaTeX, e.g.

pdflatex news

The resulting document is shown in Figure 11.79.

Things to note:

- You may have noticed that I had the page list for all my frames set to All. Naturally if you want more pages in your document, you will need to change this. However on your final page you will need to specify an open ended range. For example, if you have a 4 page document, then at least one flow frame defined on page 4 should have a page list like >3. This is because the flowfram package
Fairy Tale Times

Issue 2. 7 December 2005.

Killer Wolf on the Loose

The authorities are warning of a killer wolf on the loose. He has so far devoured an old grandmother and two pig brothers. He is described as being furry with big eyes and big teeth.

On Monday this week he broke into a house, and devoured an old lady. He then disguised himself as the old lady in order to deceive her granddaughter. Luckily for the little girl a woodman arrived in time to rescue her. Parents are being cautioned not to let their children wander about on their own, and to remind them not to talk to strangers.

The next day the wolf struck again, this time targeting two pig brothers who had most incautiously made their dwellings on the cheap using inadequate materials. The wolf also made an attempt on the third pig brother, but was unable to break into his home.

Police are appealing to the public for witnesses, and remind people to keep their doors securely fastened at all times.

“Always ask to see identification,” said one police advisor, “and invest in improving the general security of your property.”

Tragic Wall Accident

An egg person tragically fell from a six foot wall yesterday afternoon and was smashed to pieces. The king’s cavalry rushed to the scene, but regretted that they were unable to help him.

Humpty Dumpty was believed to be sitting on the wall when he fell. Police have ruled out foul play, but are advising people not to play on high walls, particularly those vulnerable members of the population suffering from eggshell syndrome.

Exclusive interview with one of the King’s men on page 6.

Relief as Missing Sheep Finally Return Home

There was much celebration yesterday morning when Little Bo Peep’s sheep finally returned home. They had been missing for more than a week.

“I just didn’t know where to find them,” the shepherdess stated, “but I was told to leave them alone and they’d come home.”

Unusual advice perhaps, but it seems to have worked as they did indeed come home. Eye witnesses reported that their tails were wagging behind them. “I’m just so happy they’ve come home,” Little Bo Peep said in a press conference yesterday afternoon. The sheep themselves made no comment, and police are still trying to determine what happened to them. The big bad wolf is reportedly helping them with their inquiries.

This is a sample document illustrating the flowfram package. It uses TeX’s \parshape command to create irregularly shaped paragraphs. This can be a complicated and somewhat tiresome task, but is made easier using FlowframTk. The paragraph breaks in the static frames are actually simulated breaks to ensure the \parshape stays in effect until the end of the frame. This is done behind the scenes by the flowfram package, but is something that you need to be aware of in case it causes a problem with other commands.

Figure 11.79: Newspaper Example — Final Document
looks ahead for the next flow frame before it ships out the page. If there are no more flow frames defined, it will automatically create a new flow frame, and you may end up with an unwanted page.

- The `twoside` class option is required to ensure the footer frame’s horizontal shift is implemented on even pages. Since this example only has one page, there’s no noticeable difference.

- If you use `FlowframTk` to create \parshape’d paragraphs for your document, you must make sure that the normal font size setting in `FlowframTk`’s Document Settings dialog box is the same as that used by your document, otherwise it will affect the shape of the paragraph. Likewise, if your paragraph contains larger or smaller than normal lines this will also adversely affect the paragraph shape, and you will need to adjust the shape of the path accordingly.

Since I exported to a class rather than a package, the class file correctly sets the normal font size to match the setting used by the image, and I’m only using normal sized text in my paragraphs with no displayed material, so I don’t need to worry about it. However, if I had exported to a package, `newspaper.sty`, which was then included in the document using:

```latex
\documentclass[twoside,12pt]{article}
\usepackage{newspaper}

\begin{document}
% set the paragraph shape
\input{sheepcutout}
% suppress paragraph indentation
\noindent
There was much celebration yesterday morning when Little Bo
% etc

Then the paragraph shape will go wrong if the document normal size doesn’t match the image’s normal size setting (see Figure 11.80).

11.8 A Brochure

This example illustrates how to use `FlowframTk` to create a class that loads the `flowfram` package. The aim is to produce a two-sided document with different recto and verso headers and footers.

1. For this example I’m going to start with the Tschichold grid. Use `Settings → Grid → Grid Settings` to open the grid dialog box. Select the Tschichold tab and set the Major Divisions to 100pt, as shown in Figure 11.81. Make sure that the grid lock is on (`Settings → Grid → Lock Grid`).

2. Use `Settings → Configure TeX/LaTeX Settings` to open the TeX/LaTeX Settings dialog and select the Document Settings tab. Set the Normal Font Size to 10pt, as shown in Figure 11.82, and make sure the Use default class radio button is selected.
The normal font size setting affects paragraph shapes: (a) both the \LaTeX document and FlowframTk have been set to use a normal size font of 12pt — the paragraph follows the correct shape; (b) the \LaTeX document used 12pt as the normal font size, but FlowframTk had the normal font size set to 10pt — the paragraph has too many narrow lines and spills over the bottom of the frame.

Figure 11.81: Brochure Example — Setting the Grid

Figure 11.82: Brochure Example — Setting the Normal Font Size
Figure 11.83: Brochure Example — Setting the Storage Unit

If you change the storage unit, all coordinates in the current frame will be converted to the new storage unit. This may take a while if you have a large or complex image, so it’s generally best to set the storage unit before you start your image. The storage unit is independent of the grid unit. Some settings, such as line width or font size, are independent of the storage unit.
3. Set the image storage unit to pt using Settings → Configure Image Settings dialog box, as shown in Figure 11.83.

4. Select the rectangle tool (either via Tools → Rectangle or Ctrl-R) and draw the rectangle with three of its vertices on the diagonals, as shown in Figure 11.84. With the grid lock on, you are limited to only fourteen tick marks.

5. Switch to the select tool (Tools → Select or Ctrl-P) and select the rectangle. Then open the Typeblock dialog using \texttt{TeX/LaTeX} → \texttt{Flow Frames} → Set Typeblock. Click on the Compute Margins From Selected Path button. (If this button is disabled, close the dialog and check that the rectangle has been selected.) This will fill the margins, but it looks a bit untidy with all those decimal places and since a pt is so small such precision seems unnecessary so round the Left and Top margins to the nearest pt (66pt and 94pt, respectively). Make sure the Adjust width to nearest field is set to 1pc and click on the Adjust Width button. This should alter the Right field. Make sure the Baselineskip radio button is selected and click on the Adjust Height button. Finally, click on the Compute button to calculate the even page shift. The settings should now be as shown in Figure 11.85. Click on the okay button to apply these settings and close the dialog.

6. The typeblock is slightly smaller than the rectangle so, making sure the rectangle is still selected, use the menu item \texttt{TeX/LaTeX} → \texttt{Flow Frames} → Scale to Fit Typeblock to scale the rectangle so that it’s the same size as the typeblock. Then use the \texttt{TeX/LaTeX} → \texttt{Flow Frames} → Set Frame menu item to open the Set Frame dialog. Set the Type to Flow, set the Label to “main” and set the Border to None, as shown in Figure 11.86. The margins and shifts should all be zero and the page list All.

7. Now use Settings → Grid → Grid Settings to switch the grid to a rectangular grid with 100pt major divisions and use the ellipse tool (Tools → Ellipse or Ctrl-E) to create a circle with a 100pt radius centred on (400, 700), as shown in Figure 11.87.

8. Switch to the select tool (Tools → Select or Ctrl-P), select the circle and switch to edit path mode (Edit → Path → Edit Path or Ctrl-I). Use the popup menu to remove the segment from (500, 700) to (400, 800), convert the curve segments from (400, 800) to (300, 700) and from (400, 600) to (400, 800) into line segments, and move the control at (400, 800) to (400, 700). The path should now appear as shown in Figure 11.88.

9. Exit the edit path mode and move the path to the bottom right edge of the canvas, as shown in Figure 11.89.

10. Use Edit → Fill Colour to change the fill colour to orchid (68% red, 36% green, 100% blue) and use Edit → Path → Line Colour to change the line colour to transparent. The arc should now appear as shown in Figure 11.90.

11. Make sure the arc is still selected and open the Set Frame dialog using \texttt{TeX/LaTeX} → \texttt{Flow Frames} → Set Frame menu item. Set the Type to Dynamic, set the Label to “footer”, set the Border to As Shown, set the Pages to Odd and set the Alignment to Middle. Set the Left and Top margins to 40pt and the Right and Bottom margins to 10pt. Next, click on the Edit button to open the mini \LaTeX{} editor and enter:
Figure 11.84: Brochure Example — Draw a Rectangle
Figure 11.85: Brochure Example — Setting the Typeblock

Figure 11.86: Brochure Example — Setting the Main Flow Frame
Figure 11.87: Brochure Example — Draw a Circle
Figure 11.88: Brochure Example — Change the Circle into an Arc
Figure 11.89: Brochure Example — Move the Arc to the Bottom Right Corner
Figure 11.90: Brochure Example — Apply a Fill Paint to the Arc
as shown in Figure 11.91(a). Click on the okay button to close the editor and return to the Set Frame dialog, which should now look like Figure 11.91(b).

12. Click okay to apply the new settings and close the dialog. The image should now appear as shown in Figure 11.92.

13. Copy (Edit $\rightarrow$ Copy or Ctrl-C) and paste (Edit $\rightarrow$ Paste or Ctrl-V) the arc to create a duplicate. The duplicate should now be the only object selected. Use Transform $\rightarrow$ Scale to open the Scale Selection dialog and set the Scale X field to $-1$, as shown in Figure 11.93. Click on the okay button and this should flip the duplicate arc.

14. With the duplicate arc still selected, use TeX/LaTeX $\rightarrow$ Flow Frames $\rightarrow$ Set Frame to open the Set Frame dialog box again. Set the Label to “evenfooter”, set the Pages to Even, set the Left margin to 10pt and the Right margin to 40pt. The dialog should now appear as shown in Figure 11.94.

15. Use TeX/LaTeX $\rightarrow$ Flow Frames $\rightarrow$ Display Page to open the Display Frames dialog and select the Even Pages radio button, as shown in Figure 11.95. The canvas should now look as shown in Figure 11.96. The “footer” frame is no longer displayed as it’s only defined on odd pages.

16. Move the “evenfooter” frame to the bottom left corner, so that it now appears as shown in Figure 11.97.

17. Use TeX/LaTeX $\rightarrow$ Flow Frames $\rightarrow$ Display Page to open the Display Frames dialog again and select the All Pages radio button and click on the okay button. The canvas should now look like Figure 11.98. The “evenfooter” frame now appears in a different location, but that’s just its odd page position. Since the page list is set to even pages only, it won’t actually be displayed in that location in the document.

18. Use the closed-line tool (Tools $\rightarrow$ Closed Line) to create the path shown in Figure 11.99. The co-ordinates are: (310,0), (360,50), (600,50) and (600,0).

19. Switch to the select tool (Tools $\rightarrow$ Select) and select this new polygon. Set the fill to orchid and line colour to transparent, as done earlier for the arc. Then use TeX/LaTeX $\rightarrow$ Flow Frames $\rightarrow$ Set Frame to open the Set Frame dialog again. Set the Type to Dynamic, set the Label to “header”, set the Pages to Odd, set the Border to As Shown, set the Alignment to Middle, set the Left to 50pt and set the remaining margins to 10pt. Then click on the Edit button to open the editor, and set the contents to:

\textbf{large}

as shown in Figure 11.100(a). Click on the okay button to go close the editor and go back to the Set Frame dialog, which should now look like Figure 11.100(b).

20. Click on the okay button to apply these settings and close the dialog. Keep the polygon selected and copy and paste it to create a duplicate, as shown in Figure 11.101.
Figure 11.91: Brochure Example — Setting the odd footer: (a) entering the frame contents; (b) the frame settings.
Figure 11.92: Brochure Example — Arc is Now an Odd Footer

Figure 11.93: Brochure Example — Flipping the Duplicate Arc
Figure 11.94: Brochure Example — Setting the Even Footer

Figure 11.95: Brochure Example — Changing the Display Page
Figure 11.96: Brochure Example — Even Pages Display
Figure 11.97: Brochure Example — Moving the Even Footer
Figure 11.98: Brochure Example — “all pages” display mode shows all objects in their odd-page location.
Figure 11.99: Brochure Example — Adding a Closed Polygon
Figure 11.100: Brochure Example — Setting the odd header: (a) entering the frame contents; (b) the frame settings.
Figure 11.101: Brochure Example — Create a Duplicate Polygon
21. Flip the duplicate using the same method as earlier (Transform → Scale) and, keeping the duplicate selected, use TeX/LaTeX → Flow Frames → Set Frame to open the Set Frame dialog again. Set the Label to “evenheader” and change the left margin to 10pt and the right margin to 50pt, as shown in Figure 11.102.

![Figure 11.102: Brochure Example — Setting the Even Header](image)

22. Use TeX/LaTeX → Flow Frames → Display Page to open the Display Frames dialog again and select the Even Pages radio button to switch to the even page view, as shown in Figure 11.103.

23. Move the “evenheader” frame to the top left corner of the canvas, as shown in Figure 11.104.

As with the “evenfooter” frame, when you switch back to the “all pages” view, the frame will be displayed in its odd page position, but since the page list is set to even pages only, it won’t be displayed in the document at that location.

24. Save the image as brochure.jdr or brochure.ajr using the File → Save As menu item. Then use File → Export to open the Export dialog. Select the Class (*.cls) filter and export the image as brochure.cls.
Figure 11.103: Brochure Example — Even Pages Display (Two Objects Hidden)
Figure 11.104: Brochure Example — Move Even Header
Figure 11.105: Brochure Example — All Pages View Again (All Frames Shown in their Odd Page Position)
11.9 A HOUSE WITH NO MOUSE

25. Create a document that uses this new class. I’ve used the blindtext package to generate pages of dummy text for illustrative purposes:

\documentclass[twoside]{brochure}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage{blindtext}

\begin{document}
\Blinddocument
\end{document}

A double-page spread view of the resulting document (pages 2 and 3) is shown in Figure 11.106.

Figure 11.106: Brochure Example — Double-Page Spread View of Brochure

11.9 A House With No Mouse

This example illustrates how to create and edit pictures without using the mouse.

1. For this example I’m going to use bp units, both for the grid and for the storage unit. First for the grid, use the menu mnemonics Alt-S G G. This will open up the Grid Settings dialog box shown in Figure 11.107. The Major Divisions field should always have the focus, but if not, you can do Alt-M. Set this value to 100.
Press the Tab key to move to the unit drop-down list. Press the bp key to select bp. Press Tab or Alt-S to select the Sub-Divisions field. Set this value to 10. Then press Enter or Shift-Enter to apply these settings and close the dialog box.

Figure 11.107: No Mouse Example — Grid Settings Dialog Box

2. Use the menu mnemonics Alt-S C to open the Configure Image Settings dialog (Figure 11.108). If the Control Points tab isn’t already visible, you can do Alt-N to select it. Then do Alt-U to move the focus to the storage unit drop-down list. Press bp to select bp or use the up/down cursor keys. If the focus is on a drop-down list you need to use Shift-Enter to apply these settings and close the dialog box. If you move the focus to another component, you can use Enter instead.

Figure 11.108: No Mouse Example — Storage Unit
3. Make sure that you don’t have the grid lock on as some of the co-ordinates that this example uses lie between tick marks. Shift-F2 or Alt-S G L toggles between setting the grid lock on and off.

4. Select the rectangle tool, using either Ctrl-R or Alt-O R.

5. The rectangle forming the main part of the house will go from (100bp, 100bp) to (250bp, 200bp). To move the mouse either press F5 or use the menu mnemonic Alt-N G. This will open up the dialog box shown in Figure 11.109. Set the x field to 100bp and the y field to 100bp. (You can use the Tab key to move to the next focusable component, or you can use Alt-X to select the x field and Alt-Y to select the y field.) Then press Enter or Shift-Enter.

![Figure 11.109: No Mouse Example — Go To Co-Ordinate Dialog Box](image)

6. Press F4 to emulate a mouse click. This will anchor the rectangle at (100bp, 100bp). Then use either F5 or Alt-N G to display the Go To dialog box. Set the x field to 250bp and the y field to 200bp. Then press Enter or Shift-Enter.

7. To complete the rectangle, press either Enter or F4. (See Figure 11.110.)

![Figure 11.110: No Mouse Example — Completed Rectangle](image)

8. Let’s make it a yellow brick house. To change the rectangle’s fill colour, we first need to switch to the select tool. To do this either use Ctrl-P or use the menu mnemonic Alt-O S.
9. To select the rectangle, use either F6 or Alt-N K. \(^2\) Alternatively, you can use Alt-N D which will show a dialog box with a drop-down list that you can use to select an object.

10. To change the fill colour use the menu mnemonic Alt-E L. This will open up the dialog box shown in Figure 11.111.

\[\text{Figure 11.111: No Mouse Example — Set Fill Colour Dialog Box}\]

11. To select the Colour radio button, either do Alt-L or press Tab until the Colour button has the focus, and then press Space.

12. The single colour selector will now be enabled. To change the colour to yellow, you can do one of the following:

- Press Tab until the yellow swatch is selected, and then press Space.
- Press Alt-R to select the RGB panel and set the Red field to 100, the Green field to 100, the Blue field to 0 and the Alpha field to 100.
- Press Alt-K to select the CMYK panel and set the Cyan field to 0, the Magenta field to 0, the Yellow field to 100, the Black field to 0 and the Alpha field to 100.

\(^2\)Since there is only one object on the canvas, you could use any of the other select functions in the Navigate menu, but F6 is easier to type.
Then press Enter or Shift-Enter to apply the fill colour and close the dialog box (see Figure 11.112).

Figure 11.112: No Mouse Example — Fill Colour Set

13. Next we need to construct a triangle for the roof. The closed line path tool is needed for this, so either use Ctrl+Shift-L or use the menu mnemonic Alt-O I.

14. The triangle vertices will be at (80bp, 100bp), (175bp, 50bp) and (270bp, 100bp). Move to the first co-ordinate using either F5 or Alt-N G, and set the x field to 80bp and the y field to 100bp in the Go To dialog box. Press Enter or Shift-Enter to close the dialog box and move the mouse to the required location, and press F4 to set the first vertex.

15. Repeat the process for the second and third vertices, and press Enter to complete the path. The path will automatically close. (See Figure 11.113.)

16. Let’s make the roof red. First switch to the select tool using either Ctrl-P or Alt-O S.

17. Select the triangle using F6 or Alt-N K.

18. Open the fill colour dialog box using the menu mnemonic Alt-E L.

19. Use Alt-L to select the Colour radio button.

20. To set the colour to red either use the Tab key to move the focus to the red colour swatch and press Space or use Alt-R to select the RGB tab and set the Red field to 100, the Green and Blue fields to 0 and the Alpha field to 100.

21. Press Enter or Shift-Enter to set the fill colour and close the dialog box. (See Figure 11.114.)

22. Now for the windows: press Ctrl-R or use the menu mnemonic Alt-O R to select the rectangle tool.
11.9 A HOUSE WITH NO MOUSE

Figure 11.113: No Mouse Example — Completed Triangle

Figure 11.114: No Mouse Example — Triangle Fill Colour Set to Red
23. Create four rectangles using the method described above with opposing vertices at:

- Window 1: (120bp, 180bp), (145bp, 155bp)
- Window 2: (120bp, 135bp), (145bp, 110bp)
- Window 3: (205bp, 135bp), (230bp, 110bp)
- Window 4: (205bp, 180bp), (230bp, 155bp)

See Figure 11.115.

Figure 11.115: No Mouse Example — Windows Added

24. To change the fill colour of the window rectangles, you will first need to switch to the select tool using either Ctrl-P or Alt-O S.

25. It’s more efficient to select all four of the window rectangles and change their fill colour simultaneously, rather than setting the fill colour individually. Since the four small rectangles are at the front of the stack, pressing Shift-F6 four times will select these four rectangles.

26. Now use the menu mnemonic Alt-E L to set the fill colour to white, following the same process as before to produce the image shown in Figure 11.116.

27. Now make a black rectangle with opposing corners at (160bp, 200bp) and (190bp, 160bp) using the same method as above, to produce the image shown in Figure 11.117.

28. To illustrate how to move objects using the keyboard, let’s now shift the house 100bp to the right and 50bp down. First make sure you are using the select tool. Then select all the objects using either Ctrl-A or Alt-E A.

29. Then either press F7 or use the menu mnemonic Alt-E M. This will open up the dialog box shown in Figure 11.118. Set the x field to 100bp and the y field to 50bp.
11.9  A HOUSE WITH NO MOUSE

Figure 11.116: No Mouse Example — Window Fill Colour Set

Figure 11.117: No Mouse Example — Completed House

Figure 11.118: No Mouse Example — Move Dialog Box
30. To illustrate how to edit a path using only the keyboard, let’s make the roof a bit shallower. First deselect all the objects using Ctrl+Shift-A or Alt-E D.

31. Press F6 repeatedly until the triangle is selected.

32. To enter edit mode, use either Ctrl-I or Alt-E H E. You should now see the path in edit mode. (See Figure 11.119.)

33. Press F6 until the highest vertex is selected.

34. Press F3 to popup the edit path menu (Figure 11.120).

35. Press Alt-R to display the dialog box shown in Figure 11.121.

36. Set the y field to 120bp, and press Enter.

37. Press Ctrl-I to exit edit path mode. The image should now look like Figure 11.122.

38. To illustrate how to create a text area using the keyboard, let’s add a label. First select the text tool using either Ctrl-T or Alt-O T.

39. Press F5 or Alt-N G to display the Go To dialog box. Set the x field to 200bp and the y field to 100bp.

40. Press F4 to start the text area. You should now see a small pale rectangle with a cursor, as illustrated in Figure 11.123. Whilst this rectangle contains a cursor, you can type in text or press F3 to display the text area popup menu.

41. Type in the text House #1, then switch to the select tool (using Ctrl-P or Alt-O S.)

42. The text area contains one of \TeX’s special characters, namely the hash (#) character. This will cause a problem if you want to save your image as a pgfpicture environment if the auto escape special characters facility is not enabled. If so,
11.9 A HOUSE WITH NO MOUSE

Figure 11.120: No Mouse Example — Edit Path Menu

Figure 11.121: No Mouse Example — Control Point Co-Ordinates Dialog Box

Figure 11.122: No Mouse Example — Editing Finished
11.9  A HOUSE WITH NO MOUSE

you will need to modify the text area so that it has an alternative text to be used if the image is saved in a \LaTeX file. You can do this as follows:

(a) Press F6 to select the text area.

(b) Press Ctrl+Shift-I or Alt-E X E to display the Edit Text dialog box. Select the Different button (either Tab to it and press Space or use Alt-D.) This will enable the alternate text field. Change the text to House \#1 (Figure 11.124).

(c) Press Enter or Shift-Enter to update the text area, and close the dialog box.

43. It would look better if the label was centred over the house. In order to use the align function, it is necessary to group all the objects that make up the house. This is done as follows:

44. Assuming you created all the objects in the same order as listing in this example, the text area should be at the front of the stack, then the door, the four windows, the roof and lastly the body of the house. You should still have the text area
11.9  A HOUSE WITH NO MOUSE

selected, and nothing else. If not, deselect all objects (Ctrl+Shift-A) and press F6 to select the text area.

45. Press F6 to deselect the text area and select the next object in the stack (the door).

46. Press Shift-F6 to add the next object to the selection. Keep pressing Shift-F6 until everything has been selected except the text area.

47. Press Ctrl-G or Alt-T G to group the selected objects.

48. Press Shift-F6 to add the text area to the selection.

49. Press Ctrl-G or Alt-T G to group the selected objects.

50. Use the menu mnemonic Alt-T J C to centre the objects.

51. Press Ctrl-U or Alt-T U to ungroup the objects. The image should now look like Figure 11.125. Note that the house had to be grouped and that group then grouped with the text area to ensure that the individual house components maintained their position relative to each other.

52. If you want to save your image as a \texttt{pgfpicture} environment, you will need to change the anchor settings to ensure that the text area in the \LaTeX file remains centred. (Otherwise font differences may cause the text to appear slightly off centre.) To do this:

   (a) Ensure that the text area is selected.

   (b) Use the menu mnemonic Alt-E X F A H to display the Horizontal Anchor Setting dialog box.

   (c) If the drop-down list doesn’t already have the focus, press Alt-A.

   (d) Press c or use the arrow keys to set the horizontal setting to Centre.
A Lute Rose

This example illustrates how to use symmetric shapes and patterns. The aim is to design the lute rose (the decorative cover of a lute’s sound hole) shown in Figure 11.139. This example uses a radial grid. All co-ordinates \((r : \theta)\) are radial co-ordinates where \(r\) is the radius (bp) and \(\theta\) is the angle (degrees).

1. Set the paper size to A3 landscape using the Settings → Paper menu.

2. Use Settings → Grid → Grid Settings to select a radial grid with 100bp major division interval, 10 sub-divisions and 32 spokes. (See Figure 11.126.)

3. Create a path (using the open curve tool and the edit path tool) starting at \((20 : -170)\) containing three Bézier segments with control points:
   
   (a) \((145 : -145), (215 : -145), (200 : -170)\)
   
   (b) \((200 : 135), (200 : -115), (200 : 170)\)
   
   (c) \((210 : 150), (255 : 115), (200 : 100)\)
   
   (See Figure 11.127)

   Although the co-ordinates are being specified as radial co-ordinates, they are always stored as rectangular co-ordinates. This conversion may cause slight rounding errors.

4. In edit path mode, use the popup menu and select Path Symmetry → Has Symmetry (see Figure 11.128).
Figure 11.127: The Underlying Path
5. Using the edit path popup menu again, deselect Path Symmetry → Anchor Join (see Figure 11.129).

6. Still in edit path mode, move the control points governing the line of symmetry (coloured blue by default) to (85 : −90) and (215 : 90) (see Figure 11.130).

7. Select the last control point on the path (not including the line of symmetry) and select the edit path popup menu item Convert To Curve. This should add a curve segment that joins the underlying path with its reflection (see Figure 11.131). Note that this joining segment only has one curvature control to enforce symmetry.
8. Move the curvature control point on the join segment to (200 : 0) (see Figure 11.132).

![Figure 11.132: Adjust the Curvature Control of the Join Segment](image)

9. Leave edit path mode and, ensuring the path is still selected, use the Edit → Path → Line Styles → All Styles menu item to change the path style to: 10bp pen width, round cap and round join (see Figure 11.133).

10. The path should now look like that shown in Figure 11.134.

11. Ensure that the path is selected. Use the Transform → Pattern → Set Pattern menu item. This should open the dialog box shown in Figure 11.135. Set the number of replicas to 11. Select the Rotational tab, and set the angle of rotation to 30 degrees.

12. The shape should now look like that shown in Figure 11.136.
Figure 11.133: Change the Path Style
Figure 11.134: The Symmetric Path

Figure 11.135: Setting the Pattern
13. Switch to edit path mode. You should now see an extra control point (coloured green by default). Move this control to \((0 : 0)\) (see Figure 11.137).

![Figure 11.136: The Pattern](image1)

![Figure 11.137: Move the Control Governing the Rotational Anchor](image2)

14. Leave path edit mode, select the ellipse tool and draw a circle around the pattern (see Figure 11.138).

15. Select the circle, set its fill colour to black and move the circle to the back of the stack. Select the pattern, and set its line colour to white. The image should now look as Figure 11.139.

![Figure 11.138: Add a Circle Around the Pattern](image3)

![Figure 11.139: The Completed Lute Rose](image4)
A  JDR/AJR File Formats

FlowframTk has two native file formats that it can both read and write. The JDR (.jdr) format is binary written in the big-endian fashion. The AJR (.ajr) format is an ASCII format. The AJR format has less precision than the JDR format. The current version number for both formats is 1.9.

The first line of the ASCII AJR format must be:

AJR {version}

where {version} is the version number. For example:

AJR 1.8

The version number must be followed by white space (such as a newline or space character).

The binary JDR format starts with a sequence of the three 16-bit Unicode characters “JDR” followed by the version string (not a decimal number) which is saved as an integer (the string length) followed by each character of the version string. In Java this is implemented using:

```
dout.writeChars("JDR");
dout.writeInt(version.length());
dout.writeChars(version);
```

where dout is a java.io.DataOutputStream object and version is a java.lang.String.

The remainder of both the JDR and AJR formats have the same syntax but the data types are stored differently.

integer

The binary version writes 32-bit signed two’s complement integers using the writeInt(int) method of the java.io.DataOutputStream class. The ASCII version writes the integer to the file followed by white space.

byte

The binary version writes 8-bit signed two’s complement bytes using the writeByte(byte) method of the java.io.DataOutputStream class. The ASCII version is the same as for the integer type, but the range of values is more limited.

long

The binary version writes 64-bit two’s complement integers using the writeLong(long) method of the java.io.DataOutputStream class. The ASCII version is the same as for the integer type.

float

The binary version writes single-precision 32-bit floating point values using the writeFloat(float) method of the java.io.DataOutputStream class. The ASCII version writes the number (possibly truncated) to the file followed by white space.

double

The binary version writes double-precision 64-bit floating point values using the writeDouble(double) method of the java.io.DataOutputStream class. The ASCII version is the same as for the float type.
APPENDIX A. JDR/AJR FILE FORMATS

boolean
The binary version writes boolean values using the `writeBoolean(boolean)` method of the `java.io.DataOutputStream` class. The ASCII version writes the number 0 (false) or 1 (true) to the file followed by white space.

char
The binary version writes a single 16-bit Unicode character using the `writeChar(int)` method of the `java.io.DataOutputStream` class. The ASCII version writes the character followed by white space.

string
A string consisting of \( n \) 16-bit Unicode characters is written as an integer followed by the \( n \) characters of type char. For the binary format, this is equivalent to:

```java
dout.writeInt(text.length());
dout.writeChars(text);
```

where `dout` is a `java.io.DataOutputStream` object and `text` is a `java.lang.String`. For the ASCII format, the length is written as an integer followed by a single white space character. (Avoid using `println` for just \( n \) as the end-of-line character for some operating systems consists of two characters.) Then the string is written followed by white space. For example:

```java
out.print(String.format("%d %s ", text.length(), text));
```

or

```java
out.println(String.format("%d %s", text.length(), text));
```

(where `out` is a `java.io.PrintWriter` object.) As in the above example, a newline character can be used after the string, just not after the number. A null or empty string is just written as the number 0. For example, for the binary version:

```java
dout.writeInt(0);
```

or for the ASCII version:

```java
out.print("0 ");
```
**transform-matrix**

A transformation matrix is saved as six `double` values representing the scale-x factor, the shear-y factor, the shear-x factor, the scale-y factor, the x-translation and the y-translation. For versions below 1.8, the translations are in terms of the `bp` PostScript unit; otherwise, they are in terms of the storage unit.

**float-array**

An array of `float` values is stored as an `integer ⟨n⟩` indicating the length of the array (may be 0 for a null or empty array) followed by the `⟨n⟩ float` array elements.

**double-array**

An array of `double` values is stored as an `integer ⟨n⟩` indicating the length of the array (may be 0 for a null or empty array) followed by the `⟨n⟩ double` array elements.

**unit-id**

A unit identifier is stored as a `byte`. This may take one of eight values: 0 (pt), 1 (inch), 2 (cm), 3 (bp), 4 (mm), 5 (pc), 6 (dd) or 7 (cc).

**length**

Lengths that are independent of the storage unit are stored as a `double` followed by the `unit-id`.

**angle**

An angle is stored as a `double` followed by a `byte` indicating the unit where 0 represents radians and 1 represents degrees.

**paint**

Colour data is stored as a `char` indicating the colour type (`⟨col-id⟩`). Available types are listed in Table A.1.

If `⟨col-id⟩` is T (transparent) this ends the paint information. Otherwise `⟨col-id⟩` is followed by the colour specifications (`⟨colour-specs⟩`).

<table>
<thead>
<tr>
<th>Type</th>
<th>ID</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transparent</td>
<td>T</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>RGB</td>
<td>R</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>CMYK</td>
<td>C</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>Linear Gradient</td>
<td>G</td>
<td>1.0 onwards</td>
</tr>
<tr>
<td>Radial Gradient</td>
<td>D</td>
<td>1.3 onwards</td>
</tr>
<tr>
<td>Grey</td>
<td>Y</td>
<td>1.4 onwards</td>
</tr>
<tr>
<td>HSB</td>
<td>S</td>
<td>1.4 onwards</td>
</tr>
</tbody>
</table>

**rgb**

RGB colour specs are saved as four `float` values in the range 0 to 1 (inclusive) representing the red, green, blue and alpha components.

**cymk**

CYMK colour specs are saved as five `float` values in the range 0 to 1 (inclusive) representing the cyan, magenta, yellow, black and alpha components.
APPENDIX A. JDR/AJR FILE FORMATS

hsb

HSB colour specs are saved as four float values representing the hue, saturation, brightness and alpha components. The hue value must lie in the range 0 (inclusive) to 360 (exclusive). The other values must lie in the range 0 to 1 (inclusive).

grey

Grey specs are saved as two float values in the range 0 to 1 (inclusive) representing the grey and alpha components.

linear-paint

Linear gradient paint specs are saved as the start paint, the end paint followed by an integer indicating the direction, which may be one of: 0 (North), 1 (North-East), 2 (East), 3 (South-East), 4 (South), 5 (South-West), 6 (West) or 7 (North-West). FlowframTk doesn’t support another gradient type as the start or end paint.

radial-paint

Radial gradient paint specs are saved as the start paint, the end paint followed by an integer indicating the starting location, which may be one of: 0 (North), 1 (North-East), 2 (East), 3 (South-East), 4 (South), 5 (South-West), 6 (West), 7 (North-West) or 8 (Centre). FlowframTk doesn’t support another gradient type as the start or end paint.

Spaces in any syntax specifications below are for clarity and ease of line breaking only and don’t form part of the specification (although white space may be acceptable at that point in the ASCII AJR format, according to the above data types).

1. JDR1.8 onwards

⟨storage-id⟩

JDR1.8 onwards

Regardless of whether or not the settings are saved in the file, as from JDR/AJR version 1.8 the storage unit ⟨storage-id⟩ is always present immediately after the version number and is used for all lengths described below (including coordinates) unless otherwise indicated. The unit is saved as a unit-id type, as described above.

Versions below 1.8 must have all lengths stored as PostScript points.

2. ⟨settings-id⟩

Next is a value ⟨settings-id⟩ indicating whether or not the FlowframTk settings are stored. In version 1.3 onwards, this value is a byte, and may take one of three values: 0 (no settings), 1 (all settings) or 2 (paper size only). In versions prior to 1.3, this value is a boolean value, where true indicates all settings and false indicates no settings.
3. The settings information is stored as follows when the \( \text{settings-id} \) is 1:

\[
\begin{align*}
\text{JDR1.0–1.7} \\
\langle \text{show-grid} \rangle \langle \text{lock-grid} \rangle \langle \text{show-rulers} \rangle \langle \text{tool-id} \rangle \langle \text{normalsize} \rangle \langle \text{paper} \rangle \langle \text{grid} \rangle
\end{align*}
\]

\[
\text{JDR1.8 onwards} \\
\langle \text{show-grid} \rangle \langle \text{lock-grid} \rangle \langle \text{show-rulers} \rangle \langle \text{tool-id} \rangle \langle \text{paper} \rangle \langle \text{grid} \rangle \langle \text{point size} \rangle \langle \text{scale flag} \rangle
\]

If \( \langle \text{settings-id} \rangle \) is 2, just \( \langle \text{paper} \rangle \) is present.

3.1. \( \langle \text{show-grid} \rangle \) is a \textbf{boolean} variable indicating whether or not to display the grid.

3.2. \( \langle \text{lock-grid} \rangle \) is a \textbf{boolean} variable indicating whether or not to lock the grid.

3.3. \( \langle \text{show-rulers} \rangle \) is a \textbf{boolean} variable indicating whether or not to show the rulers.

3.4. \( \langle \text{tool-id} \rangle \) is an \textbf{integer} indicating which tool to select. For versions below 1.8, this must be an \textbf{integer} in the range 0 and 7 (inclusive). As from version 1.8, this must be in the range 0 and 8 (inclusive). Table A.2 indicates the ID for each tool.

Table A.2: Tool Identifiers

<table>
<thead>
<tr>
<th>ID</th>
<th>Tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Select</td>
</tr>
<tr>
<td>1</td>
<td>Open Line Path</td>
</tr>
<tr>
<td>2</td>
<td>Closed Line Path</td>
</tr>
<tr>
<td>3</td>
<td>Open Curve Path</td>
</tr>
<tr>
<td>4</td>
<td>Closed Curve Path</td>
</tr>
<tr>
<td>5</td>
<td>Rectangle</td>
</tr>
<tr>
<td>6</td>
<td>Ellipse</td>
</tr>
<tr>
<td>7</td>
<td>Text</td>
</tr>
<tr>
<td>7</td>
<td>Maths (as from version 1.8)</td>
</tr>
</tbody>
</table>

3.5. For versions below 1.8, \( \langle \text{normalsize} \rangle \) is an \textbf{integer} indicating the \LaTeX{} normal font size. As from version 1.8, this value is stored later (see below) and isn’t governed by the settings flag.

\[
\text{JDR1.0–1.7} \\
\langle \text{paper} \rangle
\]

3.6. The \( \langle \text{paper} \rangle \) specs are:

\[
\begin{align*}
\text{JDR1.0–1.2} \\
\langle \text{paper-id} \rangle \langle \text{width} \rangle \langle \text{height} \rangle \langle \text{portrait-flag} \rangle
\end{align*}
\]
The paper size \( \langle \text{paper-id} \rangle \) is specified as a byte. For versions below 1.3, this must be a number in the range 0 to 18 (inclusive), otherwise it must be in the range 0 to 72 (inclusive). Table A.3 indicates the ID for each paper size, and Table A.4 shows additional values for version 1.3 onwards. If the paper size has an ID of 18 (user defined), then there must follow the paper \( \langle \text{width} \rangle \) (a \text{double} in \text{bp}) and \( \langle \text{height} \rangle \) (a \text{double} in \text{bp}). For versions prior to 1.3, the user defined setting must also be followed by \( \langle \text{portrait-flag} \rangle \) a \text{boolean} variable to indicate whether or not the orientation is portrait (true) or landscape (false). The paper dimensions are always stored in PostScript points (bp) and the unit id isn’t saved. (This is still true for version 1.8.)

### Table A.3: Paper Size Identifiers

<table>
<thead>
<tr>
<th>ID</th>
<th>Paper Size</th>
<th>ID</th>
<th>Paper Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>A0 (portrait)</td>
<td>9</td>
<td>A0 (landscape)</td>
</tr>
<tr>
<td>1</td>
<td>A1 (portrait)</td>
<td>10</td>
<td>A1 (landscape)</td>
</tr>
<tr>
<td>2</td>
<td>A2 (portrait)</td>
<td>11</td>
<td>A2 (landscape)</td>
</tr>
<tr>
<td>3</td>
<td>A3 (portrait)</td>
<td>12</td>
<td>A3 (landscape)</td>
</tr>
<tr>
<td>4</td>
<td>A4 (portrait)</td>
<td>13</td>
<td>A4 (landscape)</td>
</tr>
<tr>
<td>5</td>
<td>A5 (portrait)</td>
<td>14</td>
<td>A5 (landscape)</td>
</tr>
<tr>
<td>6</td>
<td>letter (portrait)</td>
<td>15</td>
<td>letter (landscape)</td>
</tr>
<tr>
<td>7</td>
<td>legal (portrait)</td>
<td>16</td>
<td>legal (landscape)</td>
</tr>
<tr>
<td>8</td>
<td>executive (portrait)</td>
<td>17</td>
<td>executive (landscape)</td>
</tr>
<tr>
<td>18</td>
<td>user defined</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3.7. The \( \langle \text{grid style} \rangle \) has the syntax:

\[
\langle \text{unit} \rangle \langle \text{major} \rangle \langle \text{minor} \rangle
\]

where:

3.7.1. \( \langle \text{unit} \rangle \) is the \text{unit-id} used for the rulers and grid. (Restricted to: 0 (\text{T\H\TeX\ pt}), 1 (inches), 2 (centimetres) or 3 (PostScript points).)

3.7.2. \( \langle \text{major} \rangle \) and \( \langle \text{minor} \rangle \) are \text{integers} representing the major grid divisions and the subdivisions, respectively.

\[
\langle \text{grid-id} \rangle \langle \text{grid-specs} \rangle
\]

The \( \langle \text{grid-id} \rangle \) is a byte representing the grid style ID. This may be:
Table A.4: Additional Paper Size Identifiers (JDR v1.3 onwards)

<table>
<thead>
<tr>
<th>ID</th>
<th>Paper Size</th>
<th>ID</th>
<th>Paper Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>19</td>
<td>A6 (portrait)</td>
<td>46</td>
<td>A6 (landscape)</td>
</tr>
<tr>
<td>20</td>
<td>A7 (portrait)</td>
<td>47</td>
<td>A7 (landscape)</td>
</tr>
<tr>
<td>21</td>
<td>A8 (portrait)</td>
<td>48</td>
<td>A8 (landscape)</td>
</tr>
<tr>
<td>22</td>
<td>A9 (portrait)</td>
<td>49</td>
<td>A9 (landscape)</td>
</tr>
<tr>
<td>23</td>
<td>A10 (portrait)</td>
<td>50</td>
<td>A10 (landscape)</td>
</tr>
<tr>
<td>24</td>
<td>B0 (portrait)</td>
<td>51</td>
<td>B0 (landscape)</td>
</tr>
<tr>
<td>25</td>
<td>B1 (portrait)</td>
<td>52</td>
<td>B1 (landscape)</td>
</tr>
<tr>
<td>26</td>
<td>B2 (portrait)</td>
<td>53</td>
<td>B2 (landscape)</td>
</tr>
<tr>
<td>27</td>
<td>B3 (portrait)</td>
<td>54</td>
<td>B3 (landscape)</td>
</tr>
<tr>
<td>28</td>
<td>B4 (portrait)</td>
<td>55</td>
<td>B4 (landscape)</td>
</tr>
<tr>
<td>29</td>
<td>B5 (portrait)</td>
<td>56</td>
<td>B5 (landscape)</td>
</tr>
<tr>
<td>30</td>
<td>B6 (portrait)</td>
<td>57</td>
<td>B6 (landscape)</td>
</tr>
<tr>
<td>31</td>
<td>B7 (portrait)</td>
<td>58</td>
<td>B7 (landscape)</td>
</tr>
<tr>
<td>32</td>
<td>B8 (portrait)</td>
<td>59</td>
<td>B8 (landscape)</td>
</tr>
<tr>
<td>33</td>
<td>B9 (portrait)</td>
<td>60</td>
<td>B9 (landscape)</td>
</tr>
<tr>
<td>34</td>
<td>B10 (portrait)</td>
<td>61</td>
<td>B10 (landscape)</td>
</tr>
<tr>
<td>35</td>
<td>C0 (portrait)</td>
<td>62</td>
<td>C0 (landscape)</td>
</tr>
<tr>
<td>36</td>
<td>C1 (portrait)</td>
<td>63</td>
<td>C1 (landscape)</td>
</tr>
<tr>
<td>37</td>
<td>C2 (portrait)</td>
<td>64</td>
<td>C2 (landscape)</td>
</tr>
<tr>
<td>38</td>
<td>C3 (portrait)</td>
<td>65</td>
<td>C3 (landscape)</td>
</tr>
<tr>
<td>39</td>
<td>C4 (portrait)</td>
<td>66</td>
<td>C4 (landscape)</td>
</tr>
<tr>
<td>40</td>
<td>C5 (portrait)</td>
<td>67</td>
<td>C5 (landscape)</td>
</tr>
<tr>
<td>41</td>
<td>C6 (portrait)</td>
<td>68</td>
<td>C6 (landscape)</td>
</tr>
<tr>
<td>42</td>
<td>C7 (portrait)</td>
<td>69</td>
<td>C7 (landscape)</td>
</tr>
<tr>
<td>43</td>
<td>C8 (portrait)</td>
<td>70</td>
<td>C8 (landscape)</td>
</tr>
<tr>
<td>44</td>
<td>C9 (portrait)</td>
<td>71</td>
<td>C9 (landscape)</td>
</tr>
<tr>
<td>45</td>
<td>C10 (portrait)</td>
<td>72</td>
<td>C10 (landscape)</td>
</tr>
</tbody>
</table>
A rectangular grid. The \textlangle grid-specs \rangle are:

\textlangle unit \rangle \textlangle major \rangle \textlangle minor \rangle

where
3.7.1. \textlangle unit \rangle is the \textit{unit-id} representing the grid unit.
3.7.2. \textlangle major \rangle is a \texttt{double} representing the major grid division (in terms of the grid unit).
3.7.3. \textlangle minor \rangle is an \texttt{integer} representing the grid subdivision.

A radial grid. The \textlangle grid-specs \rangle are:

\textlangle unit \rangle \textlangle major \rangle \textlangle minor \rangle \textlangle spokes \rangle

where:
3.7.1. \textlangle unit \rangle is the \textit{unit-id}.
3.7.2. \textlangle major \rangle is a \texttt{double} representing the major grid division.
3.7.3. \textlangle minor \rangle is an \texttt{integer} representing the grid subdivision.
3.7.4. \textlangle spokes \rangle is an \texttt{integer} representing the number of spokes.

An isometric grid (Version 1.8 onwards.) The \textlangle grid-specs \rangle are:

\textlangle unit \rangle \textlangle major \rangle \textlangle minor \rangle

where
3.7.1. \textlangle unit \rangle is the \textit{unit-id} representing the grid unit.
3.7.2. \textlangle major \rangle is a \texttt{double} representing the major grid division (in terms of the grid unit). This is the length of each side of the equilateral triangles that form the grid.
3.7.3. \textlangle minor \rangle is an \texttt{integer} representing the grid subdivision.

A Tschichold grid (Version 1.8 onwards.) The \textlangle grid-specs \rangle are the same as for the rectangular grid.

| JDR1.6 onwards |

As from JDR version 1.8, the \textlangle point size \rangle is also saved as a \texttt{length}, followed by a \texttt{boolean} value \textlangle scale flag \rangle indicating whether the control point scaling is enabled.

| JDR1.8 onwards |

| JDR1.9 onwards |

\textlangle normsize \rangle \textlangle preamble \rangle \textlangle mid-preamble \rangle \textlangle end-preamble \rangle \textlangle class name \rangle \textlangle absolute pages flag \rangle
APPENDIX A. JDR/AJR FILE FORMATS

JDR1.8

\langle \text{normalsize} \rangle \langle \text{preamble} \rangle \langle \text{class name} \rangle \langle \text{absolute pages flag} \rangle

For version 1.8 onwards, the LaTeX normal size value is always saved at this point, regardless of the \langle \text{settings-id} \rangle. In addition, from version 1.8, preamble text, document class and absolute pages setting are now saved. Version 1.8 only stores the early-preamble text. As from version 1.9, the mid-preamble and end-preamble text is also stored.

4.1. The normal size value \langle \text{normalsize} \rangle is stored as an integer.

4.2. The preamble text \langle \text{preamble} \rangle is stored as a string and may be empty or null. Similarly for the \langle \text{mid-preamble} \rangle and \langle \text{end-preamble} \rangle for version 1.9 onwards.

4.3. If the default document class setting is enabled, \langle \text{class name} \rangle is saved as an empty or null string otherwise the user specified \langle \text{class name} \rangle is saved.

4.4. The \langle \text{absolute pages flag} \rangle is saved as a boolean value, where true indicates flowfram’s \text{pages=absolute} option and false indicates flowfram’s \text{pages=relative} option.

JDR1.8

5. The objects that constitute the image are now stored. When saving to a file, an outer grouping is implied that is not evident whilst using FlowframTk. This means that there should always be a single group structure saved to file which contains all the objects that constitute the picture. Each object is then recursively stored. For example, if an image contains a path, a group and a text area, in the JDR/AJR file these three objects will be stored as a single group structure containing the three objects. If in FlowframTk you explicitly group all the objects, then in the JDR file, the outermost implicit group will contain only one object which will be this group. It’s an error for the top-level object to be anything other than a group.

Each object has the following format:

JDR1.0 & 1.1

\langle \text{id-char} \rangle \langle \text{object-specs} \rangle \langle \text{fflag} \rangle \langle \text{fflag} \rangle \langle \text{description} \rangle

JDR1.0 & 1.1

where \langle \text{id-char} \rangle is a char determining the object type:

JDR1.0–1.4

• G — group;
APPENDIX A. JDR/AJR FILE FORMATS

• P — path;
• T — text area;
• I — bitmap.

JDR1.0–1.4

As versions 1.0–1.4. Additionally:
• X — text-path

JDR1.5

As version 1.5. Additionally:
• S — symmetric shape;
• R — rotational pattern;
• C — scaled pattern;
• L — spiral pattern.

JDR1.6 onwards

The object specifications \langle object-specs \rangle vary according to the object type and are described below. \langle fflag \rangle is a boolean value indicating whether or not this object has flowframe data associated with it. If true, then the flowframe specifications \langle flowframe-specs \rangle should follow (see below), otherwise \langle flowframe-specs \rangle should be omitted. Note that JDR version 1.2 and above contains the string \langle description \rangle, which was omitted in earlier versions.

Recall from above that the image is stored with an implied outer grouping. The \langle flowframe-specs \rangle for this implicit group represents the image typeblock and the \langle description \rangle represents the image description.

The \langle object-specs \rangle are as follows:

1. Group data, \langle G \rangle, is stored as:

\langle n \rangle \langle object data \rangle +

where \langle n \rangle is an integer indicating the number of objects within the group. There should then follow \langle n \rangle lots of \langle object data \rangle, where \langle object data \rangle is the data for each object within the group, and is as described above.

2. Path data, \langle P \rangle, is stored as follows:

\langle line paint \rangle \langle fill paint \rangle \langle line style \rangle \circ \langle C \rangle \langle n \rangle \langle segment data \rangle +
APPENDIX A. JDR/AJR FILE FORMATS

JDR1.3–1.5
⟨line paint⟩ ⟨fill paint⟩ ⟨line style⟩ ⟨path specs⟩

JDR1.6
⟨path style⟩ ⟨path specs⟩

JDR1.7 onwards
⟨path style⟩ ⟨path specs⟩ ⟨anchor info⟩

where ⟨line paint⟩ and ⟨fill paint⟩ are paint specifications and ⟨line style⟩ is the line style data (see below).

The ⟨path specs⟩ are

O|C ⟨n⟩ ⟨segment data⟩+

where the char value O or C indicates whether the path is open (O) or closed (C). ⟨n⟩ is an integer indicating the number of segments that constitute the path. This should be followed by ⟨n⟩ lots of ⟨segment data⟩ (described below).

Version 1.3 removed the redundancy present in earlier versions but requires that the starting point ⟨start point⟩ follows the number of segments (⟨n⟩). The starting point is stored as two double numbers. For versions below 1.8, these values are always in terms of the PostScript point bp. As from version 1.8, they are in terms of the storage unit, as described above.

Version 1.7 added anchor information ⟨⟨anchor info⟩⟩. This comes after the above path specifications. Control points are indexed from 0 and include curvature control points. For example, a path that consists of a line segment followed by a Bézier segment has 5 control points: index 0 is the point at the start of the path (the start of the line segment), index 1 is the point at the join between the line segment and Bézier segment, indices 2 and 3 are the two curvature control points and index 4 is the end point. The anchor information is the list of integer indices for which the anchor is on. This list must be in ascending order of index and is terminated by −1. Only control points occurring between a continuous join may be anchored.

For example, in the ASCII AJR version

3 6 9 −1

indicates that control points 3, 6 and 9 have the anchor setting on. If no controls are anchored, the −1 is still required.

2.1. Version 1.6 onwards stores the ⟨path style⟩ specification as

⟨id⟩ ⟨specs⟩
where \( \langle id \rangle \) is a byte indicating the path style. This may be 0 (basic stroke) or 1 (text-path stroke).

2.1.1. The basic stroke \( \langle specs \rangle \) are:

\[
\langle line\ paint \rangle \langle fill\ paint \rangle \langle line\ style \rangle
\]

where \( \langle line\ style \rangle \) is described below.

2.1.2. The text-path stroke \( \langle specs \rangle \) are:

\[
\langle line\ paint \rangle \langle text-path\ style \rangle
\]

where \( \langle text-path\ style \rangle \) is described below.

A path should only have a text-path stroke if it is the base path for a composite shape.

2.2. The \( \langle line\ style \rangle \) data has changed from file version 1.0 to 1.1 to take into account the inclusion of mid point markers, and is stored as follows:

<table>
<thead>
<tr>
<th>JDR1.0</th>
<th>JDR1.1 and above</th>
</tr>
</thead>
<tbody>
<tr>
<td>\langle linewidth\rangle\langle dash\rangle\langle cap\rangle\langle join\rangle[\langle mitre-limit\rangle]\langle winding\rangle\langle start\ arrow\rangle\langle end\ arrow\rangle</td>
<td>\langle linewidth\rangle\langle dash\rangle\langle cap\rangle\langle join\rangle[\langle mitre-limit\rangle]\langle winding\rangle\langle start\ arrow\rangle\langle mid\ marker\rangle\langle end\ arrow\rangle</td>
</tr>
</tbody>
</table>

where:

2.2.1. \( \langle linewidth\rangle \) the line width stored as a float (below version 1.8) in PostScript points (bp). For version 1.8 onwards, the line width is stored as a length.

2.2.2. \( \langle dash\rangle \) is the dash pattern. This is stored as a float-array, optionally followed by the float offset. The array may be empty or null to indicate a solid line, otherwise it should have an even number of elements representing \( \langle dash\rangle \langle gap\rangle \) pairs. The offset is only saved for a non-empty, non-null array.

The unit of measurement (not saved in the dash pattern specs) is bp for versions below 1.8 and the storage unit for version 1.8 onwards.

2.2.3. \( \langle cap\rangle \) is the cap style, stored as a byte. It may only have one of the following values: 0 (butt), 1 (round) or 2 (square).

2.2.4. \( \langle join\rangle \) is the join style, stored as a byte. It may only have one of the following values: 0 (mitre), 1 (round) or 2 (bevel).

2.2.5. \( \langle mitre-limit\rangle \) is the mitre-limit and should only be stored if the join style is a mitre. For versions below 1.8, the mitre-limit is stored as a float, otherwise it’s stored as a length.

2.2.6. \( \langle winding\rangle \) is the winding rule, stored as a byte. It may only have one of the following values: 0 (Even-Odd) or 1 (Non Zero).
2.2.7. \textit{⟨start arrow⟩} and \textit{⟨end arrow⟩} are the starting and ending arrow styles. The \textit{⟨mid marker⟩} is the style for the mid-point markers. Each marker type (start/mid/end) has the same format, but the file format varies as follows:

\begin{verbatim}
JDR1.0
⟨id⟩[⟨size⟩⟨is double⟩⟨is reversed⟩]
\end{verbatim}

where \textit{⟨id⟩} is a \texttt{byte} identifying the arrow type. This may be one of: 0 (none), 1 (pointed), 2 (triangle), 3 (circle), 4 (diamond), 5 (square), 6 (bar) or 7 (single). \textit{⟨size⟩} is \texttt{float} representing the arrow size. (Some arrows only have a fixed size, but a size must still be present.) \textit{⟨is double⟩} is a \texttt{boolean} value indicating whether the arrow head is a double arrow (⟨\texttt{true}⟩) or a single arrow (⟨\texttt{false}⟩). \textit{⟨is reversed⟩} is a \texttt{boolean} value indicating whether the arrow head has been reversed. The values \textit{⟨size⟩⟨is double⟩⟨is reversed⟩} are omitted if \textit{⟨id⟩} equals 0 (no arrow head).

\begin{verbatim}
JDR1.1–1.3
⟨id⟩[⟨marker data⟩]
\end{verbatim}

where \textit{⟨id⟩} is a \texttt{byte} identifying the marker type. If \textit{⟨id⟩} is 0, then \textit{⟨marker data⟩} should be omitted, otherwise it should be present. Valid \textit{⟨id⟩} values are listed in \textit{Table A.5}.

The \textit{⟨marker data⟩} is stored as follows:

\begin{verbatim}
⟨size⟩⟨repeat⟩⟨is reversed⟩⟨orient data⟩⟨colour data⟩⟨overlay⟩⟨composite data⟩
\end{verbatim}

where:

- \textit{⟨size⟩} is a \texttt{float} representing the marker size (some markers will ignore this attribute, but it must still be present in the file.)
- \textit{⟨repeat⟩} is a \texttt{byte} identifying the repeat factor (a value of 1 indicates a single marker, a value of 2 indicates a double marker, a value of 3 indicates a triple marker.)
- \textit{⟨is reversed⟩} is a \texttt{boolean} value indicating whether or not the marker has been reversed.
- \textit{⟨orient data⟩} is the marker orientation data. This has the form \textit{⟨auto-orient⟩[⟨angle⟩]} where \textit{⟨auto-orient⟩} is a \texttt{boolean} value indicating whether the marker should be oriented along the path. If \textit{⟨auto-orient⟩} is true, \textit{⟨angle⟩} should be omitted, otherwise \textit{⟨angle⟩} should be a \texttt{float} representing the orientation angle (in Radians).
- \textit{⟨colour data⟩} is the marker \texttt{paint} where a transparent value indicates the colour should be derived from the path to which the marker is attached, and there is no provision for gradient paint markers.
- \textit{⟨overlay⟩} is a \texttt{boolean} value indicating whether to overlay com-
posite markers.

- \(\langle\text{composite data}\rangle\) is the data for composite markers. This has the same format as the \(\langle\text{marker data}\rangle\). If the \(\langle\text{composite data}\rangle\) has a marker id of 0, then the marker is not a composite marker. Although the format allows for nested composite markers, FlowframTk’s marker settings dialog boxes do not allow for it.

<table>
<thead>
<tr>
<th>Table A.5: Marker IDs</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 No marker 11 Box Filled</td>
</tr>
<tr>
<td>1 Pointed 12 Box Open</td>
</tr>
<tr>
<td>2 Triangle 13 Cross</td>
</tr>
<tr>
<td>3 Circle 14 Plus</td>
</tr>
<tr>
<td>4 Diamond 15 Star</td>
</tr>
<tr>
<td>5 Square bracket 16 Triangle Up Filled</td>
</tr>
<tr>
<td>6 Bar 17 Triangle Up Open</td>
</tr>
<tr>
<td>7 Single 18 Triangle Down Filled</td>
</tr>
<tr>
<td>8 Round bracket 19 Triangle Down Open</td>
</tr>
<tr>
<td>9 Dot Filled 20 Rhombus Filled</td>
</tr>
<tr>
<td>10 Dot Open 21 Rhombus Open</td>
</tr>
</tbody>
</table>

For version 1.4 onwards the markers are stored as

\[\langle id\rangle[\langle\text{marker data}\rangle]\]
Table A.7: Additional Marker IDs (JDR 1.6)

<table>
<thead>
<tr>
<th>ID</th>
<th>Marker Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>80</td>
<td>Ball Cap</td>
</tr>
<tr>
<td>81</td>
<td>Leaf Cap</td>
</tr>
<tr>
<td>82</td>
<td>Double Leaf Cap</td>
</tr>
<tr>
<td>83</td>
<td>Triple Leaf Cap</td>
</tr>
<tr>
<td>84</td>
<td>Club Cap</td>
</tr>
<tr>
<td>85</td>
<td>Forward Triple Leaf Cap</td>
</tr>
<tr>
<td>86</td>
<td>Back Triple Leaf Cap</td>
</tr>
<tr>
<td>87</td>
<td>Forward Double Leaf Cap</td>
</tr>
<tr>
<td>88</td>
<td>Back Double Leaf Cap</td>
</tr>
<tr>
<td>89</td>
<td>Cutout Bulge Cap</td>
</tr>
</tbody>
</table>

where \(\langle id \rangle\) is a byte identifying the marker type. If \(\langle id \rangle\) is 0, then \(\langle marker data \rangle\) should be omitted, otherwise it should be present. Valid \(\langle id \rangle\) values are listed in Table A.5 and Table A.6. Additional markers listed in Table A.7 are also available for version 1.6 onwards.

The \(\langle marker data \rangle\) is stored as follows:

\[
\langle size \rangle \langle repeat \rangle (is reversed) \langle orient data \rangle \langle colour data \rangle \langle overlay \rangle \{\langle user offset flag \rangle \{\langle user offset \rangle \} \langle repeat offset flag \rangle \{\langle repeat offset \rangle \}\} \langle composite data \rangle
\]

(spaces for syntax clarity) where: \(\langle user offset flag \rangle\) \(\{\langle user offset \rangle\}\) \(\langle repeat offset flag \rangle\) \(\{\langle repeat offset \rangle\}\) are only specified if the \(\langle overlay \rangle\) is false. Additionally, \(\langle user offset \rangle\) and \(\langle repeat offset \rangle\) are only specified if \(\langle user offset flag \rangle\) or \(\langle repeat offset flag \rangle\) are true, respectively.

- \(\langle size \rangle\) is a float (bp unit implied) for versions below 1.8 and is a length for version 1.8 onwards.
- \(\langle repeat \rangle\) is a byte identifying the repeat factor (a value of 1 indicates a single marker, a value of 2 indicates a double marker, a value of 3 indicates a triple marker.)
- \(\langle is reversed \rangle\) is a boolean value indicating whether or not the marker has been reversed.
- \(\langle orient data \rangle\) is the marker orientation data. This is as for versions 1.1–1.3 except that for version 1.8 onwards the orientation \(\langle angle \rangle\) (if required) is stored as an angle.
- \(\langle colour data \rangle\) is the marker paint as for versions 1.1–1.3.
- \(\langle overlay \rangle\) is a boolean value indicating whether to overlay composite markers.

If the \(\langle overlay \rangle\) is false:
- \(\langle user offset flag \rangle\) is a boolean value indicating whether the marker offset is specified by the user (true) or determined automatically (false).
- \(\langle user offset \rangle\) indicates the marker offset from the vertex. For versions below 1.8 this is stored as a float (bp unit implied) otherwise it’s stored as a length. This is only present if \(\langle user offset flag \rangle\) is true.
- \(\langle repeat offset flag \rangle\) is a boolean indicating whether the repeat offset (i.e. gap between repeat markers) is specified by the user (true) or determined automatically (false).
- \(\langle repeat offset \rangle\) indicates the gap between repeat markers. For versions below 1.8 this is stored as a float (bp unit implied)
otherwise it’s stored as a length. This is only present if ⟨repeat offset flag⟩ is true.

- ⟨composite data⟩ is the data for composite markers. This has the same format as the ⟨marker data⟩. If the ⟨composite data⟩ has a marker id of 0, then the marker is not a composite marker. Although the format allows for nested composite markers, FlowframTk’s marker settings dialog boxes do not allow for it.

2.3. Each path segment ⟨segment data⟩ is stored as:

⟨id⟩⟨specs⟩

where ⟨id⟩ is a char representing the segment type. This can be one of: B (cubic Bézier), L (line) or M (move). For versions below 1.8, the co-ordinates are always bp. As from version 1.8, the co-ordinate unit is as specified by the storage unit described above.

2.3.1. Bézier segments are stored as follows:

JDR1.0–1.2
⟨c0x⟩⟨c0y⟩ ⟨c1x⟩⟨c1y⟩ ⟨c2x⟩⟨c2y⟩ ⟨c3x⟩⟨c3y⟩

JDR1.3 onwards
⟨c1x⟩⟨c1y⟩ ⟨c2x⟩⟨c2y⟩ ⟨c3x⟩⟨c3y⟩

where ⟨c0x⟩ and ⟨c0y⟩ are the x and y co-ordinates of the starting point, ⟨c1x⟩ and ⟨c1y⟩ are the x and y co-ordinates of the first curvature control point, ⟨c2x⟩ and ⟨c2y⟩ are the x and y co-ordinates of the second curvature control point, and ⟨c3x⟩ and ⟨c3y⟩ are the x and y co-ordinates of the end point. Each value is stored as a double. The unit of measurement is bp for versions below 1.8, otherwise it’s the storage unit as described above.

2.3.2. Line and move to (gap) segments are stored as follows:

JDR1.0–1.2
⟨x0⟩⟨y0⟩ ⟨x1⟩⟨y1⟩

JDR1.3 onwards
⟨x1⟩ ⟨y1⟩

where ⟨x0⟩ and ⟨y0⟩ are the x and y co-ordinates of the starting point and ⟨x1⟩ and ⟨y1⟩ are the x and y co-ordinates of the end point. Each value is stored as a double. The unit of measurement is bp for versions below 1.8, otherwise it’s the storage unit as described above.

3. Text area (T) data is stored as follows:

⟨font-specs⟩ ⟨transform⟩ ⟨latex-flag⟩ [⟨latex-specs⟩] ⟨text paint⟩ ⟨text⟩
3.1. \langle outline-flag \rangle is a boolean value that indicates whether or not the text should be rendered as an outline. If true, \langle fill paint \rangle follows, which is the paint used to fill the interior. A transparent paint indicates the interior shouldn’t be filled.

3.2. \langle font-specs \rangle has the syntax:

\langle family \rangle \langle shape \rangle \langle weight \rangle \langle size \rangle

The \langle family \rangle must be a non-empty, non-null string indicating the name of the font (as used by FlowframTk, not when exported to a \LaTeX file, so it’s a system font rather than a \TeX font).

The \langle shape \rangle is a byte indicating the font shape (0 for upright, 1 for emphasized, 2 for italic, 3 for slanted and 4 for smallcaps). Version 1.6 and below only permitted 0 or 1 for the shape. Although the file format allows five different shape styles, java.awt.Font only supports plain or italic, so when rendering on the canvas, FlowframTk treats emphasized, italic and slanted as Font.ITALIC and the other styles as Font.PLAIN. The Italic option in the font style dialogs actually sets the shape to type 1 (emphasized) rather than type 2.

The \langle weight \rangle is a byte indicating the font weight (0 for medium, 1 for bold).

For versions below 1.8 the font size is a non-negative integer, otherwise it’s stored as a non-negative length.

3.3. \langle transform \rangle is a transform-matrix indicating the text transformation relative to the top left corner of the canvas.

3.4. The \langle latex-flag \rangle is a boolean value that indicates whether the \LaTeX-related attributes (\langle latex specs \rangle) are saved. If true, the syntax for \langle latex specs \rangle is

\langle latex font specs \rangle \langle h-align \rangle \langle v-align \rangle \langle latex text \rangle

The \langle latex font specs \rangle are the \LaTeX font declarations: \langle family \rangle, \langle weight \rangle, \langle shape \rangle and \langle size \rangle. Each attribute is stored as a string.
APPENDIX A. JDR/AJR FILE FORMATS

The \( h\)-align element represents the horizontal alignment and is stored as a byte that may be one of: 0 (left), 1 (centre) or 2 (right).

The \( v\)-align element represents the vertical alignment and is stored as a byte that may be one of: 0 (top), 1 (middle), 2 (baseline) or 3 (bottom).

The \LaTeX\ alternative text \( \langle \text{latex text} \rangle \) is a string. If empty or null, the \LaTeX\ alternative text should be considered equivalent to \( \langle \text{text} \rangle \).

4. Bitmap (I) information is stored as follows:

\[
\langle \text{filename} \rangle \langle \text{latex-flag} \rangle \{\langle \text{latex-bitmap-specs} \rangle\} \langle \text{transformation} \rangle
\]

where:

4.1. \( \langle \text{filename} \rangle \) is a non-empty, non-null string containing the file name. This may be a path relative to the JDR/AJR file for version 1.8 onwards.

4.2. If the boolean value \( \langle \text{latex-flag} \rangle \) is true, it must be followed by \( \langle \text{latex-bitmap-specs} \rangle \)

4.3. \( \langle \text{latex-bitmaps-specs} \rangle \) has the following format:

\[
\langle \text{filename} \rangle \langle \text{imgcmd} \rangle
\]

where \( \langle \text{filename} \rangle \) is a string containing the \LaTeX\ path name for the bitmap. A null or empty value indicates it should be determined from \( \langle \text{filename} \rangle \) (replacing the pathname separator with / if necessary). The image command is stored in the string \( \langle \text{imgcmd} \rangle \) and may be empty or null.

4.4. \( \langle \text{transformation} \rangle \) is a transform-matrix. The origin is the bottom left corner of the bitmap.

5. Composite Shapes

As from version 1.6, all composite shapes except symmetric shape (X, R, C and L) have \( \langle \text{object-specs} \rangle \) in the form:

\[\langle \text{modifier specs} \rangle \langle \text{underlying shape specs} \rangle\]

For symmetric shapes (S) the syntax is:

\[\langle \text{underlying shape specs} \rangle \langle \text{modifier specs} \rangle\]

The \( \langle \text{underlying shape specs} \rangle \) is the specification for the underlying shape in the form:

\[\langle \text{id-char} \rangle \langle \text{object-specs} \rangle\]

where \( \langle \text{id-char} \rangle \) is as above, but limited to the shape IDs, so the text (T), bitmap (B) and group (G) IDs aren’t permitted here.
The underlying shape may be another composite shape. Descendent underlying shapes refer to the composite shape’s underlying shape and any descendent of that underlying shape if it is also a composite shape. The base underlying shape is the maximal descendent underlying shape and must be a path (P), in which case ⟨id-char⟩ ⟨object-specs⟩ will be \( P \langle \text{path style} \rangle \langle \text{path specs} \rangle \langle \text{anchor info} \rangle \) (⟨anchor info⟩ is omitted below version 1.7).

Although the descendent underlying shapes may be another composite shape, they can’t share the same type as either their ancestor or descendent shapes. For example, a text-path may have a pattern as its underlying shape, but a pattern can’t have another pattern as its underlying shape.

The ⟨modifier specs⟩ are as follows:

5.1. Text-paths (X) are not available for versions below 1.5.

For this type of composite shape, the ⟨modifier specs⟩ are only present from version 1.8 and relate to the outline option ⟨outline-flag⟩ [⟨fill paint⟩], which is the same as for text-areas. So the ⟨object-specs⟩ are:

```
JDR1.8 onwards

⟨outline-flag⟩ [⟨fill paint⟩] ⟨underlying shape specs⟩
```

```
JDR1.6–1.7

⟨underlying shape specs⟩
```

For version 1.5 the ⟨object-specs⟩ are:

```
JDR1.5

⟨text paint⟩ ⟨line style⟩ ⟨path specs⟩
```

For version 1.5, the ⟨line style⟩ and ⟨path specs⟩ are as described earlier. The base path must have the text-path stroke (id 1) ⟨path style⟩.

5.1.1. The ⟨text-path style⟩ is stored as:

\[
\langle \text{font specs} \rangle \langle \text{transform} \rangle \langle \text{latex-flag} \rangle [\langle \text{latex specs} \rangle] \langle \text{text} \rangle
\]

where:

5.1.1.1. ⟨font specs⟩ are the same as for text areas.

5.1.1.2. ⟨transform⟩ is a transform-matrix indicating the text transformation relative to the underlying shape (see §8.9 Combining a Text Area and Path to Form a Text-Path).

5.1.1.3. The ⟨latex-flag⟩ is a boolean value that indicates whether the \LaTeX\-related attributes (⟨latex specs⟩) are saved. If true, the syntax for ⟨latex specs⟩ is
APPENDIX A. JDR/AJR FILE FORMATS

JDRbelow 1.8

\langle \text{latex font specs} \rangle \langle \text{h-align} \rangle \langle \text{v-align} \rangle \langle \text{latex text} \rangle

JDR1.8 onwards

\langle \text{latex font specs} \rangle \langle \text{left delimiter} \rangle \langle \text{latex text} \rangle \langle \right delimiter \rangle

This is the same as for \text{text areas} but additionally includes the delimiters used by the \texttt{pgf} package’s \text{text decoration} function for version 1.8 onwards. These are both stored as a \texttt{char}.

5.1.2. The \texttt{<text>} is stored as a \texttt{string} and shouldn’t be empty or null.

5.2. \textbf{Symmetric shapes (S)} are not available for versions below 1.6. For newer versions, the \texttt{<modifier specs>} are:

\langle \text{join anchored} \rangle \langle \text{join segment} \rangle \langle \text{symmetry x0} \rangle \langle \text{symmetry y0} \rangle \langle \text{symmetry x1} \rangle \langle \text{symmetry y1} \rangle \langle \text{closed} \rangle \langle \text{close anchored} \rangle \langle \text{closing segment} \rangle

where:

5.2.1. The \texttt{boolean} value \texttt{<join anchored>} indicates whether or not the join between the original shape and its reflection is anchored.

5.2.2. If the join isn’t anchored, \texttt{<join segment>} is the information about the joining segment. This is omitted if \texttt{<join anchored> is true}. The syntax for the join segment is:

\langle \text{segment-id} \rangle \langle \text{segment specs} \rangle

where the \texttt{<segment-id>} is a \texttt{char} indicating the segment type. This may be one of \texttt{m} (gap), \texttt{l} (line) or \texttt{c} (Bézier curve).

5.2.2.1. The \texttt{<segment specs>} for both the gap (\texttt{m}) and line (\texttt{l}) segments is omitted.

5.2.2.2. The \texttt{<segment specs>} for the Bézier curve is:

\langle \text{cx} \rangle \langle \text{cy} \rangle

where \texttt{<cx>} and \texttt{<cy>} are the x- and y-coordinates of the curvature control, respectively, and are each stored as a \texttt{double} (in terms of the PostScript point \texttt{bp} for versions below 1.8 and in terms of the storage unit otherwise).

5.2.3. The co-ordinates for the line of symmetry \texttt{<symmetry x0> \langle symmetry y0 \rangle <symmetry x1> \langle symmetry y1 \rangle} are each stored as a \texttt{double} and are in terms of the PostScript point \texttt{bp} for versions below 1.8 otherwise are in terms of the storage unit.

5.2.4. The \texttt{boolean} value \texttt{<closed>} indicates if the shape is closed.
5.2.5. If the shape is closed, the \textit{boolean} \textit{close anchor} indicates whether or not the starting control is anchored to the line of symmetry (true indicates the anchor setting is on). If the shape isn’t closed, this value is omitted.

5.2.6. If the \textit{close anchor} is false, the \textit{closing segment} is the information about the segment used to close the shape. This has the same syntax as for the \textit{join segment} described above. The \textit{closing segment} data is omitted if \textit{close anchor} is true.

5.3. Rotational patterns (R) are not available for versions below 1.6. For newer versions, the \textit{modifier specs} are:

\begin{verbatim}
\langle shape-specs \rangle \langle anchor-x \rangle \langle anchor-y \rangle \langle angle \rangle \langle replicas \rangle \langle mode \rangle \langle show \rangle
\end{verbatim}

where:

5.3.1. \textit{shape-specs} are the underlying object’s specifications as described above.

5.3.2. \textit{anchor-x} is a \textit{double} representing the \textit{x}-coordinate of the anchor point (in terms of the PostScript point \textit{bp} for versions below 1.8, otherwise in terms of the storage unit).

5.3.3. \textit{anchor-y} is a \textit{double} representing the \textit{y}-coordinate of the anchor point (in terms of the PostScript point \textit{bp} for versions below 1.8, otherwise in terms of the storage unit).

5.3.4. \textit{angle} is the angle of rotation and is stored as a \textit{double} (in radians) for versions below 1.8, otherwise is stored as an \textit{angle}.

5.3.5. \textit{replicas} is an \textit{integer} representing the number of replicas.

5.3.6. \textit{mode} is a \textit{boolean} variable, true if single-path mode.

5.3.7. \textit{show} is a \textit{boolean} variable, true if the underlying path is visible.

5.4. Scaled patterns (C) are not available for versions below 1.6. For newer versions, the specifications are:

\begin{verbatim}
\langle shape-specs \rangle \langle anchor-x \rangle \langle anchor-y \rangle \langle adjust-x \rangle \langle adjust-y \rangle \langle scale-x \rangle \langle scale-y \rangle \langle replicas \rangle \langle mode \rangle \langle show \rangle
\end{verbatim}

where \textit{shape-specs}, \textit{anchor-x}, \textit{anchor-y}, \textit{replicas}, \textit{mode} and \textit{show} are as for the rotational pattern described above. Additionally:

5.4.1. \textit{adjust-x} is a \textit{double} representing the \textit{x}-coordinate of the adjust control point (in terms of the PostScript point \textit{bp} for versions below 1.8, otherwise in terms of the storage unit).

5.4.2. \textit{adjust-y} is a \textit{double} representing the \textit{y}-coordinate of the adjust control point (in terms of the PostScript point \textit{bp} for versions below 1.8, otherwise in terms of the storage unit).

5.4.3. \textit{scale-x} is a \textit{double} representing the \textit{x}-scale factor.

5.4.4. \textit{scale-y} is a \textit{double} representing the \textit{y}-scale factor.

5.5. Spiral patterns (L) are not available for versions below 1.6. For newer versions, the specifications are:
APPENDIX A. JDR/AJR FILE FORMATS

\[\text{shape-specs} \langle \text{anchor-x} \rangle \langle \text{anchor-y} \rangle \langle \text{adjust-x} \rangle \langle \text{adjust-y} \rangle \langle \text{angle} \rangle \langle \text{distance} \rangle \langle \text{replicas} \rangle \langle \text{mode} \rangle \langle \text{show} \rangle\]

where \(\text{shape-specs}, \langle \text{anchor-x} \rangle, \langle \text{anchor-y} \rangle, \langle \text{adjust-x} \rangle, \langle \text{adjust-y} \rangle, \langle \text{replicas} \rangle, \langle \text{mode} \rangle\) and \langle \text{show} \rangle\) are as for scaled patterns, described above. Additionally:

5.5.1. \(\langle \text{angle} \rangle\) is the spiral angle parameter and is stored as a \text{double} (in radians) for versions below 1.8, otherwise is stored as an \text{angle}.

5.5.2. \(\langle \text{distance} \rangle\) is a 64-bit \text{double} representing the spiral distance parameter.

Flow frame data is stored as follows:

\begin{verbatim}
JDR1.0–1.1
\langle \text{type} \rangle \[ \langle \text{border} \rangle \langle \text{label} \rangle \langle \text{pages} \rangle \] \langle \text{top} \rangle \langle \text{bottom} \rangle \langle \text{left} \rangle \langle \text{right} \rangle

JDR1.2
\langle \text{type} \rangle \[ \langle \text{border} \rangle \langle \text{label} \rangle \langle \text{pages} \rangle \] \langle \text{top} \rangle \langle \text{bottom} \rangle \langle \text{left} \rangle \langle \text{right} \rangle \langle \text{shape} \rangle

JDR1.3–1.7
\langle \text{type} \rangle \[ \langle \text{border} \rangle \langle \text{label} \rangle \langle \text{pages} \rangle \] \langle \text{top} \rangle \langle \text{bottom} \rangle \langle \text{left} \rangle \langle \text{right} \rangle \langle \text{shape} \rangle \langle \text{v-align} \rangle

JDR1.8 onwards
\langle \text{type} \rangle \[ \langle \text{border} \rangle \langle \text{label} \rangle \langle \text{pages} \rangle \] \langle \text{top} \rangle \langle \text{bottom} \rangle \langle \text{left} \rangle \langle \text{right} \rangle \langle \text{shape} \rangle \langle \text{v-align} \rangle \langle \text{contents} \rangle \langle \text{even-x-shift} \rangle \langle \text{even-y-shift} \rangle
\end{verbatim}

where:

1. The frame \(\langle \text{type} \rangle\) is stored as a \text{byte}. This may only take one of the following values: 0 (static), 1 (flow), 2 (dynamic) and 3 (typeblock). There should only be one typeblock and this should belong to the outermost implicit group.

2. If \(\langle \text{type} \rangle\) is not equal to 3 (i.e. is not the typeblock), the following information should also be saved:
   2.1. a \text{boolean} value (\langle \text{border} \rangle) indicating whether or not the frame should have a border;
   2.2. the identification label (\langle \text{label} \rangle) stored as a \text{string};
   2.3. the page list (\langle \text{pages} \rangle) should be stored as a \text{string}.

3. The margins \langle \text{top} \rangle, \langle \text{bottom} \rangle, \langle \text{left} \rangle\) and \langle \text{right} \rangle\) are each stored as a \text{float} (in terms of the PostScript point \text{bp}) for versions below 1.8 and are stored as a \text{double} (in terms of the storage unit) otherwise.
4. (Version 1.2 onwards.) If the frame type is either 0 (static frame) or 2 (dynamic frame) \( \langle \text{shape} \rangle \) is a \texttt{byte} indicating the paragraph shape. This may be one of: 0 (standard shape), 1 (use \\texttt{parshape}) or 2 (use \texttt{shapepar}). This value should be omitted if the frame type is 0 or 2.

5. (Version 1.3 onwards.) If the frame type is either 0 (static frame) or 2 (dynamic frame) \( \langle \text{v-align} \rangle \) is a \texttt{byte} that represents the vertical alignment. This may be one of: 0 (top), 1 (centre) or 2 (bottom). This value should be omitted if the frame type is 0 or 2.

6. (Version 1.8 onwards.) If the frame type is either 0 (static frame) or 2 (dynamic frame) \( \langle \text{contents} \rangle \) is a \texttt{string} with the frame’s contents. This may be an empty or null \texttt{string}. This value should be omitted if the frame type is 0 or 2.

7. (Version 1.8 onwards.) The horizontal even page shift \( \langle \text{even-x-shift} \rangle \) is stored as a \texttt{double}.

8. (Version 1.8 onwards.) The vertical even page shift \( \langle \text{even-y-shift} \rangle \) is stored as a \texttt{double}. This value is omitted for the typeblock (type 3).
B Multilingual Support

All the language dependent information is stored in the `lib/resources` subdirectory of the installation directory. If you want all the menus, tooltips etc in another language, you will need to translate the dictionary file (found in `lib/resources/dictionaries/`). This has a `⟨key⟩=⟨value⟩` format. Only the `⟨value⟩` text should be translated. Note that each `⟨key⟩=⟨value⟩` pair must be contained on a single line, so if `⟨value⟩` contains a lot of text, take care if your text editor likes to break lines automatically. Some of the values contain \1, \2, etc. These represent values that are substituted at runtime. The sequence \n indicates a line break needs to be inserted when displaying the string at runtime. (This only works if the text is used in a multi-line component.)

There are three keys (`about.translator`, `about.translator_info` and `about.translator.url`) which can be used to identify yourself as the translator. If the `about.translator` value is set, the information will be displayed in the Help → About dialog box.

The dictionary file should be named `flowframtk-⟨language⟩-⟨country⟩.prop` or `flowframtk-⟨language⟩.prop` (where `⟨country⟩` is an ISO-2 country identifier and `⟨language⟩` is an ISO-2 language identifier) and save it in the `resources/dictionaries/` subdirectory of FlowframTk’s installation directory. The easiest way to create this file is to copy an existing resource file, for example `flowframtk-en-GB.prop`, and replace all the text to the right of the equal signs. You will also need to add a line to the `resources/encodings.prop` file that specifies the file encoding. If you want to add your translation to the next version of FlowframTk, that’s great, but this can only be done if you assign a licence that’s compatible with FlowframTk’s licence. If you want to translate the manual, you need to download FlowframTk’s source code and create an alternative to the `flowframtk-en-GB.tex` or `flowframtk-en-US.tex` documents.

See also:

- §4 Language Settings
C  Source Code

The source code is contained in the file `flowframtk-0.8.4-src.zip`, which is available from [http://www.dickimaw-books.com/software/flowframtk/](http://www.dickimaw-books.com/software/flowframtk/). The source code was written and tested running under Linux. Some of the helper scripts may not run on other operating systems. This archive contains the following directories:

- `flowframtk-0.8.4/bin` scripts that load the required jar files into Java
- `flowframtk-0.8.4/doc` documentation
- `flowframtk-0.8.4/lib` required Java libraries
- `flowframtk-0.8.4/src` the Java source code.
- `flowframtk-0.8.4/examples` example images

In addition, the archive also contains the following files:

- **README** important information about this distribution. Read this file before you try to compile the source.
- **BUGS** list of known bugs
- **Makefile** main makefile. Run “make all” to make all the applications
- **icons** application icons.
- **CHANGES** change log

The documentation was written in \LaTeX, but shares the dictionary resource files (`flowframtk-⟨lang⟩.prop`) used by FlowframTk to ensure that the documentation uses the correct menu and dialog labels. In addition, the Java code relies on the \LaTeX documentation to provide the files required by the helpset (via \LaTeX2HTML and some helper Perl scripts). The labels used in the \LaTeX source are also used in the Java code to identify the context dependent information required by the help buttons in many of the dialog boxes.

C.1  Java Source

Requirements:

- [JavaHelp](http://java.sun.com/products/javahelp/)

The Java source is contained in subdirectories of `flowframtk-0.8.4/src`:

- `flowframtk/src/jdr/` This contains the source code for `jdr.jar`. This deals with all the information that constitutes an image as well as methods to save and load images. The code that deals with parsing PostScript code (used by `eps2jdr`) is still experimental.
flowframtk/src/jdrresources
This contains the source code for jdrresources.jar. This deals with application resources (such as the dictionary).

flowframtk/src/flowframtk
This contains the source code for flowframtk.jar. This deals with the GUI part of FlowframTk.

flowframtk/src/jdrview
This contains the source code for jdrview.jar. This deals with the GUI part of Jdrview.

flowframtk/src/jdrinfo
This contains the source code for jdrinfo.jar. I wrote this to detect the file format version numbers for my sample JDR/AJR files.

flowframtk/src/*2*
These directories contain the source code for the command line converters that together form jdrutils.

C.2 \LaTeX Source

The \LaTeX source is contained in flowframtk-0.8.4-src/doc/manual The manual is currently only available in English. The manual requires the file flowframtk-0.8.4/doc/version.tex which is created by the main makefile flowframtk-0.8.4/Makefile. If you are not using make, you will need to create this file, which should simply contain the line:

\version{0.8.4}

The documentation consists of the following files:

Makefile The documentation makefile. Just running “make” will make the PDF version and the Java helpset.

Makefile-lang Creates the documentation for either en-GB or en-US, depending on the value of the environment variable APPLANG.

flowframtk-main.tex The main contents of the manual for FlowframTk (i.e. this document).

flowframtk-⟨lang⟩.tex The driver files (containing the \documentclass command) for the FlowframTk manual.

accelerators.tex The contents of Table 2.1. This file is input by flowframtk-main.tex.

preamble.tex The main bulk of the preamble for flowframtk-main.tex and jdrview-main.tex.

jdrview-main.tex The main contents of the manual for Jdrview.

jdrview-⟨lang⟩.tex The driver files (containing the \documentclass command) for the Jdrview manual.
jdrutils-main.tex The main contents of the manual for the command line converters, such as jdr2tex.

jdrutils-{lang}.tex The driver files (containing the \documentclass command) for the jdrutils manual.

flowframtk.sty Style file used by the documentation.

transdict.pl This is a Perl script that converts the dictionary file to a file that \TeX can parse (dictionary-{lang}.tex).

flowframtk.perl This is the \TeX2HTML version of flowframtk.sty. This also creates temporary files used by makehelpset to assist generating the helpset. Note that flowframtk.sty loads the glossaries package, but flowframtk.perl doesn’t load the equivalent glossaries.perl as flowframtk.perl uses popup windows to display the glossary terms instead of linking them to the glossary section.

fixpaths This removes the path names to the images used by the HTML files that form the helpset. This is needed as the HTML files and the images are moved to a different location.

makehelpset This is a Perl script that assists making the helpset. It uses the files generated by flowframtk.perl to create the map and index files required by the JavaHelp utility jhindexer.

Makefile.jhindexer The Makefile used to generate the helpset.

images-{lang}/ Images specific to this particular language set. Images used by both US and UK manuals are stored in ../sharedimages/
D  Troubleshooting

1. My settings aren’t remembered.
   Check which option is selected in the Startup Settings tab of the Configure Image Settings dialog. This should be set to Use settings from previous instance if you want the settings remembered from the last time you quit the application. Also check the When loading option in the JDR/AJR Settings tab. If this is set to Apply all settings stored in the file then any settings stored in an image that you load will override the current settings.

2. Sometimes the canvas doesn’t get correctly redrawn after I’ve loaded an image from a file.
   This is a known bug. Use F11 to force a redraw.

3. Sometimes lines don’t show up.
   If you have a thin line and the magnification is small or you have low resolution, the line may be too thin to show up on your display. Try either using a thicker line style or increasing the magnification.

4. When I try clicking on the canvas to add a new point, nothing happens.
   Make sure that you are actually clicking and not dragging. (Some touch sensitive mouse pads can mistake a click for a move or drag.) Make sure that you have selected the correct tool.

5. I tried to select and drag a point, but another point moved.
   When you select the new point, make sure it’s highlighted before you try dragging it. The click to select operation is separate to the drag operation.

6. I tried changing the line/text style but nothing happened.
   Remember to use the Edit → Path and Edit → Text submenus to change the styles for existing objects, and use Settings → Styles for all subsequent new objects.

7. I tried to create a package based on the flowfram package, but it didn’t define some (or all) of my frames.
   Remember to identify each object as a flow frame, a dynamic frame or a static frame. Any object that hasn’t been thus identified will not be written to the sty file.

8. When I exported to a package or class, flowfram complained the option “hide” or “hidethis” isn’t available.
   Upgrade to at least version 1.16 of the flowframtk package.

9. When I exported to a package or class, flowfram complained that I couldn’t use \Shapepar.
   Upgrade to at least version 1.16 of the flowframtk package.

10. I got an error that \Shapepar isn’t defined.
    Upgrade to the latest version of the shapepar package.
11. I get an error when I try to \LaTeX\ a \texttt{pgfpicture} environment created by FlowframTk. Remember to include the \texttt{pgf} package. FlowframTk was tested using version 3.0 of the \texttt{pgf} package. It may not work with earlier versions.

\section*{D.1 Known Bugs}

If for some reason you are unable to access the save dialog box, you can do an emergency save by pressing F11. This will save all currently open images to a subdirectory in the configuration directory. (This works for most, but not all windows used by FlowframTk.)

1. Occasionally bits of the screen don’t get repainted. Use F11 to force a redraw.

2. Occasionally the message window doesn’t automatically close when there are no new warning messages.

3. Occasionally the \texttt{java.awt.*} or \texttt{javax.swing.*} classes throw a Null-PointerException.
Bibliography


**Glossary**

**AJR**
FlowframTk’s native ASCII format. Files in this format should have the extension .ajr. This format is primarily provided to assist conversion to and from JDR files or for version control. 1, 5, 8, 16, 48, 50, 55, 67, 71, 258, 266

**backmost object**
The first object to be painted on the canvas. 4, 5, 70, 90, 107–109, 112, 113

**bitmap**
A raster graphics image. 17, 30, 48, 67, 86, 88, 122, 163, 186, 267, 275

**bounding box**
The smallest rectangle that encompasses the object. 28, 30, 70, 93, 94, 99, 101, 138

**bp**
\(\text{T}_{\text{E}}\text{X}'s \text{‘big point’}. \text{This is the same as a PostScript point.} \ 72bp = 1\text{in.} \ 9, 37, 57, 122, 128, 136, 153, 239, 260, 261, 263, 268, 269, 272, 273, 277–279

**canvas**
The white area on which you construct your picture. 1, 4, 9, 11, 12, 14, 16, 20, 23, 28, 35, 37, 39, 45–48, 50–53, 55, 57, 61–63, 67, 70, 71, 74, 142, 150, 152, 158, 190, 194, 199, 218, 225, 235, 274

**checkbox**
A GUI element with two states: on (true) and off (false). 20–23, 33, 67, 101, 128, 134, 140, 141, 251

**click**
Press and release a mouse button. If the button isn’t specified, assume the primary button. 2, 11, 12, 23, 25, 33, 38, 47, 60, 61, 70, 73

**combo box**
A GUI element similar to a drop-down list, but can be edited if the required value is not in the list. 140, 142, 163

**composite shape**
A shape that is described by an underlying shape and a means of transforming it, such as apply symmetry or replicas. 28, 86, 99, 275, 276

**construction mode**
Any of the tools except the select tool. 4, 57
control point
The points that define a path. Line segments and gaps have two control points, at the start and end, cubic Bézier segments have four control points: one at the start of the segment, one at the end of the segment, and two others that define the curvature of the segment. Adjacent segments share a common control point. When a path is under construction, or is being edited, the control points are shown as orange or red squares. Composite paths also have control points that govern how the full path is created from the underlying shape. The composite control points are coloured differently to the standard path controls. 1, 3–5, 11, 14, 16, 28, 59, 60, 73–75, 78, 80, 84, 99, 103, 118, 122, 171, 172, 180, 251, 253, 254, 257, 265

control point index
Each control point defining a given path or composite shape has an index relative to the initial control point (at the start of the path). Use F6 (in edit path mode) to cycle through the points in increasing order of index. 73

double-click
Press and release the mouse button twice in rapid succession. If no button is specified, assume the primary button. 2, 11, 12, 14, 25, 33, 46, 47, 57, 59, 60, 70

drop-down list
A GUI element that allows a user to choose one value from a list. When inactive, it only displays the selected value. When activated (usually by pressing an arrow button to on one side) it displays a list of all available values from which the user can select the required value. 3, 19, 26, 39, 139–142, 161, 163–165, 170, 173, 176, 192, 240, 242, 250

frontmost object
The last object to be painted on the canvas. 4, 5, 70, 89, 245

grid
Tick marks located at regular intervals on the canvas. The grid can be locked so that new points will be placed at the tick nearest the specified position. 4, 8, 11, 73

group
A collection of objects treated as a single entity. 5, 22, 70, 72, 73, 83, 90, 93, 94, 101, 122, 124, 126, 165, 266, 267

Java
A platform-independent object-orientated language. 1

JavaHelp
An optional package of the JRE enabling applications to use a native browser to display help topics. 3, 282, 284
JDR

FlowframTk’s native binary format. Files in this format should have the extension .jdr. 1, 5, 8, 9, 16, 48, 50, 55, 67, 71, 258, 266

menu-click

Click the mouse button that activates context-menus. This depends on your mouse configuration. For example, this is typically the right button on a two-button right-handed mouse, but may be the left button on a left-handed mouse or the middle button on three button mouse. 2, 12, 27, 47, 63, 70, 150

object

A path, text area, text-path, bitmap or group. 4–6, 12, 14, 20, 28, 30, 46, 51, 70–73, 83, 89–91, 93, 94, 96, 98, 99, 101, 103, 105, 161, 163–165, 167, 225, 266, 267, 285

path


path attributes

The line colour, fill colour and line styles for the path. 57

pattern

A composite shape formed by repeatedly applying a given transformation on a shape. Each pattern has a specified number of replicas. The underlying shape may or may not be visible. The pattern mode determines whether the underlying path and replicas are drawn in one go (single mode) or whether they are drawn independently of each other (multi-mode). Transformations (rotating, scaling and shearing) are applied to the path not to the text. 96, 103, 108, 109, 112, 113, 122, 251, 276

popup menu

A menu whose items vary depending on the context. These menus are usually invoked with the menu or secondary mouse button. In FlowframTk it is also possible to invoke popup menus using F3 or your keyboard may have a context-menu key. 63, 70, 72–74, 78, 83, 150, 171, 180, 218, 247

primary-click

Click the primary mouse button. This depends on your mouse configuration. For example, this is typically the left button on a two-button right-handed mouse, but may be the right button on a left-handed mouse. 2, 4, 11, 59–62, 70, 71

pt

\(\text{T}_{\text{E}}\text{X}'s\ point.\ Not\ to\ be\ confused\ with\ bp\ (a\ PostScript\ point).\ 72.27\text{pt}=1\text{in}.\ 9, 19, 141, 155, 159, 175, 192, 215, 218, 225, 235, 260, 263\)
raster graphics
Representing images as a collection of pixels. Also called a bitmap. 67, 72

recto
the “front” side of a leaf of paper (the right or odd-numbered page). 12, 167, 168, 215

rotational pattern
A pattern where the replicas are created by rotating the underlying path. In addition to the control points defining the underlying shape, rotational patterns also have a control point that governs the point of rotation. 168, 267, 278

rulers
The two panels containing the horizontal and vertical rulers. 9, 11, 35, 46, 262

scaled pattern
A pattern where the replicas are created by scaling the underlying path. In addition to the control points defining the underlying shape, scaled patterns also have two control points governing the scale anchor and the scale direction. 267, 278

shape
Either a path, text-path or a composite shape. 74, 78, 88, 103, 108, 109, 112, 113, 122, 254

spiral pattern
A pattern where the replicas are created by rotating and translating the underlying path so that the replicas are aligned along a spiral. In addition to the control points defining the underlying shape, spiral patterns also have two control points that govern the anchor and offset. 267, 278

stacking order
The order in which objects are painted on the canvas. To determine the reverse stacking order, deselect all objects, then use F6 to cycle through the stack starting from the frontmost object. Reverse this list to obtain the stacking order. Note that the frontmost object is the last object in the stack, not the first. 4–6, 70, 89, 90, 99, 103, 105, 107, 158, 183, 245, 249, 250, 257

status bar
The status bar is the horizontal panel positioned along the bottom of FlowframTk’s main window. 9, 11, 14, 35, 47

storage unit
The length unit used when storing co-ordinates. The default unit is bp (PostScript point) but may be changed in the configuration dialog. 14, 78, 142, 192, 218, 239, 240, 260, 261

symmetric shape
A composite shape that is formed by the underlying shape added to its reflection in a line a symmetry. Depending on how it’s created, the symmetric shape may
be drawn as a single shape, or the underlying shape and its reflection may be drawn independently of each other. The line of symmetry has two control points that can be adjusted to change the overall shape. 84, 168, 251, 267, 275, 277

text area
An object consisting of a single line of text. The text may be moved, scaled, rotated, sheared or converted to a path. 3, 11, 19, 20, 22, 23, 46, 48, 52, 53, 57, 61–63, 71, 72, 80, 83, 84, 86, 88, 90, 91, 93, 96, 101, 103, 114, 122, 124, 126, 127, 138–143, 146, 149, 150, 152, 163, 177–179, 247, 249–251, 266, 267, 273

text-path
A composite object formed by combining a path and a text area to create a text along a path effect. The underlying path is only visible when editing the text-path object using the edit path function. Transformations (rotating, scaling and shearing) are applied to the path not to the text. 23, 52, 53, 57, 73, 74, 78, 80, 83, 84, 86, 90, 91, 93, 96, 103, 105, 108, 112–114, 118, 122, 124, 126, 127, 139, 140, 142, 143, 149, 267, 269, 276

toolbars
The two panels containing buttons, the horizontal toolbar is positioned at the top of FlowframTk’s main window, the vertical toolbar is positioned along the left edge of the main window. 8, 9, 35, 46, 57, 99

vector graphics
A means of describing images through the use of points, lines and curves. 1, 67

verso
the “back” side of a leaf of paper (the left or even-numbered page). 12, 159, 161, 167, 168, 215
Abbreviations

**Graphical user interface (GUI)**
An application with windows and buttons in which the user can point and click with the mouse. 1, 39, 283

**Java Standard Edition SDK (JDK)**
A development environment for building applications, applets and components using the Java programming language. 282

**Java Runtime Environment (JRE)**
Allows end-users to run Java applications. The JRE can be downloaded from http://java.sun.com/j2se/. 1, 2, 8, 48, 67

**Java Virtual Machine (JVM)**
Also known as the Java Runtime Environment. 8

**Multiple-document interface (MDI)**
A main (parent) window containing child windows allowing you to process several documents in parallel. 45

**Scalable vector graphics (SVG)**
A Modularized language for describing two-dimensional vector and mixed vector/raster graphics in XML. 1, 17, 20, 50, 52, 69